CHDK für SX20

Sx, Sxx, Sxxx, SX1, SXxx, SX1xx, SX2xx, SX4xx, SX5xx, SX6xx, SX7xx

Re: CHDK für SX20

Beitragvon f_m_b » 11.04.2011, 23:02

Werner_O hat geschrieben:So, ich habe eben meine Kamera zurückbekommen und meine geänderte "german.lng" selber testen können.

:-). msl hat sich unser angenommen und den Text angepasst, nicht ganz so wie Dein oder mein Vorschlag, aber irgendwie doch gelungen.
Lass Dich überraschen...

msl hat geschrieben:Dabei ist konstruktive Kritik immer willkommen. Das gilt auch für innovative Verbesserungsvorschläge und kreative Nutzung. Das Forum besteht aber in letzter Zeit fast nur noch aus Beiträgen wie: bei Kamera x funktioniert Funktion y oder Skript z nicht, wann kommt Abhilfe (überspitzte Zusammenfassung!).

Ich fürchte das ist der Weg von c"H"dk wie Hack zu c"S"dk wie Serie. CHDK hat einen Qualitätsstand erlangt, der weit weg von einem Feldtest ist und damit sind eben auch die Erwartungen gestiegen. Das Publikum ist zwar größer geworden, aber vielen reichen die per Standard vorgegebenen Funktionen und haben wenig Interesse weiter und tiefer vorzudringen.

msl hat geschrieben:Ganz zu schweigen von Unterstützungen, wenn z.B. zu einer bestimmten Sache ein Testaufruf erfolgt.

Das finde ich auch sehr traurig.:-(
Die SX20 war leider nie sehr aktiv besucht, ich denke nur an die Portierung derselben, wenn es "damals" nur wenigstens einen Anwender gegeben hätte der die 1.00f mit getestet hätte wären heute alle drei Firmwareversionen (ohne großen Mehraufwand) im stabilen Zustand.

Ich bin sehr froh, dass ich hier nicht alleine auf der Forumseite meine kleinen spärlichen Erfolge niederschreibe. Solange es ebenfalls motivierte Tester gibt wie z.B. Werner (Vielen Dank =D> ) macht es gleich doppelt so viel Spaß ein Problem oder eine Erweiterung anzugehen.

Die Zeit und der Aufwand, der hier von allen "aktiven" auf sich genommen wird ist mehr als bewundernswert. =D> =D> =D>

msl hat geschrieben:Innovation sind da eher Mangelware.

Ein schönes Besispiel, dass es dennoch weiter geht...
Wir sind im Land von Milch und Honig angekommen. Aus wenig und knapp wird viel und reichlich. Die Zeiten des Speichermangels der SX20 und anderen ebenfalls betroffenen Kameras sind gezählt.

Das Thema bringt die Kamera einen riesig großen Schritt vorwärts. Mit dieser Änderung gibt es nicht mehr die Frage: Wenn ich Funktion A auf der Kamera verwenden möchte muss ich auf Funktion B verzichten...
Wir haben ganze 2MB Arbeitsspeicher für CHDK zur Verfügung, ohne den jetzigen Speicher überhaupt anzugreifen. (Ich hatte auch bereits positive Tests mit 4MB gemacht. Aber nicht gleich übermütig werden. ;-) )
Wer mehr darüber erfahren möchte kann sich unter Link1 oder Link2 etwas einlesen und natürlich auch gerne dort seine Kommentare, Wünsche, Anregungen loswerden.

Arbeiten am Speicher sind immer mit etwas mehr Risiko behaftet als andere Änderungen.
Deshalb benötigen wir auch etwas mehr Testaufwand als sonst.

Vorgehensweise:
Als erstes installiert/kopiert Ihr Euch die CHDK-Version "Basiert auf CHDK-626 (x.xxx). Erweiterter Speicher aktiv. Testbetrieb!!!"
Diese Version hat keine Spiele, Kalender, ...
Dort wird der "erweiterte" Speicher zwar angelegt, aber noch nicht verwendet. Es erfolgt nur eine Überprüfung ob die original Canon-Firmware Bereiche aus diesem angelegten Speicher verwendet.
Falls alles in Ordnung ist, seht Ihr in der unteren linken Ecke ein ok.

Der erste Test besteht darin, möglichst viele original Funktionen der Kamera auszuführen. Video-Filme zu drehen, Serienbildfolgen, Pano... Kurzum alles was Euch einfällt und die Kamera stresst.
Sollte das ok am unteren linken Rand einmal durch 4 Adressen ersetzt werden gab es einen Speicherkonflikt und hätte ohne Testbetrieb die Kamera mit großer Wahrscheinlichkeit zum Absturz gebracht.
Sollten diese Adressen auftauchen, bitte aufschreiben und mir durchgeben. Falls die Kamera überhaupt nicht damit läuft meldet Euch ebenfalls.
Falls Ihr die Kamera so richtig durch die fotografische "Mangel" gedreht habt und unten links immer ok steht...
...geht es weiter mit dem zweiten Teil:

Installiert/kopiert jetzt die CHDK-DE Version "Basiert auf CHDK-626 (x.xxx). Erweiterter Speicher aktiv. Realbetrieb!!!"
(Schaut mal auf die Speicheranzeige. :-) ) Diese Version hat übrigens alles an optionalen Compiler-Funktionen was CHDK so mitbringt, also das volle Programm. :-D
Der nächste Test besteht darin die Kamera mit CHDK-Features zu stressen, also Zebra (übrigens gepuffert, merkt jemand den Unterschied?), Histogramm, Kanten, PTP, Skripte alles was Euch so einfällt.

Ich habe die Firmware 1.02b schon ziemlich "gequält" und bislang nur Verbesserungen erfahren. Was als nächstes noch ansteht ist ein ausführlicher Test der neuen PTP-Version.
Aber: Falls jemand ebenfalls eine 1.02b besitzt... 4 Augen sehen mehr als 2. ;-)

So und jetzt habe ich genug geschrieben (und werde im Bett verschwinden, der morgige Tag beginnt früh und endet späääät ;-) )

und wünsche viel Spaß beim Testen...


EDIT 15.04.2011 22:13:
Ich hatte bei Firmware 1.00f eine Datei nicht mit geändert...
Neuer Versuch.
"Basiert auf CHDK-626 (1.00f). Erweiterter Speicher aktiv. Testbetrieb!!!" gelöscht
"Basiert auf CHDK-626 (1.00f). Erweiterter Speicher aktiv. Realbetrieb!!!" gelöscht

"Basiert auf CHDK-629 (1.00f). Erweiterter Speicher aktiv. Testbetrieb!!!" hinzugefügt.
"Basiert auf CHDK-629 (1.00f). Erweiterter Speicher aktiv. Realbetrieb!!!" hinzugefügt.
Dateianhänge
sx20-100f-1.1.0-629-full.zip
Basiert auf CHDK-629 (1.00f). Erweiterter Speicher aktiv. Realbetrieb!!!
(390.5 KiB) 215-mal heruntergeladen
sx20-100f-1.1.0-629-full.zip
Basiert auf CHDK-629 (1.00f). Erweiterter Speicher aktiv. Testbetrieb!!!
(289.12 KiB) 191-mal heruntergeladen
sx20-102b-1.1.0-626-full.zip
Basiert auf CHDK-626 (1.02b). Erweiterter Speicher aktiv. Testbetrieb!!!
(374.13 KiB) 196-mal heruntergeladen
sx20-102d-1.1.0-626-full.zip
Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Testbetrieb!!!
(373.96 KiB) 192-mal heruntergeladen
sx20-102b-1.1.0-626-full.zip
Basiert auf CHDK-626 (1.02b). Erweiterter Speicher aktiv. Realbetrieb!!!
(394.68 KiB) 204-mal heruntergeladen
sx20-102d-1.1.0-626-full.zip
Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Realbetrieb!!!
(394.76 KiB) 208-mal heruntergeladen
Zuletzt geändert von f_m_b am 15.04.2011, 21:29, insgesamt 1-mal geändert.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 11.04.2011, 23:30

Hallo zusammen,

Ich habe eben mal kurz die aktuelle sx20-102d-1.1.0-full_rev_626 getestet und bin ehrlich gesagt alles andere als begeistert davon :-(

Auf die Schnelle möchte ich hier nur zwei Sachen zu v626 erwähnen:
1) Bisher hat ein längerer Druck auf die On/Off-Taste die SX20IS immer im Aufnahmemodus gestartet.
Mit v626 geht meine Kamera dabei aber reproduzierbar sehr oft sofort wieder aus (sprich schaltet sich sofort wieder ab).
Nur der einfache kurze Druck auf die On/Off-Taste funktioniert anscheinend problemlos, wobei dann die SX20IS natürlich im Wiedergabemodus startet.
2) Auch hat sich die Anzeige der Einstellparameter im CHDK-Menü geändert:
Bisher wurden zu lange Einträge schlichtweg gekürzt, mit v626 erscheinen nun aber teilweise Artefakte abgeschnittener alphanumerischer Zeichen, was die Lesbarkeit deutlich verschlechtert.

Mehr habe ich heute leider noch nicht testen können, weil ich jetzt ins Bett muß.

Schlagt mich aber bitte nicht tot, nur weil ich hier Kritik an einer neueren CHDK-Version geäußert habe!
Ich als reiner CHDK-Tester MUSS aber diese ersten negativen Erfahrungen bezüglich v626 hier posten, damit diese Probleme anschließend von entsprechend kompetenten Leuten aus diesem Forum geklärt werden können.

Liebe Grüße
Werner
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1027
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 12.04.2011, 06:01

Danke für den späten/frühen Test und die ersten Eindrücke.
Melde bitte alles was Dir auffällt. :-)

Erst mal bin ich sehr froh, dass die Version bereits hochläuft, dass bedeutet ich habe vermutlich die richtigen Adressen für 1.02d gefunden. :-)

zu 1)
Es tut mir leid, dass dieser Effekt jetzt gerade bei Dir auftaucht. Das Problem das Du beschreibst hat leider nichts mit der Version 626 direkt zu tun, sondern ist ein alter Bekannter, den ich immer mal wieder sporadisch treffe. Scheint ein zeitliches Problem zu sein. Ich habe den Punkt bereits auf meiner TODO-Liste. Bernd_R hat im internationalen CHDK SX20-Forum bereits einen "Sleep-Patch" der das Problem entschärft. Bin aber leider noch nicht dazugekommen mir das etwas genauer anzuschauen.
Ich hatte einmal sogar das Problem im Urlaub, dass eine vorher gut getestete Version einfach nicht mehr "anspringen" wollte... Ich musste dann für den ganzen Urlaub auf CHDK verzichten. Auf die andere Partition konnte ich ohne CHDK auch nicht springen... und mir blieb nur noch der Ausweg den Schreibschutzschalter auf "schreibend" umzulegen und die Kamera in Ihrer ganzen Originalität zu verwenden.

zu 2) schaue ich mir heute abend noch etwas genauer an... Kann aber spät werden.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 12.04.2011, 14:41

Hallo zusammen,

ich habe eben einige Tests mit v626 durchgeführt.

Werner_O hatte geschrieben:
Nur der einfache kurze Druck auf die On/Off-Taste funktioniert anscheinend problemlos

Das stimmt leider nicht, auch dabei (wie auch per Starten per Wiedergabetaste) kann die SX20IS anschließend sofort wieder ausgehen :-(
Das nur Info - das Problem ist ja laut f_m_b bereits bekannt und in Arbeit.

Bisher habe ich v626 aber immer irgendwie nach mehreren Anläufen (bisher waren max. 8 Anläufe nötig) starten können.
Das Starten im Wiedergabemodus (insbesondere mit der Wiedergabetaste) scheint aber statistisch gesehen z.Zt. die beste Wahl.

Ich habe inzwischen schon mal einige CHDK-Einstellungen ausprobiert mit durchweg positiven Ergebnissen
(OK bedeutet dabei volle Funktionalität wie bei bisher als stabil geltenden Versionen):

1) Die OSD-Einstellungen modifizieren und persönlich anpassen - OK
2) Den OSD-Layouteditor verwenden und persönlich anpassen - OK
3) Ersetze "Fine" durch "Superfine" bei JPGs - OK
4) Speichere RAW bzw. DNG in JPG-Ordner - OK
5) Speichere RAW als DNG - OK
6) HD-Movie-Aufnahme bei Videomodus "Default" und Videoqualität "99" inkl. Zoomen (auf einer Class10 SDHC-Card) - im Prinzip OK, bei 5 gemachten Test-Movies allerdings 1x Abbrechen der Aufnahme während des Zoomens (was aber nicht zwangsläufig mit v626 zusammenhängen muß)
7) Tauschen der Partition (auf meiner 8GB-Card mit zwei Partitionen) - OK
8) Aufnahmen in verschiedenen Canon-Modi mit jeweils den Varianten "Speichere RAW deaktiviert", "Speichere RAW aktiviert" und "Speichere RAW als DNG":
Modus "Auto" - OK
Modus "P" - OK
Modus "TV" - OK
Modus "AV" - OK
Modus "M" - OK

Aus meiner Sicht sieht das mit v626 ja eigentlich recht gut aus :-)))
Jetzt müssen nur noch die Startprobleme behoben sowie zusätzlich geklärt werden, warum bisher abgeschnittene Buchstaben im CHDK-Menü jetzt noch teilweise als störende Rest-Artefakte angezeigt werden.

Bezüglich "Zebra" habe ich aber nichts getestet weil ich davon keine Ahnung habe, ebenso habe ich keine Scripts ausprobiert.
Eine neue "badpixel.bin" habe ich aber erstellen können.

P.S. @f_m_b:
Bei v608 hattest Du ja ein Zusatzfeature eingebaut ("Zeige Partitionsnummer"), welches überaus nützlich ist.
Wann geht das "in Serie..." ?
Einmal daran gewöhnt, möchte man das nicht mehr missen wollen.

Soviel zunächst von mir,
liebe Grüße
Werner

(SX20IS 1.0.2.d)
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1027
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 12.04.2011, 23:02

Werner_O hat geschrieben:ich habe eben einige Tests mit v626 durchgeführt.

Hallo Werner
erst mal Danke fürn den ausführlichen Test.
Ich befürchte nur, dass ich das Testszenario nicht richtig beschreiben konnte...
Meine Änderungen sind nicht ganz ohne Risiko... Deshalb habe ich die Versionen erst mal lokal übersetzt und als Anhang in den Beitrag gestellt.
Revision 626 habe ich hierfür als Basis verwendet.
D.h. leider, dass Du zwar die Version ausgibigst getestet hast, allerdings ohne meine lokalen Änderungen.
Sorry, dass ich mich nicht exakt genug erklärt habe und es zu dem Missverständnis gekommen ist.
Wenn Du also noch Lust hast, müsstest Du die Datei "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Testbetrieb!!" herunterladen, entpacken und auf Deine SD-Karte spielen und den Test wiederholen. Dabei ist es wichtig, dass Du möglichst viele kamerainterne Funktionen verwendest (Hattest Du ja auch bereits gemacht :-) ).
Wie beschrieben sollte mit dieser lokal von mir erweiterten Version in der unteren linken Ecke ein (ok) eingeblendet werden.
Wenn nach Deinem Test das (ok) immer noch da steht und keine kryptischen Zahlen hat der erste Test funktioniert und es geht in die zweite Runde:

Dann heißt es die Datei "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Realbetrieb!!" herunterladen, entpacken und auf die SD-Karte bringen.
Erster Test ist dann "Miscellaneous Stuff ->Show Memory Info" aufrufen und Free Memory steht ca. bei 1,8MB. :-)
Das wäre, falls der Test ebenfalls ok ist, die Version die in die "Serie" einfließt. Bei diesem Test ist vor allem wichtig CHDK Funktionen zu verwenden. (übrigens: Mit "Zebra Parameters -> Draw Zebra" kannst Du in der Vorschau bereits sehen welche Bildteile über/unterbelichet sind. Der Name kommt vermutlich daher, dass diese Bereiche gestreift angezeigt werden. ;-) )

Werner_O hat geschrieben:P.S. @f_m_b:
Bei v608 hattest Du ja ein Zusatzfeature eingebaut ("Zeige Partitionsnummer"), welches überaus nützlich ist.
Wann geht das "in Serie..." ?
Einmal daran gewöhnt, möchte man das nicht mehr missen wollen.


Ich möchte es auch nicht mehr missen. ;-) (In der lokalen Version übrigens auch wieder enthalten. ;-))
Ich möchte mich momentan nicht "verzetteln" und erst mal die Geschichte mit dem erweiterten Speicher und den Tests mit der neuen PTP-Versionen abschließen.

Da dies ein allgemeines Thema ist und nicht nur die SX20 betrifft möchte ich ein wenig Diskussion und andere Kameratypen mit ins Boot bringen.
Eine der nächsten Punkte ist dann etwas Prosa zu schreiben und meine Änderungen der Allgemeinheit zu präsentieren.
Vielleicht etwas Lob, Tadel, vieleicht die eine oder andere Diskussion, Erweiterungsvorschläge erleben und wenn dann mehrere Benutzer (auch von anderen Kameratypen) Bedarf sehen und sich genügend Tester gefunden haben...
erfolgt nach Abstimmung mit den Administratoren die Übernahme in die CHDK-"Serie".
Ein mühsamer aber notwendiger Prozess. :-)

Werner_O hat geschrieben:... warum bisher abgeschnittene Buchstaben im CHDK-Menü jetzt noch teilweise als störende Rest-Artefakte angezeigt werden.

Ich denke die Änderung is tdurch eine Übernahme einer Funktionalität aus dem internationalen CHDK hereingekommen.
Ich werde bei Gelegenheit etwas experimentieren.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 13.04.2011, 18:28

Hallo f_m_b,

sorry, daß ich das total verpeilt hatte - mea culpa (wer lesen kann ist klar im Vorteil...).

Die "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Testbetrieb!" habe ich heute mal recht ausführlich getestet mit Schwerpunkt auf die kamerainternen Aufnahme-Funktionen.

Getestet habe ich dabei:
1) Alle Programme inkl. aller Szenenprogramme
2) Die verschiedenen Selbstauslöser
3) Diverse Blitzsteuerungseinstellungen inkl. Blitzaufnahmen
4) Movie-Aufnahmen in allen 3 möglichen Videoauflösüngen
5) Verschiedene AF- und IS-Einstellungen sowie Serien-Aufnahmen mit/ohne Servo-AF
6) Verschiedene Belichtungsmessmethoden
7I Die ISO- und Makro-Einstellungen sowie den MF bei Bildern/Movies
8) 3er-Serienaufnahmen mit +/- 1 EV
9) 3er-Serienaufnahmen mit verschiedenen Fokusebenen (dafür war ich aber anscheinend zu doof - siehe weiter unten)
10) Das Canon-Histogramm bereits bei Aufnahmen anzeigen lassen

Das erfreuliche Resultat: Immer "OK" unten links :-)

Ich habe aber in den drei Stunden natürlich nicht wirklich SÄMTLICHE Einstellungen bzw. Einstellungskombinationen testen können...
Anspruch auf Vollständigkeit kann ich darum auch nicht erheben.

Die "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Realbetrieb!!" kann ich erst frühestens morgen testen - für heute reicht es mir ;-)

@Alle:
Die 3er-Serienaufnahmen mit verschiedenen Fokusebenen bekomme ich leider weder mit noch ohne CHDK hin - meine 1.0.2.d macht da immer nur ein Bild. Die recht kurze Beschreibung dazu im SX20IS-Handbuch hilft mir dabei auch nicht wirklich weiter.
Geht das bei euren SX20IS und wenn ja, was muß dabei besonders beachtet werden (etwa Stativ oder Mindest-Entfernung nötig etc.)?
Wäre für jeden Rat dazu dankbar, weil ich diesbezüglich einfach nicht weiterkomme.

Liebe Grüße
Werner

(1.0.2.d)
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1027
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 13.04.2011, 23:14

Werner_O hat geschrieben:Hallo f_m_b,
sorry, daß ich das total verpeilt hatte - mea culpa (wer lesen kann ist klar im Vorteil...).

Kein Problem, es hätte auch an mir liegen können, da ich die Artikel meist zu später Stunde schreibe.
Da kann es schon passieren, dass die Klarheit meiner Gedanken nicht ganz im Text wieder zu erkennen sind. ;-)

Werner_O hat geschrieben:Die "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Testbetrieb!" habe ich heute mal recht ausführlich getestet mit Schwerpunkt auf die kamerainternen Aufnahme-Funktionen.

Getestet habe ich dabei:
1) Alle Programme inkl. aller Szenenprogramme
2) Die verschiedenen Selbstauslöser
3) Diverse Blitzsteuerungseinstellungen inkl. Blitzaufnahmen
4) Movie-Aufnahmen in allen 3 möglichen Videoauflösüngen
5) Verschiedene AF- und IS-Einstellungen sowie Serien-Aufnahmen mit/ohne Servo-AF
6) Verschiedene Belichtungsmessmethoden
7I Die ISO- und Makro-Einstellungen sowie den MF bei Bildern/Movies
8) 3er-Serienaufnahmen mit +/- 1 EV
9) 3er-Serienaufnahmen mit verschiedenen Fokusebenen (dafür war ich aber anscheinend zu doof - siehe weiter unten)
10) Das Canon-Histogramm bereits bei Aufnahmen anzeigen lassen

Das erfreuliche Resultat: Immer "OK" unten links :-)

Danke für den ausführlichen Testbericht. Ich denke die Funktionen die Du getestet hast reichen vollkommen aus. :-)
Wenn der zweite Test ebenfalls so gut ausfällt steht dem "in Serie" gehen nichts mehr im Wege.
Ich freue mich bereits auf Deine weiteren Testergebnisse.
Ich bin mal gespannt, on das Ergebnis bei der 1.00f (unser kleines Sorgenkind) ebenfalls so positiv ausfällt.

Hattest Du übrigens mit meiner lokalen Version ebenfalls die Probleme beim Einschalten?

Werner_O hat geschrieben:@Alle:
Die 3er-Serienaufnahmen mit verschiedenen Fokusebenen bekomme ich leider weder mit noch ohne CHDK hin - meine 1.0.2.d macht da immer nur ein Bild. Die recht kurze Beschreibung dazu im SX20IS-Handbuch hilft mir dabei auch nicht wirklich weiter.
Geht das bei euren SX20IS und wenn ja, was muß dabei besonders beachtet werden (etwa Stativ oder Mindest-Entfernung nötig etc.)?
Wäre für jeden Rat dazu dankbar, weil ich diesbezüglich einfach nicht weiterkomme.


Achtung, die Option funktioniert nur wenn manueller Fokus aktiviert ist.
Ich habe Anfangs gedacht ich könnte die Funktion bei Makroaufnahmen verwenden...
Leider ist der Fokusunterschied viel zu gering um brauchbar eingesetzt zu werden. Gute Idee von Canon, die Umsetzung ist leider mehr schlecht als recht gelungen.
Aber deswegen haben wir ja CHDK :-)
Es gibt ein Skript mit dem man "gestapelte" Aufnahmen machen kann. Suche mal hier im Forum "Susi2Stack", das sollte Dir weiterhelfen.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 14.04.2011, 17:11

Hallo f_m_b:

f_m_b schrieb:
Hattest Du übrigens mit meiner lokalen Version ebenfalls die Probleme beim Einschalten?

Nein, damit hatte ich keine Einschaltprobleme.

Nun zu meinen allerersten Eindrücken zu "sx20-102d-1.1.0-626-full.zip" mit dem Kommentar "Basiert auf CHDK-626 (1.02d). Erweiterter Speicher aktiv. Realbetrieb!!"

f_m_b schrieb:
Erster Test (zu Realbetrieb) ist dann "Miscellaneous Stuff ->Show Memory Info" aufrufen und Free Memory steht ca. bei 1,8MB. :-)

Unter "Zeige Speicher-Info" erscheint bei mir:
Freier Speicher: 1766568 Bytes
CHDK-Größe: 300320 Bytes
geladen bei: 0x3B089E0
Das scheint ja anscheinend OK zu sein.

Zunächst habe ich schon mal stichprobenartig einige kamerainternen Funktionen aufgerufen und auf die Schnelle keine Fehler finden können.
Das Canon-OSD ist wie gewohnt einstellbar, einige schnelle Testbilder mit Auto/P/TV/AV (mit und ohne Blitz) waren kein Problem, ebenso nicht eine kurze Movie-Aufnahme in HD (720p). Ich habe damit auch keine Einschaltprobleme. Das nur zur Info.

f_m_b schrieb:
Bei diesem Test ist vor allem wichtig CHDK Funktionen zu verwenden.

Einige wenige CHDK-Funktionen habe ich heute schon ausprobiert:
1) Ich habe problemlos meine persönlichen Präferenz-CHDK-Einstellungen machen können inkl. OSD-Layout-Editor-Änderungen.
2) Die Erstellung einer neuen "badpixel.bin" ging problemlos.
3) Das CHDK-Histogramm funktioniert anscheinend (ich hatte die Einstellungen gewählt "Zeige Live-History: Shoot" und "Histogramm-Layout: RGB all").
4) Bei aktiviertem "Zebra" blinken zu helle Bildbereiche in Orange (was ja anscheinend so gewollt ist) - ich bin aber auch da nicht in irgendwelche Detaileinstellungen gegangen.
5) "Tausche Partition" funktioniert.
6) "Zeige aktuelle Partitionnummer" funktioniert auch GsD :-)))

Anmerkung:
Die CHDK-Scripte kenne ich ja bisher (leider!) noch nicht wirklich und setze die darum auch nie ein. Bzgl. etwa "HDR" oder "Extreme Tiefenschärfe" habe ich extremen Wissens-Nachholbedarf, obwohl mich das sehr interessiert - das geht aber nicht von heute auf morgen. Bzgl. "USB-Fernbedienung" oder ähnlich exotischer CHDK-Funktionen muß ich total passen und kann da leider erst recht nichts testen :-(
Insofern sehe ich mich momentan nicht in der Lage, hier auch sinnvoll Scripte an einer 1.0.2.d zu testen :-(((

Erster Eindruck:
Es läuft so gut wie alles einwandfrei außer den zwei genannten Ausnahmen im nächsten Absatz - das sieht doch grundsätzlich gut aus :-)))
Ich kann damit arbeiten, und das ist ja zunächst mal das allerwichtigste.

Hier sehe ich noch Nachholbedarf:

1) Die "OSD-Alt-Anzeige" schaltet nicht immer im Display aus wenn man den Alt-Modus wieder deaktiviert hat durch Drücken der zugewiesenen Taste - erst nach etwa Wechsel des Programmaufnahmemodus wird oft ersichtlich, ob der Alt-Modus tatsächlich noch aktiv ist oder nicht. Das ist nervig weil irreführend.

2) Ich hatte ja bereits geschrieben, daß bei dieser neuen CHDK-Version Rest-Artefakte von alphanumerischen Zeichen von CHDK-OSD-Strings auftauchen, die früher schlichtweg abgeschnitten wurden, was die Lesbarkeit des CHDK-OSD-Menü deutlich verschlechert - das ist übrigens nach wie vor der Fall.
Zusätzlich ist mir aber nun noch aufgefallen, daß ZUDEM auch bei einigen CHDK-OSD-Einträgen auch noch HINTER den Schaltflächen ganz rechts (wo die CHDK-OSD-Einträge eigentlich längst beendet sein sollten bzw. normalerweise gar nichts mehr von CHDK anzeigt wird) weitere alphanumerische Artefakte in einigen Menüs auftauchen.
Bei meiner 1.0.2.d betrifft das folgende Menüs/Menüeinträge:
a) Im Menü "Extra-Foto-Einstellungen":
die letzten 7 Menüeinträge oberhalb von "zurück" (Von "Lösche Ersatzwerte..." bis "Ersetze Bildqualität..." -
im vorletzten Eintrag "NUR bei Video..." nur manchmal angehängte Artefakte)
b) Im Menü "Video-Einstellungen":
Nur Menüeintrag "Lösche Einstellungen bei..."
c) Im Menü "Zebra-Einstellungen":
Nur Menüeintrag "Orig.-Anzeige wiederhers..."
d) Im Menü "OSD-Einstellungen/Diverse Werte":
die letzten 5 Menüeinträge oberhalb von "zurück" (Von "Zeige eingest. Helligkeit..." bis "Zeige Szenen-Luminanz...")
sowie hier zusätzlich AUCH hinter dem Eintrag "zurück" (???)
e) Im Menü "OSD-Einstellungen/DOF-Rechner":
die Menüeinträge 2 und 3 ("Canon Motiv-Dist. als...-" und "Benutze EXIF Motiv-Dist...")
Hoffentlich können diese Infos von mir dazu beitragen, diesem bisher ungelösten Problem an den Kragen zu gehen.

Soviel zunächst von mir,
liebe Grüße
Werner

(SX20IS 1.0.2.d)
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1027
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 14.04.2011, 22:45

@Werner: Phantastisch. \:D/
Ich freue mich riesig, dass die Änderung so toll funktionieren. Nochmals Danke für Deinen ausführlichen Test.

Pauli hat sich bereit erklärt, die 1.00f zu testen. Aber unabhängig davon werde ich CHDKLover Bescheid geben, dass er die Änderungen einfließen lassen kann.


Werner_O hat geschrieben:Freier Speicher: 1766568 Bytes
CHDK-Größe: 300320 Bytes
geladen bei: 0x3B089E0
Das scheint ja anscheinend OK zu sein.
:D :D :D

Werner_O hat geschrieben:Anmerkung:
Die CHDK-Scripte kenne ich ja bisher (leider!) noch nicht wirklich und setze die darum auch nie ein. Bzgl. etwa "HDR" oder "Extreme Tiefenschärfe" habe ich extremen Wissens-Nachholbedarf, obwohl mich das sehr interessiert - das geht aber nicht von heute auf morgen. Bzgl. "USB-Fernbedienung" oder ähnlich exotischer CHDK-Funktionen muß ich total passen und kann da leider erst recht nichts testen :-(
Insofern sehe ich mich momentan nicht in der Lage, hier auch sinnvoll Scripte an einer 1.0.2.d zu testen :-(((

Es gibt wirklich sehr viele gute Skripte hier im Forum... Es rentiert sich auf jeden Fall sich ein wenig umzuschauen.

Werner_O hat geschrieben:Hier sehe ich noch Nachholbedarf:

1) Die "OSD-Alt-Anzeige" schaltet nicht immer im Display aus wenn man den Alt-Modus wieder deaktiviert hat durch Drücken der zugewiesenen Taste - erst nach etwa Wechsel des Programmaufnahmemodus wird oft ersichtlich, ob der Alt-Modus tatsächlich noch aktiv ist oder nicht. Das ist nervig weil irreführend.

Das Problem kenne ich auch... mal schauen ob ich was finde...

Werner_O hat geschrieben:2) Ich hatte ja bereits geschrieben, daß bei dieser neuen CHDK-Version Rest-Artefakte von alphanumerischen Zeichen von CHDK-OSD-Strings auftauchen, die früher schlichtweg abgeschnitten wurden, was die Lesbarkeit des CHDK-OSD-Menü deutlich verschlechert - das ist übrigens nach wie vor der Fall.
Zusätzlich ist mir aber nun noch aufgefallen, daß ZUDEM auch bei einigen CHDK-OSD-Einträgen auch noch HINTER den Schaltflächen ganz rechts (wo die CHDK-OSD-Einträge eigentlich längst beendet sein sollten bzw. normalerweise gar nichts mehr von CHDK anzeigt wird) weitere alphanumerische Artefakte in einigen Menüs auftauchen.
Bei meiner 1.0.2.d betrifft das folgende Menüs/Menüeinträge:
a) Im Menü "Extra-Foto-Einstellungen":
die letzten 7 Menüeinträge oberhalb von "zurück" (Von "Lösche Ersatzwerte..." bis "Ersetze Bildqualität..." -
im vorletzten Eintrag "NUR bei Video..." nur manchmal angehängte Artefakte)
b) Im Menü "Video-Einstellungen":
Nur Menüeintrag "Lösche Einstellungen bei..."
c) Im Menü "Zebra-Einstellungen":
Nur Menüeintrag "Orig.-Anzeige wiederhers..."
d) Im Menü "OSD-Einstellungen/Diverse Werte":
die letzten 5 Menüeinträge oberhalb von "zurück" (Von "Zeige eingest. Helligkeit..." bis "Zeige Szenen-Luminanz...")
sowie hier zusätzlich AUCH hinter dem Eintrag "zurück" (???)
e) Im Menü "OSD-Einstellungen/DOF-Rechner":
die Menüeinträge 2 und 3 ("Canon Motiv-Dist. als...-" und "Benutze EXIF Motiv-Dist...")
Hoffentlich können diese Infos von mir dazu beitragen, diesem bisher ungelösten Problem an den Kragen zu gehen.

msl war so nett und hat das Problem bereits gefixt, in einer der nächsten Versionen ist es wieder wir gewohnt. Ein "Danke schön" an msl. :-)
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon f_m_b » 16.04.2011, 17:50

Hallo zusammen

Für das Einschaltproblem der SX20 hat philmoz ein Fix geschrieben, der auch bereits in CHDK-DE enthalten ist.
Mit der Änderung aus CHDK 1146 oder dem angehängten patch (da camera.h bei CHDK-DE etwas anders aufgebaut ist) wirkt es auch bei der SX20.
Dateianhänge
BootProblem.patch
enable fix for camera crash at startup when opening the conf / font files see http://chdk.setepontos.com/index.php?topic=6179.0
(658 Bytes) 195-mal heruntergeladen
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 17.04.2011, 14:02

Hallo zusammen,

es ist ja sehr erfreulich, wie nun innerhalb recht kurzer Zeit CHDK-DE für die SX20IS entscheidend weiterentwickelt werden konnte!
Hier mal einen riesigen Dank dafür von mir an f_m_b, msl und dalle anderen, die auch mit beteiligt sind wie etwa philmoz uvam.

Allerdings habe ich ein Problem:

Gestern hatte ich angefangen, v629 (mit den übrigens gelungenen Änderungen von msl) zu testen und heute gibt es bereits v631 (mit den Änderungen von philmoz) - da komme ich mit dem Testen leider gar nicht mehr nach, und nach einer Woche Urlaub (weshalb ich überhaupt so viel testen konnte) wird meine Zeit ab Montag wieder sehr knapp.
Nachdem v629 bzgl. CHDK-OSD-Menü (mehr hatte ich leider nicht testen können) einwandfrei läuft (Danke an msl!) ist jetzt inwischen v631 sowohl auf meiner 4- als auch 8-GB-Karte als neue Test-/Arbeitsplattform drauf.
Ich kann hier aber unmöglich jeden Tag neuere CHDK-DE-Versionen suchen und sogleich austesten und ich BLEIBE jetzt erst mal bei v631. Falls ich da noch Fehler finden solte werde ich die hier natürlich posten. Nach einigen ersten kurzen Tests scheint v631 ja prima zu laufen.

Kurz gesagt: ich muß hier ab jetzt wieder deutlich kürzer treten bzgl. Testen noch neuerer Versionen an meiner 1.0.2.d :-(
Ich bleibe aber am Ball, und wenn kritische neue Beta-Versionen (etwa mit anderer RAM-Adressierung wie bei v626) vorab an einer 1.0.2.d getestet werden müssen stehe ich natürlich nach wie vor zur Verfügung.

@f_m_b:
Gesammelten Dank für Deine diversen nützlichen Infos aus mehreren Postings - da werde ich demnächst so einiges ausprobieren (so ich denn dazu komme...).
Bzgl. Deiner CHDK-Weiterentwicklung "Zeige aktuelle Partitionsnummer" wünsche ich Dir viel Glück in der CHDK-Community - mir fehlt dieses nützliche Feature bereits jetzt in v631.

Zur allgemeinen Info noch die aktuelle Speicher-Info bei v631:
Freier Speicher: 251168 Bytes
CHDK-Größe: 293076 Bytes
geladen bei: 0x13DD6C

Liebe Grüße
Werner

(SX20IS 1.0.2.d)
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1027
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 18.04.2011, 19:47

Werner_O hat geschrieben:Kurz gesagt: ich muß hier ab jetzt wieder deutlich kürzer treten bzgl. Testen noch neuerer Versionen an meiner 1.0.2.d :-(
Ich bleibe aber am Ball, und wenn kritische neue Beta-Versionen (etwa mit anderer RAM-Adressierung wie bei v626) vorab an einer 1.0.2.d getestet werden müssen stehe ich natürlich nach wie vor zur Verfügung.


Hallo Werner
ich werde Dich beim Wort nehmen...
und mich bei Dir melden wenn der Schuh gerade besonders drückt. ;-)

Ansonsten Frohes Arbeiten und frohe Ostern. :-)

-- 18.04.2011, 20:51 --

f_m_b hat geschrieben:Für das Einschaltproblem der SX20 hat philmoz ein Fix geschrieben, der auch bereits in CHDK-DE enthalten ist.
Mit der Änderung aus CHDK 1146 oder dem angehängten patch (da camera.h bei CHDK-DE etwas anders aufgebaut ist) wirkt es auch bei der SX20.


Danke msl. Ist mit rev 631 hier in CHDK-DE angekommen.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon f_m_b » 27.04.2011, 21:31

Hallo SX20 CHDK-DE Freunde:
Ein paar kurze Infos was gerade so läuft...

- Anzeige der Partitionsnummer ist jetzt auch in der aktuellen Version enthalten. :-D
- Der Fehler, dass die Kamera sich nur schwer einschalten lässt (Mehrfaches Drücken der Play Taste und oder ON/Off Taste), sollte nicht mehr auftreten.

- Die Portierung der Firmware 1.00f habe ich ein wenig "aufgemöbelt" ... Wird gerade im intern. Forum von phaedra, jan und baxev2005 getestet.
Die ersten Testergebnisse sehen sehr zuversichtlich aus... Mal schauen was noch an Fehlern hochkommt.
Aber ich denke wir sind einen großen Schritt in Richtung "stabile Version 1.00f" gegangen.
PS: Sollte jemand eine CHDK-DE mit der 1.00f testen wollen... Einfach mal hier anfragen.

- Die Speicherprobleme sind durch Verwendung von EXMEM Vergangenheit. Ich arbeite jetzt schon eine ganze Weile damit und selbst PTP läuft ohne Probleme.

Ein paar kleinere Fehler sind auch beim Testen hochgekommen (zumindest bei 1.02b):
- LUA-Befehl Reboot() funktioniert nicht.
Kamera startet neu, E31 erscheint in der Ecke, Splash Screen von CHKD-DE erscheint und danach schaltet sich die Kamera aus.
-> Wenn jemand eine Idee hat wie ich dem Problem Herr werden könnte, wäre ich dankbar.

- Kamera stürzt ab (schaltet sich aus) wenn man ein Foto schießt während gerade ein Film aufgenommen wird.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon msl » 28.04.2011, 10:52

Hallo Frank,

zum Problem Reboot():

Hast du schon mal versucht, per Reboot eine Binär-Datei zu laden, also z.B. reboot("A/DISKBOOT.BIN")? Das wird jetzt nicht das Problem lösen. Es wäre aber interessant zu wissen, ob es geht. Möglicherweise gibt es auch einen Zusammenhang mit dem manuellen Start, der bei der SX20 ja auch nicht funktioniert (Firm-Update).

Als Ergänzung hier noch Einführungsbeschreibung von Reboot: http://chdk.setepontos.com/index.php?to ... 4#msg55194

Gruß msl
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4546
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: CHDK für SX20

Beitragvon f_m_b » 16.05.2011, 22:27

msl hat geschrieben:Es wäre aber interessant zu wissen, ob es geht.
Wie vermutet funktioniert reboot("A/DISKBOOT.BIN") ebenfalls nicht. Ich werde mich mal ein wenig einlesen und ggf. nochmals "nerven".
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

VorherigeNächste

Zurück zu S/SX-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste