CHDK für SX20

Sx, Sxx, Sxxx, SX1, SXxx, SX1xx, SX2xx, SX4xx, SX5xx, SX6xx, SX7xx

Re: CHDK für SX20

Beitragvon f_m_b » 27.05.2011, 23:13

Ich habe unter Link: Keys für's manuelle Laden von CHDK die Adressen für die Schlüssel für's manuelle Laden von CHDK für 1.02b und 1.02d gefunden und hinterlegt.
Leider reicht es damit nicht aus... und leider reichen meine Kenntnisse über ARM und Assembler ebenfalls nicht aus um den Loader zu debuggen.
So bleibt die SX20 weiterhin nicht manuell ladbar. :-(

-- 28.05.2011, 00:30 --

Der SX20 1.02b Firmwareabzug war nicht komplett:
Hier ist der komplette Abzug: Link

@Admin:
Wäre nett wenn Ihr die Firmware auf dem Server aktualisieren könntet. :-)
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Werner_O » 09.07.2011, 12:28

Hallo SX20IS-User,

wer von Euch gerne mal HDR-Reihen oder auch Einzelaufnahmen mit hyperfokalem Fokus machen möchte sollte sich meinen Beitrag zu folgendem Thread hier im Forum anschauen: viewtopic.php?f=7&t=479&start=165

Dort findet Ihr eine von mir speziell an die SX20IS angepasste Version des Skriptes "HDR-Hyper.bas" von "gehtnix" sowie eine Hilfedatei dazu im TXT-Format, welche über den „Textbetrachter“ im CHDK-Menü an der Kamera gelesen werden kann.
Besonderen Dank an "gehtnix" für seine tolle Vorarbeit!

Viel Spass damit :-)

Liebe Grüße
Werner

SX20IS 1.0.2.d - CHDK DE 6.98
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1019
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon Lefty » 01.08.2011, 13:34

Hallo zusammen,

nachdem ich mich schon einmal vor einem Jahr mit CHDK auf der SX20 beschäftigt habe bin ich aus aktuellem Anlaß wieder auf das Thema gekommen. CHDK-DE bietet sich natürlich an. Leider habe ich eine 1.00f erwischt.

Nach einigem mitlesen habe ich diesen älteren Post entdeckt:
f_m_b hat geschrieben:Hallo SX20 CHDK-DE Freunde:
Ein paar kurze Infos was gerade so läuft...

...

- Die Portierung der Firmware 1.00f habe ich ein wenig "aufgemöbelt" ... Wird gerade im intern. Forum von phaedra, jan und baxev2005 getestet.
Die ersten Testergebnisse sehen sehr zuversichtlich aus... Mal schauen was noch an Fehlern hochkommt.
Aber ich denke wir sind einen großen Schritt in Richtung "stabile Version 1.00f" gegangen.
PS: Sollte jemand eine CHDK-DE mit der 1.00f testen wollen... Einfach mal hier anfragen.

Deswegen frage ich einfach mal an, ob man diese Beta noch irgendwie testen kann oder ob es was neues zur f-Version gibt. Ich möchte allerdings gleich dazu sagen, daß ich absoluter CHDK Anfänger bin (keine Angst werde es schon zum laufen bringen). Einen kompletten Regression Test werde ich also eher nicht hinbekommen. Allerdings einen Test im normalen Umfang wie ihn "Otto Normalbenutzer" wohl machen würde.

Kann man einen halbwegs aktuellen Build irgendwo runterladen?

Meine Kamera:
Code: Alles auswählen
Canon PowerShot SX20 IS
P-ID:31E4 PAL D

Firmware Ver GM1.00F
NoError
Jun 15 2009 15:28:22

Adj Ver.003.003

SubCPU Ver 1.02
Mecha Firm Ver 2.03
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon CHDKLover » 01.08.2011, 13:52

Hallo Lefty,
willkommen im Forum.
Ich glaube du meinst eine dieser Beta Versionen: viewtopic.php?f=10&t=1501&start=240#p21727 oder http://chdk.setepontos.com/index.php?to ... 7#msg65447
Ein Testbericht wäre sehr interessant. Vielleicht findet die Version dann auch den Weg in den Trunk und auf den Autobuildserver.

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 18:25
Wohnort: Dresden
Kamera(s): a610 100e

Re: CHDK für SX20

Beitragvon Lefty » 01.08.2011, 14:08

Hallo CHDKLover,

danke für die nette Begrüßung :-).

Ja diese Versionen meinte ich. Ich habe fälschlicherweise das intern. als intern statt international gedeutet. Ich werde wohl mal die 1160 testen.

Nachtrag:
Mal als erstes Feedback: Mit umpartitionierter 8GB Karte die per Cardtricks bootbar gemacht wurde startet die sx20-100f-0.9.9-1160-full einwandfrei. Auch RAW in DNG Format geht schon mal (ups, 6140 badpixels). Wenn man die Linse zu hält werden auch die Menüs nicht ständig überschrieben (wohl der Autofokus der da zuschlägt). Jetzt lese ich mal in Ruhe das Handbuch und teste in Ruhe. Vom ersten Eindruck muß ich aber sagen läuft. Kein offensichtlicher Showstopper. =D>
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon Lefty » 03.08.2011, 16:46

So, zwei Tage CHDK. Bisher sind mir zwei Dinge aufgefallen.

Zuerst das Gute, oder auch Schlechte, je nachdem wie man das sehen möchte: Ich war jedenfalls recht schockiert.

Ich habe hier im Forum mehrfach gelesen, daß RAW auf den Canon Knipsen überbewertet wird. Dem möchte ich hier mal als Normalknipser heftigst wiedersprechen. Ich kann natürlich nur für die SX20 IS sprechen. ABER: Ohne CHDK mache ich mit dieser Kamera kein einziges Foto mehr. Hätte ich die letzten Stunden gravierende Probleme mit CHDK festgestellt würde ich die Kamera spätestens jetzt gleich in der Bucht versenken. Wir haben nur ein bisschen im Garten rumgeknipst (Fotografieren kann man das nicht nennen). Immer schön im grünen Modus draufgehalten. Verglichen mit den DNGs sind die JPGs der Kamera völlig unbrauchbar. Einfach nur schlecht. Grauschleier wohin man sieht. Dagegen die DNGs: In PSE einfach bei Camera RAW 5.5 auf Auto geklickt kommen wunderschöne Bilder raus. Aufwand minimal. Die Kamera macht wirklich gute Bilder (selbst im grünen Modus), aber die interne Umwandlung in JPEG ist ja wirklich grauenhaft.

Beispiel mal unten angehängt. Nur in Camera Raw "wie von Kamera", "Auto", Fertig.


Fehler:
- Die CHDK Menüs werden ständig überschrieben. Das ist aber bekannt und läßt sich leicht beheben indem man das Objektiv zu hält. Kann man mit leben.
-Ein (echter?) Fehler ist das Speichern der Bilder. Ich habe ausgewählt die DNGs im selben Ordner wie die JPGs zu speichern (RAW-Einstellungen -> RAW-Datei in JPEG-Ordne.). Kamera hällt sich aber nicht daran. Das führt dazu, daß man die geschossenen Bilder nicht mehr im Playback Mode anzeigen kann. Löscht man nun den DCIM Ordner auf der Karte funktioniert der Playback Mode so lange bis man die Kamera ausschaltet und neue Bilder schiesst. Danach geht der Playback Mode nicht mehr. Die Bilder werden aber gespeichert (in getrennten Ordnern). Kann man mit leben, ist aber unschön.

Samstag gehts in den Urlaub. Wenn mir noch was auffällt werde ich berichten.
Dateianhänge
Unbenannt.PNG
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon Werner_O » 08.08.2011, 20:36

Hallo Lefty,

Immer schön im grünen Modus draufgehalten. Verglichen mit den DNGs sind die JPGs der Kamera völlig unbrauchbar. Einfach nur schlecht. Grauschleier wohin man sieht.


Meinst Du mit "grünen Modus" das Szenenprogramm "Laubaufnahmen"? Das ändert in den JPGs (aber nicht in den DNGs) die Farben und ist darum zumeist keine gute Wahl. Farben sollte man immer erst nachträglich in der Bildbearbeitung ändern.
Falls Du mit "grünen Modus" dagegen die "Vollautomatik" meinst, dann stellt die Kamera automatisch eines von vielen Programmen ein, welches sie gerade für das beste hält (auch wenn das nicht unbedingt wirklich das beste für die jeweilige Aufnahmesituation ist). Dieser Modus ist darum mit Vorsicht zu "genießen" da man absolut keinerlei Einflußmöglichkeiten auf das Bild hat - man kann noch nicht einmal den ISO-Wert vorgeben. Ich selber nutze diesen Modus darum fast nie - außerdem habe ich nicht mehr als 300 EUR für eine Kamera mit immensen Möglichkeiten ausgegeben, um damit anschließend Aufnahmen im "Modus für den DAU" zu machen.

Mit Programm- oder AV/TV-Automatik (und zumeist auch mit Vollautomatik) macht meine SX20 IS 1.02d durchaus auch brauchbare JPGs (mit CHDK ist ja sogar "superfein" einstellbar) ohne Grauschleier und auch ohne krasse Farbänderungen verglichen mit den DNGs. DNG ist darum für mich nicht immer ein Muß, insbesondere wenn ich schnell Aufnahmen hintereinander machen möchte.

Teste aber unbedingt, ob Deine SX20 IS mit Programm- oder AV/TV-Automatik brauchbare JPGs erzeugt! Wenn nicht, ist Deine Kamera evtl. defekt!!!
Bei mir gibt es definitiv keine Grauschleier und ich bin mit der SX20 IS wirklich sehr zufrieden.

P.S.:
Evtl. hattest Du auch "I-Contrast" aktiviert, was bei Bildern mit extremen Kontrastumfang zu dunkle Stellen heller und zu helle Stellen dagegen dunkler macht. Auch diese Funktion ist mit Vorsicht zu genießen (mal Segen, mal Fluch).

ups, 6140 badpixels


Das ist ein normaler und üblicher Wert, keine Sorge. Bei mir sind es es 7.489 badpixel. Stelle aber bei den RAW-Einstellungen bei "Pixelfehler entfernen" die Einstellung "Mittelwert" ein. Dann werden diese falschen Pixel aus den Umgebungspixeln interpoliert und sind im DNG sozusagen unsichtbar.

-Ein (echter?) Fehler ist das Speichern der Bilder. Ich habe ausgewählt die DNGs im selben Ordner wie die JPGs zu speichern (RAW-Einstellungen -> RAW-Datei in JPEG-Ordne.). Kamera hällt sich aber nicht daran. Das führt dazu, daß man die geschossenen Bilder nicht mehr im Playback Mode anzeigen kann. Löscht man nun den DCIM Ordner auf der Karte funktioniert der Playback Mode so lange bis man die Kamera ausschaltet und neue Bilder schiesst. Danach geht der Playback Mode nicht mehr. Die Bilder werden aber gespeichert (in getrennten Ordnern). Kann man mit leben, ist aber unschön.


1. Bei meinem CHDK (allerdings für die 1.02d!) landeten die DNGs auch erst in einem separaten Ordner. Bei mir habe ich dieses Problem lösen können, indem ich im Canon-Menü die Einstellungen "Datei-Nummer = Reihenaufnahme" und "Ordner anlegen = täglich" eingestellt habe. Vielleicht klappt das bei Dir auch.
2. Die SX20 IS zeigt im Playback-Modus IMMER NUR die JPGs, auch wenn die DNGs (wie bei mir) im gleichen Ordner liegen. Den DCIM-Ordner zu löschen macht darum keinen Sinn und verursacht ja anscheinend bei Dir auch Fehlfunktionen.
3. Außerdem muß auch ich die DNGs immer separat per Cardreader auslesen, weil die Canon-Software diese nicht automatisch mit auf den Rechner transferiert. Damit kann ich aber leben - besser so als gar keine DNGs mit der SX20 IS.

Tip: Im Alt-Modus kannst Du bei der SX20IS mit der Löschtaste einfachst RAW/DNG-Aufnahmen aktivieren/deaktivieren :-)
Das wird dann am Bildschirm angezeigt. Ich habe diese DNG bzw. RAW-Anzeige allerdings im OSD-Layouteditor an eine andere Position verschoben.

Zu den noch vorhandenen CHDK-Fehlern bei der Version für die SX20 IS 1.00f kann ich mit meiner 1.02d natürlich leider nichts sagen :-(

Ansonsten finde ich es prima, daß Du Dich hier im Forum angemeldest hast und mitarbeiten möchtest :-)))
Bei CHDK für die SX20 IS 1.00f besteht ja anscheinend noch Nachholbedarf, und Tester für Version 1.00f sind leider rar gesät. Insofern könntest Du hier wertvolle Beiträge leisten.
Ich selber habe ja hier auch als Tester für die CHDK-Version für die 1.02d mitgearbeitet und das nie bereut:
Durch Ausprobieren insbesondere auch von weiterentwickelten und noch inoffiziellen Testversionen konnte ich Erfolge/Fehler an die Entwickler weitergeben, sodaß CHDK für die 1.02d inzwischen super funktioniert. Es ist für mch ein gutes Gefühl, dabei immerhin ein klein wenig dazu beigetragen zu haben im Rahmen meiner Möglichkeiten.

Liebe Grüße
Werner
Zuletzt geändert von Werner_O am 24.09.2011, 12:32, insgesamt 3-mal geändert.
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1019
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon Lefty » 15.08.2011, 14:41

Hallo zusammen,

sorry, daß ich mich so spät melde, aber im Urlaub wollte ich mich etwas erholen. Wir sind nun zurück und ich kann zumindest etwas zur CHDK Version für die 1.00F Firmware beitragen.
Getestet wurde, wie oben geschrieben, die sx20-100f-0.9.9-1160-full.
Ich habe in einer Woche rund 600 Bilder geschossen. Auch im "grünen" Vollautomatik "Dau" Modus. Dazu gleich noch mehr. Es wurden aber auch Bilder im AV / TV / P und komplett Manuell gemacht. Inklusive Dauerbelichtungen. Eine Belichtungsreihe (über Canon Menüs) erzeugte nur weiße Bilder, aber das war eine Fehlbedienung von mir. Ich habe in dieser einen Woche KEINE Fehler finden können. Es kam NIE zu einem Absturz oder irgendwelchen Unzulänglichkeiten. Auch Video Aufnahmen funktionierten einwandfrei. Die Overlays für Histogram funktionierten in allen zur Verfügung stehenden Modi einwandfrei und waren sehr hilfreich.

Das Problem mit "Speicherkarte leer" konnte ich mit Hilfe von Werners Hinweisen oben lösen. Danke dafür.

Das will jetzt natürlich nicht bedeuten, daß es keine Fehler gibt, ich habe nur keine gefunden. Bei normaler Benutzung sehe ich persönlich keinen Grund dafür obige CHDK Version nicht einzusetzen. Zumal ja ein Rückfall auf die Original Firmware jederzeit durch entfernen des Schreibschutzes der Speicherkarte möglich ist.

Ich denke, man kann die Firmware ohne Bedenken auch der Allgemeinheit zur Verfügung stellen. In den anderen Versionen von CHDK, die man über den Autobuild Server bekommt, werden ja auch noch Dinge verbessert wenn es doch zu "Fehlerchen" kommt. Vieleicht finden sich dann auch mehr Tester für die 1.00F Firmware. Ich wiederhole mich, aber die sx20-100f-0.9.9-1160-full ist (meiner Meinung nach) reif für einen regulären Einsatz. Die Kamera hat mich mit CHDK nicht im Stich gelassen. Es kam nie zu einem Verlust von Daten.



@ Werner,

ich habe mich über Dein Feedback gefreut und möchte nochmal kurz darauf eingehen. Ich muß vieleicht auch etwas konkretisieren warum ich oben geschrieben habe die Kamera sei teilweise unbrauchbar.

Die Knipserei im Garten war im "grünen Modus" was tatsächlich die Vollautomatik meint. iContrast(? find ich bei mir gar nicht) und myColors waren abgeschaltet. Dies in voller Absicht weil ich die Unterschiede zwischen RAW und Vollautomatik austesten wollte. Im AV / TV Modus sind die JPEGs definitiv besser als mit der Automatik. Das gilt auch für die ISO Einstellung. Begrenzt man konsequent auf höchstens ISO 400 sind die Bilder besser als mit Auto ISO (zu starke Rauschunterdrückung). Das ist aber dem kleinen Sensor geschuldet. Ich habe mir die Kamera auch gekauft um mehr zu machen als mit einfacheren Knipsen möglich ist. Dennoch wird die Kamera von mehreren Personen benutzt, die nicht alle den Anspruch haben die Technik auch nur im Ansatz zu verstehen. Oft bleibt auch gar nicht die Zeit erst irgendwelche Parameter einzustellen. Manchmal muß es schnell gehen. Wir kommen von einer EOS 50E mit der wir extrem gut zurecht gekommen sind. Das nur als Hintergrund. Dazu kommen noch diverse Digicams in den vergangenen Jahren.

Ich erwarte von einer Kamera dieser Preisklasse eigentlich schon, daß nicht nur Papa gute Bilder macht weil er die diversen Modi versteht, sondern auch der Rest der Familie ohne sich vorher die Kamera einstellen zu lassen. Es stimmt schon, man sollte sich nicht auf die Automatik verlassen. Da sind wir sicher einer Meinung. Aber man darf schon erwarten, daß eine 350€ Kamera im Automatikmodus mindestens so gut ist wie die kleine Schwester um 100€. Es kann aber auch gut sein, daß das ein spezielles Problem der 1.00f ist. Möglicherweise wurde zur 1.02 genau hier etwas verändert.

Mit der Kombi CHDK und SX20 bin ich jedenfalls zufrieden. Macht nicht immer gute JPEGs aber immer gute (RAW)Fotos.
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon Werner_O » 15.08.2011, 21:35

Hallo Lefty,

vorab: von einer schnellen Antwort von Dir war ich wegen Deines Urlaubs erst gar nicht ausgegangen ;-)
Schön, daß Du wenigstens die Speicherfehlermeldung durch meine Hinweise wegbekommen hast.
Landen die DNGs nun auch bei Dir im normalen JPG-Folder?

Den "i-contrast" kann ich bei mir im Canon-Menü unter "Aufnahmeinstellungen ändern" einstellen (liegt weiter unter zwischen "Blitzsteuerung..." und "Spotmessfeld" - Auto oder Off sind wählbar). Vielleicht ist das bei der Firmware 1.00f noch nicht implementiert.

Aber man darf schon erwarten, daß eine 350€ Kamera im Automatikmodus mindestens so gut ist wie die kleine Schwester um 100€. Es kann aber auch gut sein, daß das ein spezielles Problem der 1.00f ist. Möglicherweise wurde zur 1.02 genau hier etwas verändert.


Das vermute ich ebenfalls. Nach 1.00f kamen ja m.W. noch 1.02b, 1.02c und 1.02d als neuere Firmware-Versionen.
Da bei meiner 1.02d der Unterschied zwischen JPG und DNG anscheinend bei weitem nicht so groß ist wie bei Dir (auch mit "grüner Vollautomatik") scheint Canon hier deutlich nachgebessert zu haben (bzw. haben zu müssen). Die "Optimierung" der JPGs vor dem Speichern wurde anscheinend schrittweise optimiert. Darauf deutet Deine positive Resonanz zu den DNGs hin, welche ja ohne "Optimierung" gespeichert werden.

Ich erwarte von einer Kamera dieser Preisklasse eigentlich schon, daß nicht nur Papa gute Bilder macht weil er die diversen Modi versteht, sondern auch der Rest der Familie ohne sich vorher die Kamera einstellen zu lassen.


Mit meiner 1.02d, die ich desöfteren an zwei Freunde vom Typ "DAU" ausleihe und die diese Kamera inzwischen lieben, machen auch diese zumeist recht gute Aufnahmen mit Vollautomatik (was anderes wagen die erst gar nicht vorzugeben).

Trotzdem ist diese Kamera m.E. kaum geeignet für User vom Typ "DAU", ohne denen vorher wenigstens ein paar Basics zu dieser Kamera mitzugeben.
Das fängt beim Blitz an, der bei Vollautomatik immer "per se" schon manuell ausgeklappt sein sollte, damit er überhaupt wenn nötig zünden kann (er klappt ja nicht automatisch bei Bedarf aus, was übliche User einfacher Kameras aber erwarten). Ein Kumpel hat so bei Dunkelheit ohne ausgeklappten Blitz 'zig unbrauchbare Bilder gemacht ohne das selber zu merken, da sich das rückwärtige Kameradisplay ja automatisch an die Umgebungshelligkeit anpasst und die Bilder für ihn darum am Display OK aussahen!

Zudem blitze ich zumeist im Dunklen und habe darum üblicherweise Langzeitsynchronisation mit Blitz auf den zweiten Verschlußvorhang als Standardvorgabe aktiviert, um möglichst viel vorhandenes Licht mit einzufangen (mit entsprechend langen Verschlußzeiten und viel größerer Verwackelungsgefahr). Beim Aufhellblitz für ein Porträt am Tage bei Gegenlicht ist das aber enorm kontraproduktiv. Deswegen muß ich vor einem Verleihen meiner Kamera an "DAUs" defakto immer erst die "üblichen Normal-Einstellungen" (etwa: Blitz auslösen wenn nötig; keine Langzeitsychronisation etc.) zurückstellen, damit diese möglichst sogar auch im P-Modus noch gute Aufnahmen machen können.

Wenn ich meinen Feunden zudem meinen externen Dörr-Blitz vom Typ "DAF 42 Power Zoom" (max. LZ 42) mitgebe muß ich zudem die Blitzbelichtung manuell auf mindestens +1,3 EV stellen, weil sonst trotz TTL-Messung die Bilder zu dunkel werden.

Summa summarum:
Die SX20IS gehört eigentlich in erfahrene Hände und ist (vorsichtig formuliert) nur suboptimal für "DAUs".

Last not least freut es mich, daß CHDK für die 1.00f bei Dir anscheinend prima funktioniert :-)))
Das ist ja schonmal Gold wert - ebenso Deine durchweg positiven Resonanzen zu CHDK für diese Firmware-Version.
Schade nur, daß die JPGs bei Dir anscheinend nicht überzeugen können. aber das kann ich mit meiner 1.02d so nicht nachvollziehen.

Liebe Grüße
Werner
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1019
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: CHDK für SX20

Beitragvon f_m_b » 16.08.2011, 12:48

Hallo Lefty

vielen Dank, dass Du die Version gründlich getestet hast. Die Änderungen waren alle "Blind" gemacht, da ich 1.00f nicht auf meiner SX20 testen kann. Umsomehr freut es mich, dass Dein Test so positiv ausgefallen ist.

Die Tester im Int. Forum haben eine einmalige positive Rückmeldung zu einem Kurztest gegeben und sich danach nicht mehr gemeldet...
Was vermutlich bedeutet, dass es keine größerern Probleme mehr mit der Version gibt.

Das Problem "RAW File in Dir with JPEG" sollte in CHDK-DE mit Rev. 618 behoben sein. Ich glaube allerdings nicht, dass der Fix in das Int. CHDK zurückgeflossen ist.
@Werner: Falls Du Lust hast kannst Du ja mal schauen ob es bei Deiner aktuellen Version (>Rev. 618) funktioniert. ;-)

Ich bin jetzt ein paar Tage weg, werde dann mal versuchen die Änderungen auf den aktuellen Stand zu heben. Von meiner Seite spricht nichts mehr dagegen die 1.00f ebenfalls für den Autobuild freizugeben. Vermutlich ab Anfang September kann ich mir etwas Zeit dafür nehmen.

@CHDKLover und msl:
Mein Vorschlag ist folgender:
- Altes Patch von mir in aktuelle CHDK-Version bringen. Falls notwendig Anpassungen/Ergänzungen durchführen und lokal übersetzen.
- Falls gewünscht könnte Lefty noch einen Kurztest mit dieser Version durchführen.
- reyalp darum bitten diesen Stand freizugeben.
- Wie gehen wir mit CHDK-DE um? Soll ich Euch dafür ebenfalls ein Patch zur Verfügung stellen oder wollt Ihr die Änderungen aus CHDK (Int.) mergen?
- Die EXMEM-Erweiterungen funktionieren bei mir sehr zuverlässig. Wollen wir die Änderungen ebenfalls einbuchen?

Zum Thema EXMEM: Mit einer der letzten Mergeaktionen (kann auch schon etwas länger her sein) lässt sich zumindest die SX20 1.02b nicht mehr mit EXMEM übersetzen. Ist das Problem bereits gemeldet? Wäre nett wenn Ihr mal drüber schaut. Falls Ihr momentan keine Zeit habt... kümmere ich mich gerne ab Anfang September darum. :D

-- 16.08.2011, 14:03 --

Ich habe schon länger nicht mehr in dieses Thema geschaut, da ich einen "Beobachter" eingerichtet habe. Allerdings wurde ich bei den letzten neuen Einträgen nicht mehr informiert. :-(

Soll ich den Beobachter löschen und wieder neu einrichten? Gab es vielleicht Anpassungen der Web-Seite?
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Lefty » 16.08.2011, 18:42

Hallo nochmal,

@Werner: Ich kann Deiner Einschätzung, daß die Kamera in Hände gehört die sich mit dem Thema beschäftigen wollen nur anschließen. Wenn dann aber eine A530 "bessere" JPEGs liefert als die SX 20, dann bin ich als Kunde von Canon enttäuscht. Flashen wäre eine Option die es aber so bei dem Modell wohl nicht gibt.

Hänge unten mal noch ein kurioses Beispiel an: Bin wohl versehentlich in den Digitalzoom gerutscht. Deswegen im JPEG anderer Ausschnitt als im korespondierenden RAW (unbearbeitet von der Kamera). f/5.8, ISO 400, 1/90 Sek, 100mm Brennweite. Leider etwas unscharf geworden.

Bild

Speichern:
Die Bilder sind bei mir in 100Canon gelandet. Nicht zusammen mit den JPEGs (obwohl so eingestellt) aber damit kann ich leben.

Allgemein:
Wenn ich noch was testen soll, dann gerne hier schreiben was ich testen soll. Dann mache ich das gerne noch.
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon CHDKLover » 16.08.2011, 19:11

Hallo f_m_b und Lefty,
ich habe gerade die sx20 100f in den trunk des CHDK-DE eingepflegt.
@Lefty
Es wäre klasse, wenn du die Version vom Autobuildserver die Tage mal testen könntest (ab Revision 755). Möglicherweise speichert diese Version auch die RAW-Bilder im richtigen Verzeichnis.

@f_m_b
Ich habe zusätzlich die sx20 102b um deinen EXMEM-Patch erweitert. Beim Kompilieren konnte ich bisher keine Probleme feststellen.

Zu dem Problem bei der Beobachtung des Beitrags:
Der Admin hat vor einiger Zeit das Forum dahingehend erweitert, dass jetzt nicht nur eine Statusmeldung Versandt wird sondern gleich der komplette Beitrag als Inhalt der E-Mail. Möglicherweise funktioniert da was noch nicht 100%. Kannst du bitte sonst mal testen, wenn du das Thema erneut beobachtest, ob es dann funktioniert. Ansonsten muss der Admin nochmal schauen.

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 18:25
Wohnort: Dresden
Kamera(s): a610 100e

Re: CHDK für SX20

Beitragvon f_m_b » 16.08.2011, 19:44

CHDKLover hat geschrieben:ich habe gerade die sx20 100f in den trunk des CHDK-DE eingepflegt.
=D> =D> =D> Vielen Dank für die freundliche und superschnelle Umsetzung.

CHDKLover hat geschrieben:Ich habe zusätzlich die sx20 102b um deinen EXMEM-Patch erweitert. Beim Kompilieren konnte ich bisher keine Probleme feststellen.
Übersetzt wieder lokal bei mir... scheinbar hatte ich einen "nicht vollständigen" Zwischenstand ausgebucht. (1.00f hat ebenfalls lokal übersetzt. :-D )
Noch größeren Dank. Wieder ein lokaler Patch weniger auf der Platte. ;-)

CHDKLover hat geschrieben:@Lefty
Es wäre klasse, wenn du die Version vom Autobuildserver die Tage mal testen könntest (ab Revision 755). Möglicherweise speichert diese Version auch die RAW-Bilder im richtigen Verzeichnis.
So sollte es sein.

CHDKLover hat geschrieben:Zu dem Problem bei der Beobachtung des Beitrags:
Für Leftys Beitrag habe ich eine email bekommen, für Deine nicht...
Ich habe mich mal abgemeldet und wieder neu für eine Benachrichtigung eingetragen. Wenn ich Anfang September wieder am PC bin sehe ich ja ob's geklappt hat.

Nochmals Danke für die schnelle Umsetzung.


Lefty hat geschrieben:Hänge unten mal noch ein kurioses Beispiel an: Bin wohl versehentlich in den Digitalzoom gerutscht. Deswegen im JPEG anderer Ausschnitt als im korespondierenden RAW (unbearbeitet von der Kamera). f/5.8, ISO 400, 1/90 Sek, 100mm Brennweite.
Ich bin sprachlos, da hat Canon sich ja bei der 1.02b und 1.02d so richtig ins Zeug gelegt. Ich mache nur in den wenigsten Fällen RAW (nur bei schlechten Lichtverhältnissen, schwierigem Motiv,...) da ich bei den meisten Bildern überhaupt keinen großen Unterschied zwischen RAW und JPG merke und ich den zusätzlichen Aufwand der RAW-Bearbeitung scheue.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 21:59
Kamera(s): -

Re: CHDK für SX20

Beitragvon Lefty » 16.08.2011, 20:14

CHDKLover hat geschrieben:@Lefty
Es wäre klasse, wenn du die Version vom Autobuildserver die Tage mal testen könntest (ab Revision 755). Möglicherweise speichert diese Version auch die RAW-Bilder im richtigen Verzeichnis.


Super, danke. =D> Ich lade mir die morgen mal runter und werde dann am Donnerstag auf einer Schwarzwaldtour testen.
Gruß,
Lefty
----
PowerShot SX20 IS / 1.00F
Lefty
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 01.08.2011, 12:47
Kamera(s): Canon Powershot SX20 IS

Re: CHDK für SX20

Beitragvon Werner_O » 16.08.2011, 22:10

@f_m_b:

Das Problem "RAW File in Dir with JPEG" sollte in CHDK-DE mit Rev. 618 behoben sein. Ich glaube allerdings nicht, dass der Fix in das Int. CHDK zurückgeflossen ist.
@Werner: Falls Du Lust hast kannst Du ja mal schauen ob es bei Deiner aktuellen Version (>Rev. 618) funktioniert. ;-)


Das klappt bei mir prima seit etlicher Zeit - momentan habe ich CHDK-DE 698.

@Lefty:

Bezüglich "RAW/DNG in JPG folder": Dazu hast Du ja inzwischen von den anderen hier wertvolle zusätzliche Hinweise bekommen.
Ist eh' nicht soooo wichtig, da man RAW/DNG Bilder sowieso separat via Cardreader von der SD-Karte auslesen muß.

Ansonsten habe ich mich eben längere Zeit (darum meine so späte Antwort) um Deine beiden letzten geposteten Bilder gekümmert und diese ein wenig analysiert um evtl. herauszufinden, warum Deine SX20IS 1.00f dermaßen zugegebenermaßen schlechte JPG-Bilder macht, daß wir anderen SX20IS-User uns hier nur noch wundern (und rätseln) können.

Alarmierend ist dabei das "Grau-Histogramms" von Deinem JPG:
Es gibt keinerlei (!!!) wirklich sehr dunkle Pixel im JPG und erst recht kein "echtes Schwarz" - siehe den rot eingerahmten Bereich:

Bild

Das erklärt, warum das JPG so beschissen aussieht: Der Kontrastumfang ist schlichtweg extrem reduziert, da die dunklen Stellen fehlen.

Im Vergleich dazu das Histogramm vom (gut aussehenden) DNG:

Bild

Hier werden dagegen auch die dunkelsten Bereiche bis hin zu fast total Schwarz abgebildet, und genau darum sieht dieses DNG so viel besser aus.

Es gibt jetzt m.E. für Dich nur noch zwei Möglichkeiten zum Ausprobieren:

1) Deine SX20IS könnte schlichtweg defekt sein:
Mache mal ein Bild mit großem Kontrastumfang OHNE CHDK und OHNE aktiviertem I-Contrast und analysiere anschließend mit einem Grau-Histogramm (etwa mit dem kostenlosen IrfanView möglich) das resultierende JPG:
Wenn dann immer noch dieses Loch im Grau-Histogramm bei den sehr dunklen Pixeln (siehe Bild 1 - roter Rahmen) auftaucht ist Deine Kamera wahrscheinlich defekt und muß ausgetauscht werden (>Garantie).

2) Du hattest beim Einrichten von CHDK gravierende Fehler gemacht:
Lösche alle Deine persönlichen CHDK-Einstellungen, indem Du im Cardreader die Datei CHDK/CCHDK.CFG löschst.
Aktiviere beim nächsten Neustart von CHDK NUR (!) "RAW" und"RAW als DNG", mache ein paar Bilder und vergleiche die Grau-Histogramme zu den JPGs und DNGs (etwa mit IrfanView).

P.S. 1:
Die meisten User hier sind mit der SX20IS dermaßen zufrieden, daß sie die meisten Bilder ohne RAW/DNG machen, weil auch die JPGs bereits für die meisten Fälle ausreichen. Warum das bei Dir nicht klappt erstaunt uns alle.

P.S. 2:
Schicke mir mal ein "not edited JPG-Bild" in voller Größe, mit dem Du nicht zufrieden bist.
Dann könnte ich über dessen Exif-Daten evtl.herausfinden, was bei Dir vielleicht schief läuft.

Liebe Grüße
Werner
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1019
Registriert: 22.10.2010, 13:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

VorherigeNächste

Zurück zu S/SX-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast