[gelöst] Datenfehler/-wiederherstellung

A4xx, A5xx, A6xx, A7xx, A8xx, A1xxx, A2xxx, A3xxx, A4xxx

Datenfehler/-wiederherstellung

Beitragvon derandi » 06.07.2009, 20:58

Ja, ich habe die Forumsuche bemüht, aber nichts passendes gefunden.

Aus irgendwelchen Gründen sind die letzten ca. 20 Bilder weg, und das Dateisystem der Karte (8 GB) ist inkonsistent geworden. Blöderweise hatte ich den USB-Hub während der Datenübertragung (Karte in Kamera, Kamera an Hub, Hub am Computer) vom Stromnetz getrennt, ob es dabei passiert ist? Kann das Ding so empfindlich sein, denn es sollte dabei ja eigentlich nur gelesen, nicht geschrieben werden. Andererseits sind auch alle JPGs und alle CRWs und alle AVIs weg ab dem Zeitpunkt, an dem ich eine Belichtungsreihe gemacht hatte und ab dem ich mit Hilfe der Kamera ein paar Bilder gelöscht hatte. Ob da noch was faul ist?

Jedenfalls bin ich seit zwei Tagen mit Datenrettung beschäftigt, und die JPG-Dateien habe ich auch wiederherstellen können, bis auf eine, die mittendrin abbricht. Verwendet habe ich "Exif Untrasher", das hat am besten funktioniert. Außerdem habe ich noch "Image Rescue 3" probiert, das schien aber eher unzuverlässig.

Nun meine Probleme: Zwei AVIs sind futsch, und außerdem alle CRWs. Der Exif Untrasher hat auch die JPG-Dateien viel zu lang gemacht, so daß ich sie mühsamst von Hand gekürzt habe.

Wenn ich nun herausfinde, wo auf der Karte die JPGs jeweils liegen, dann müßten doch die zugehörigen CRWs entweder unmittelbar davor oder dahinter liegen. Blöderweise haben die keinen Header, nach dem man suchen kann, es sind einfach nur Rohdaten. Wo kann ich die denn finden? Oder werden noch Zwischendateien o.ä. berechnet, die das Dateisystem bzw. die Cluster-Reihenfolge durcheinanderbringen? Oder gibt es eine intelligente Methode, die CRWs zu finden?

Der "Image Rescue 3" hat übrigens witzigerweise nur die AVIs gefunden, die ich eh noch von der Karte lesen konnte, also ältere.

PS: Ich habe natürlich von der 8-GB-Partition ein Image gemacht, das sind zwei Mausklicks mit dem Festplattendienstprogramm, außerdem will der Exif Untrasher das sowieso haben.

PPS: Noch ein Mysterium: Die JPGs, die ich noch erfolgreich über USB-Kabel in iPhoto importiert hatte, sehen von den Farben her viel kräftiger aus als die wiederhergestellten, letztere sind unnatürlich blaß. Offensichtlich manipuliert iPhoto an der Datei herum und ändert das Farbprofil von "sRGB IEC61966-2.1" in "RGB-Profil für Kameras". Auch ein Grund, weshalb ich lieber die CRW-Dateien wiederhätte.
A720
derandi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 18.05.2009, 19:31
Wohnort: Niedersachsen

Beitragvon Kettmeister » 06.07.2009, 21:13

Hallo andi,

Leider kann ich dir bei der Beseitigung der Ursache deines Problems nicht helfen, aber die Daten bekommst du ohne Probleme mit dem Programm "R-Studio" wieder.
Leider ist das Programm nicht kostenlos. Kann mich auch nicht mehr erinnern, was ich damal dafür bezahlt habe ;-)
Aber das Programm hat bis jetzt bei mir alles wieder hergestellt.

Kannst es ja auch mal versuchen...

Gruß Kettmeister
Powershot SX10is 1.02b
Powershot A630
Powershot S100
Benutzeravatar
Kettmeister
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 169
Registriert: 11.03.2008, 19:31
Wohnort: Leipzig
Kamera(s): A630, SX10IS, S100

Beitragvon derandi » 06.07.2009, 21:21

Danke!

Aber 50 EUR ist 'ne Menge Asche. Für den Preis könnte ich die Bilder auch wieder herstellen (d.h. neu knipsen), anstatt sie wiederherzustellen (d.h. zu reparieren).

Trotzdem natürlich vielen Dank für Deine Anteilnahme! Vielleicht gibt's eine Demo-Version, die ich mal ausprobieren kann, ohne zu zahlen.
A720
derandi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 18.05.2009, 19:31
Wohnort: Niedersachsen

Beitragvon derandi » 07.07.2009, 01:42

Noch ein Nachtrag: Nachdem ich ja nun den Karteninhalt als Image gesichert hatte, wurde ich mutiger und habe mich eine risikoreichere Methode gewagt: das Reparieren des Dateisystems. Statt auf das Festplattendienstprogramm zu vertrauen, habe ich lieber direkt das Kommandozeilenprogramm fsck_msdos aufgerufen und jede Frage

/DCIM/100CANON has entries after end of directory

beantwortet mit

Truncate? no
Extend? yes

. Nach gefühlt hundert Enns und hundert Ypsilons hatte ich fast alle Dateien wieder, auch die CRWs.

Ein Hoch auf die "Bordmittel"! :D

Noch ein Tipp: Wenn die CRWs auf die Platte kopiert sind, kann man den "Browser" von GraphicConverter drauf loslassen, dann hat der Finder auch die entsprechenden Vorschaubilder, und man kann die Dateien besser identifizieren.
A720
derandi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 18.05.2009, 19:31
Wohnort: Niedersachsen


Zurück zu A-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast