[geklärt] A720IS Video

A4xx, A5xx, A6xx, A7xx, A8xx, A1xxx, A2xxx, A3xxx, A4xxx

A720IS Video

Beitragvon ferdy » 24.05.2011, 10:54

Hallo,

es ist zwar kein CHDK Problem, aber eventuell kann mir trotzdem jemand helfen. Ich war gerade in Kroatien im Tauchurlaub und habe neben den Fotos auch einige Videos gemacht. In der Kamera werden die ordentlich abgespielt. Karte raus und die .avi mit VLC angesehen kommt die Fehlermeldung AVI Datei beschädigt. Nachdem ich das erst auf CHDK geschoben habe ich gerade mal mit der Originalfirmware experimentiert.
Ich habe jetzt mal alle Videomodi getestet. Normal 640x480 (30 Bilder/Sek)spinnt und will garnicht. 640x480 (30 Bilder/Sek) LP bringt die Fehlermeldung, geht aber. Und 320x240 geht.
Hat jemand eine Idee wo da was klemmen könnte? Ach ja, andere Programme spielen die avi auch nicht ab. :?
Zuletzt geändert von ferdy am 01.06.2011, 08:04, insgesamt 1-mal geändert.
Es gibt Leute, bei denen man im Killfile sein sollte, oder man hat etwas flashc gemacht. (Henning Sponbiel in de.org.ccc)
Benutzeravatar
ferdy
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 133
Registriert: 30.10.2009, 07:35
Wohnort: Leipzig
Kamera(s): PowerShot A540, Powershot A560,
EOS 350D im 10Bar UW-Gehäuse, YS60 und SB105

Re: A720IS Video

Beitragvon msl » 24.05.2011, 12:37

Hallo ferdy,

das Problem kenne ich. Man kann sich nun streiten, ob VLC oder Canon unsauber arbeiten. Ich denke, die Videos werden durch die Canon-Software nicht richtig abgeschlossen. Deshalb bietet der VLC-Player auch eine Reparatur der Datei an.

Letztendlich habe ich aber bisher noch nie Probleme mit Weiterverarbeitung gehabt. Diverse Player spielen die Dateien auch ohne zu meckern ab. Wir werden mit diesem Umstand halt leben müssen. :D

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: A720IS Video

Beitragvon ferdy » 24.05.2011, 14:46

msl hat geschrieben:Deshalb bietet der VLC-Player auch eine Reparatur der Datei an... Wir werden mit diesem Umstand halt leben müssen. :D

Die Reparatur mit VLC funktioniert leider nicht. :cry: Aber avidemux kann damit umgehen, wenigstens ein Lichtblick. Kann man den VLC Entwicklern das Problem nicht mal ans Herz legen? Canon braucht man da sicher nicht erst zu fragen. Leider ist mein englisch dazu nicht in der Lage.
Es gibt Leute, bei denen man im Killfile sein sollte, oder man hat etwas flashc gemacht. (Henning Sponbiel in de.org.ccc)
Benutzeravatar
ferdy
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 133
Registriert: 30.10.2009, 07:35
Wohnort: Leipzig
Kamera(s): PowerShot A540, Powershot A560,
EOS 350D im 10Bar UW-Gehäuse, YS60 und SB105

Re: A720IS Video

Beitragvon gehtnix » 25.05.2011, 01:33

@ferdy,

also ich würde da mal Canon-de anmailen und mal ganz naiv anfragen wieso die AVI mit VLC abstürzen.

Aber mal was ganz Anderes.
Was hast Du denn da als Avatar. Die finde ich sehr schön, luftig leicht, aber leider unscharf zu sehen.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: A720IS Video

Beitragvon msl » 25.05.2011, 11:56

Hallo,

naja, die Videos stürzen bei der Wiedergabe nicht ab. Es wird lediglich kein Index erstellt. Dadurch ist eine Navigation (springe zu Position x) und die Ermittlung der Laufzeit im VLC-Player nicht möglich.

Ich habe die Video-Dateien jetzt noch einmal untersucht und konnte keine Fehler feststellen. Mit diversen anderen Playern und Video-Bearbeitungsprogrammen gab es keinerlei Schwierigkeiten. Die Schlussfolgerung ist also, es liegt an VLC. Erste Maßnahme - updaten. Und siehe da, es geht auf einmal. Bild Also mit der aktuellen Version verhalten sich die Videos normal wie in allen anderen Abspielprogrammen.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: A720IS Video

Beitragvon ferdy » 29.05.2011, 15:33

Ein dist-upgrade verhalf mir zu laufenden Videos. :-)
Es gibt Leute, bei denen man im Killfile sein sollte, oder man hat etwas flashc gemacht. (Henning Sponbiel in de.org.ccc)
Benutzeravatar
ferdy
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 133
Registriert: 30.10.2009, 07:35
Wohnort: Leipzig
Kamera(s): PowerShot A540, Powershot A560,
EOS 350D im 10Bar UW-Gehäuse, YS60 und SB105


Zurück zu A-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast