Probleme mit IXUS 40 SD300-Hardwaredefekt? Pufferbatterie ?

Wireless, 30, 40, 50, 55, 60, 65, 70, 75, 80, 85IS, 90IS, 95IS

Probleme mit IXUS 40 SD300-Hardwaredefekt? Pufferbatterie ?

Beitragvon johnmalkovich » 12.06.2010, 16:13

Hi alle beisammen

Bin seit einigen Tagen mehr oder weniger stolzer Besitzer einer Ixus40 und habe folgende Probleme:

zum einen importiert mir "Digitale Bilder" ( unter Leopard ) beim ersten Mal die PS.Fir mit. was mich überrascht hat, denn hatte davor ne IXUS 50 und da hatte ich dieses Problem nicht.

wobei es ja soweit auch ohne recht gut klappt, da SD-Karte gelocked .. hab CHDK trunk 906 ( glaub ich .. ziemlich aktuell , vom 12.6.2010 ) ixus40_sd300_100k drauf, und mir dann noch manuell ein paar Extra scripts und die Fonts aus dem entsprechenden CHDK-DE build drauf.

Ein weiteres und derzeit akutes Problem is, dass CHDK die Badpixel.bin nicht findet, obwohl ich sie mittels Script entwickelt hab. liegt brav wo sie sein soll und hat 0kb. doch jedesmal wenn ich "dng-format benutzen" aktivieren will, meint er ich soll das Script laufen lassen..

weiss nun nicht, da die letzten Tage (und Nächte ) die Kamera von einem zum anderen Problem gesprungen is ( mal Raws / DNGs in Ordnung, dann zu 2/3 verrauscht / gestört , nun das mit der badpixel,..), ob es sich auch evtl. um einen hardware defekt handeln kann oder evtl. um ein Problem mit der internen Pufferbatterie..

hat wer von euch Erfahrung mit so einem merkwürdigem Verhalten ?
würd mich freuen, wenn ihr helfen könnt und verzeiht, dass ich meine Kamera signatur noch nicht im Profil hab. hab noch keine Checkung wo man die findet..

Grüße, john.b.
Zuletzt geändert von johnmalkovich am 12.06.2010, 19:30, insgesamt 1-mal geändert.
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

Re: Probleme mit IXUS 40 SD300-Hardwaredefekt? Pufferbatteri

Beitragvon fe50 » 12.06.2010, 19:30

Hallo & herzlich willkommen, johnmalkovich !

johnmalkovich hat geschrieben:zum einen importiert mir "Digitale Bilder" ( unter Leopard ) beim ersten Mal die PS.Fir mit. was mich überrascht hat, denn hatte davor ne IXUS 50 und da hatte ich dieses Problem nicht.
Da hat die ältere Kamera wohl einen weniger eingeschränkten PTP (Picture Transfer Protocol) Modus, bei neueren Modellen ist die Auswahl auf wenige Dateitypen beschränkt - das dürfte also mit der Canon-Firmware zu tun haben...

Ein weiteres und derzeit akutes Problem is, dass CHDK die Badpixel.bin nicht findet, obwohl ich sie mittels Script entwickelt hab. liegt brav wo sie sein soll und hat 0kb. doch jedesmal wenn ich "dng-format benutzen" aktivieren will, meint er ich soll das Script laufen lassen..
Am Besten, du erstellst die Datei manuell, Links findest Du im Handbuch / in der CHDK wikia ( http://chdk.wikia.com/wiki/Badpixel_removal ); die Datei muss badpixel.bin heissen und im Unterordner \CHDK\ der Speicherkarte liegen.
Beim Mac musst Du evtl. sicherstellen, dass die Datei dort auch wirklich so gespeichert wird, ohne Mac-Zusätze wie Finder-Dateien oder Quarantäne-Flags...

Möglicherweise funktioniert das Ganze bei der SD300 auch gar nicht, Du kannst dann eine Dummy-Datei erstellen, siehe hier: http://chdk.setepontos.com/index.php/to ... l#msg35042

weiss nun nicht, da die letzten Tage (und Nächte ) die Kamera von einem zum anderen Problem gesprungen is ( mal Raws / DNGs in Ordnung, dann zu 2/3 verrauscht / gestört , nun das mit der badpixel,..)nicht, ob es sich auch evtl. um einen hardware defekt handeln kann oder evtl. um ein Problem mit der internen Pufferbatterie..
Die Kamera dürfte wohl in Ordnung sein; der SD300 Port wurde nicht besonders sorgfältig umgesetzt, wenig getestet, da es eben eine recht betagte Kamera ist.
Während der Portierung wurde soweit ich mich erinnere auch diverse Probleme, u.a. mit RAW & Konsorten, diskutiert. Die Pufferbatterie ist in Ordnung, wenn die Kamera im ausgeschalteten Zustand Datum & Uhrzeit behält; Du kannst auch den Akku rausnehmen, die Kamera sollte dann Datum/Uhrzeit für mindestens einige Stunden halten.

Ansonsten kannst Du noch zur Sicherheit die Speicherkarte prüfen, nur um auf Nummer Sicher zu gehen...am einfachsten die Bilder/Daten sichern, dann die Karte in der Kamera formatieren, dann CHDK neu einrichten - aber ich denke, die Kamera ist OK.
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 14:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Re: Probleme mit IXUS 40 SD300-Hardwaredefekt? Pufferbatteri

Beitragvon johnmalkovich » 12.06.2010, 19:52

fe50 hat geschrieben:Da hat die ältere Kamera wohl einen weniger eingeschränkten PTP (Picture Transfer Protocol) Modus, bei neueren Modellen ist die Auswahl auf wenige Dateitypen beschränkt - das dürfte also mit der Canon-Firmware zu tun haben...


Tja. hab bei der Ixus 40 das Problem, dass ich jpg und raw zusammen im gleichen Ordner lagern muss, damit sie sie beim Export via PTP registriert.Andernfalls nur jpegs. Ebenso fiel mir auf, dass man die Kamera erst mal ausschalten muss, um die RAWs nacher im Review modus "sichten" zu können. Allerdings hält er dann alle pics für raws und diese lassen sich dann zusätzlich auch nicht mehr rien und rauszoomen.. aber damit könnt ich noch leben.. der Witz is, gestern gingen noch DNGs damit zu exportieren. allerdings mit Kartenleser. aber immerhin. direkt in Photoshop bearbeitbar..hmm..trauer..
ich kann sie nun zwar auch bearbeiten via ufraw aber hat halt weniger Komfort..

Am Besten, du erstellst die Datei manuell, Links findest Du im Handbuch / in der CHDK wikia ( http://chdk.wikia.com/wiki/Badpixel_removal ); die Datei muss badpixel.bin heissen und im Unterordner \CHDK\ der Speicherkarte liegen.
Beim Mac musst Du evtl. sicherstellen, dass die Datei dort auch wirklich so gespeichert wird, ohne Mac-Zusätze wie Finder-Dateien oder Quarantäne-Flags...

hab ich alles so gemacht. Bootcamp an, mit diesem GCC-shell -app neuesten Trunk runtergeladen. kompiliert, formatiert, geunzipped und hoch damit.. danach noch manuell die Fonts und Scripts drauf und via bad_pixel noch n crw zu ner badpixel.bin ( 0 defekte pixel) umgewandelt..

Möglicherweise funktioniert das Ganze bei der SD300 auch gar nicht, Du kannst dann eine Dummy-Datei erstellen, siehe hier: http://chdk.setepontos.com/index.php/to ... l#msg35042


noch nicht probiert, aber evtl. ne Lösung..

Die Kamera dürfte wohl in Ordnung sein; der SD300 Port wurde nicht besonders sorgfältig umgesetzt, wenig getestet, da es eben eine recht betagte Kamera ist.
Während der Portierung wurde soweit ich mich erinnere auch diverse Probleme, u.a. mit RAW & Konsorten, diskutiert. Die Pufferbatterie ist in Ordnung, wenn die Kamera im ausgeschalteten Zustand Datum & Uhrzeit behält; Du kannst auch den Akku rausnehmen, die Kamera sollte dann Datum/Uhrzeit für mindestens einige Stunden halten.


jo . macht sie auch.

Ansonsten kannst Du noch zur Sicherheit die Speicherkarte prüfen, nur um auf Nummer Sicher zu gehen...am einfachsten die Bilder/Daten sichern, dann die Karte in der Kamera formatieren, dann CHDK neu einrichten - aber ich denke, die Kamera ist OK.


hab mir heut mal ne neue Speicherkarte gekauft, da bei der alten das Plastik spröde geworden und ein wenig gerissen ist. aber leider das gleiche..

danke auf jedenfall für die schnelle Antwort.. ich bleib dran und berichte, solte ich s eines Tages geschafft haben ;-) und sorry für die "quote"-Konfusion in dieser Antwort. is das erste Mal dass ich sowas mach..
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

Beitragvon TaiJiGong » 12.06.2010, 22:08

Hallo johnmalkovich

kann die leider nur bei der signatur helfen:

würd mich freuen, wenn ihr helfen könnt und verzeiht, dass ich meine Kamera signatur noch nicht im Profil hab. hab noch keine Checkung wo man die findet..


Wenn Du auf der WEB-Seite oben auf "Profil" klickst, siehst Du dein Profil, da gibt es dann eine Feld
"Signatur, bitte Kameramodel(le) angeben:"

Viele Grüße, TaiJiGong
Canon IXUS 100 (SD780) Firmware: 1.00C, sonst nur rein mechanische Kameras wie Pentax-MX
TaiJiGong
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 320
Registriert: 08.04.2010, 20:10
Wohnort: München
Kamera(s): IXUS100is, 100c
IXUS IIs (etwas defekt ohne CHDK)

Lösung, die ich annehmen kann, gefunden !

Beitragvon johnmalkovich » 16.06.2010, 21:52

Sooo..

hab mich heut nochmal hingesetzt und noch ein bisschen rumgetüftelt..

hab nun rausgefunden wie s funzt, dass man mit der IXUS40 SD300 DNGs erzeugen und ins OS X importieren kann.

Des Rätsels Lösung ist, dass die Ixus 40 zwar CRWs zum Rechner via PTP exportiert ( und lustigerweise auch die PS.FIR )aber keine DNGs.

Nebenbei bemerkt: dass auch nur, wenn sie im gleichen Ordner wie die jpegs gelagert sind.

also : einfach nach erstellen einer 4byte großen "badpixel.bin" benannten Dummy-datei (mit XP - fsutil filecreate.... oder so..) muss man diese noch in den CHDK Ordner hochladen. Karte raus , locken, in die Cam. starten.

ins CHDK hauptmenü -> Raw-Einstellungen gehen und dort "Raw-Datei im jpg-Ordner" nicht klicken. ( darf kein Punkt sein. wird irgendwie nach meinem Verständnis verkehrt herum gehandhabt.. ) wennd dieser Punkt nicht ausgewählt ist, speichert sie sie im jpg Ordner, was schonmal prinzipiell das exportieren ermöglicht..
dank der Dummy datei kann man nun auch DNG-Format aktivieren, was , wenn man das badpixel. lua -script benutz nicht geht, da dessen badpixel-Datei 0 und nicht 4 bytes groß ist. Nun darf man nur nicht zu weit gehen und auch noch DNG-Format aktivieren, denn das hindert die Camera daran die DNGs zu exportieren.( findet sie nicht..)

die einzige kleine Bürde die man nun noch hat, ist, dass man nach dem Importieren auf den Rechner die Dateien noch manuell umbenennen muss von xyz.crw auf xyz.dng. . dann kann man den Adobe DNG-Converter drüber laufen lassen, der alles brav in Photoshop- kompatible DNgs umwandelt..

werde mich nun noch im Automator script erstellen versuchen und . sollts klappen dieses auch in der nächsten Antwort hochladen..



Grüßchens , john m.
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

Re: Lösung, die ich annehmen kann, gefunden !

Beitragvon msl » 16.06.2010, 22:16

johnmalkovich hat geschrieben:ins CHDK hauptmenü -> Raw-Einstellungen gehen und dort "Raw-Datei im jpg-Ordner" nicht klicken. ( darf kein Punkt sein. wird irgendwie nach meinem Verständnis verkehrt herum gehandhabt.. )


Das ist schon richtig. Wenn dieser Punkt nicht aktiviert ist, werden alle RAW/DNG-Dateien immer im Ordner 100CANON gespeichert. Ist der Punkt aktiviert, werden sie auch in andere xxxCanon-Ordner gespeichert - immer dort, wo sich auch das dazugehörige JPG befindet.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4514
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

App zum simplen Umbenennen..

Beitragvon johnmalkovich » 16.06.2010, 22:22

Aloha !


Anbei noch ein mit Automator hingepfriemeltes App, das bei mir genau das tut was es soll:

guckt in nen Ordner , pickt sich die .CRWs raus und benennt sie um in .DNGs ..

et voila , weiter kanns gehen zum bearbeiten via Photoshop.. or whatever..


Is n App für OS X und man kann einfach den Ordner in dem sich die importierten CRWs befinden drauf plumpsen lassen via Drag and Drop & that ´s it ...

jut n8
Dateianhänge
CRW2DNG.zip
nur für os x
(238.86 KiB) 99-mal heruntergeladen
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

Beitragvon johnmalkovich » 18.06.2010, 16:11

upsss.. zu früh gefreut. nachdem die ersten DNG s was wurden, kamen danach nur noch so Verunstaltete wie im Anhang raus. hab mal versucht die kamera auf Werkseinstellungen zurückzusetzen, doch half nicht viel. (ein Bild ging, dann gings wieder nicht mehr..) denk es liegt irgendwie an der Badpixel.bin oder dem script. bzw wie es auf den Buffer zugreift ?. nun ja . bin am Ende meines Lateins.. vielleicht giubts ja jemanden unter euch der in dieser Materie mehr Erfahrung hat und anhand des Bildes im Anhang mir sagen kann , was da Camera intern schief läuft..

grüßle


john m.
Bild
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

Thread erledigt..

Beitragvon johnmalkovich » 18.06.2010, 23:53

hab den Thread von Herrn E.Z zum Thema Ixus 40+DNG entdeckt...

und inzwischen am photoshoppeln..
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen

kurzer nachtrag

Beitragvon johnmalkovich » 14.08.2010, 11:35

Hi alle miteinander !

Zu dem RAW-Interpreationsfehler ( wie in obigem Bild zu sehen ..) : is Kameraintern bedingt im Zusammenspiel mit Badpixel.bin. Zumindest bei der IXUS 300 SD kann man wie folgt vorgehen um wieder normale DNGs zu erhalten :

1. badpixel.bin löschen
2. auf DNG verzichten und dafür als .crw mit .wav-suffix importieren. anders gibt es Probleme im Review modus..
3. einmalig die Auflösung der Kamera ändern. also ein Bild mit 1600x 1200 schiessen anstelle von höchster Auflösung.

dann "schnackelts scheinbar und die raws die man importiert haben diesen Streifen nicht mehr.

ach ja : Bilder die man mit dem digitalen Zoom oder Digital Makro schiesst, bleiben weiterhin von diesem Problem betroffen ( nur die RAWs.. natürlich)

4. importierte .wavs ( =crws..) mit der derzeitigen Beta von DNG2PS - unter OS X ganz gut mit Crossweaver realisierbar.. - importieren und - voila- Photoshop fähige DNGs !
Canon IXUS40 SD300

2GB SanDisk
2GB Maxflash MicroSD mit Adapter

OS X 10.5.8 Leopard
Benutzeravatar
johnmalkovich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 10
Registriert: 03.10.2009, 11:32
Wohnort: Deephousen


Zurück zu 10er-Serie

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste