Problemfall: Video unscharf

1xx, 2xx, 3xx, 5xx, 7xx, 8xx, 9xx, 1xxx

Re: Problemfall: Video unscharf

Beitragvon project2 » 06.02.2014, 14:12

Hallo.

Also die Kamera fokussiert weder im normalen, noch im CHDK-Modus nach. Ich starte die Aufnahme per Hand. Zum testen habe ich die Aufnahme nah auf die PC Tastatur gerichtet, nach dem Start wurde ganz scharf fokussiert. Doch wenn ich die Kamera dann z.b. auf ein weiter entferntes Objekt richte, wird nicht mehr scharfgestellt. Es ist auch kein Ton vom Motor zu hören.

Autofokus permanent? Wo soll das im Standard Menü stehen? finde nur Servo-AF, aber der ist ja fürs fokussieren vor dem abdrücken zuständig. Und dann noch IS ... aber da geht es ja um die Verwackelungen..

Gruß
project2
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 4
Registriert: 05.02.2014, 20:32
Wohnort: Burg
Kamera(s): Ixus 115 HS

Re: Problemfall: Video unscharf

Beitragvon roijo » 07.02.2014, 12:04

Hi project2!

Ich habe mit meiner Kamera deinen beschriebenen Versuch nachgemacht und bin auf das gleiche Ergebnis gekommen!
Allerdings vermute ich, dass das Anfangsmotiv einfach zu nahe war und die Kamera dann vielleicht in einen anderen Modus schaltet. Denn wenn das Anfangsmotiv nicht zu nahe - also vielleicht ca. 70 cm - ist, dann wird auch die größere Entfernung scharf; ich habs mit meiner grad eben ausprobiert.

Zu deiner anfänglichen Frage, ob es für dein Problem ein passendes Skript gibt:
Ich bin zwar kein Spezialist, aber ich vermute, dass das beschriebene Problem nicht per Skript gelöst werden kann. So wie ich das verstehe, kann nämlich mit einem Skript nur das gersteuert werden, was grundsätzlich auch per Hand möglich wäre, bzw. Vorgänge, die die Kamera auch wirklich bietet.

Vielleicht willst du aber dein Projekt noch näher erklären - du hast nur was von einem Schwebestativ geschrieben:
Wie wird die Kamera ausgelöst? Wenn sie per Skript ausgelöst wird, mit welchem? Welche CHDK Version verwendest du? Ist die Kamera während des auslösens in Bewegung?

lg, roijo
roijo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 19
Registriert: 03.01.2014, 23:22
Kamera(s): IXUS 115 HS
Version 101c

Re: Problemfall: Video unscharf

Beitragvon project2 » 07.02.2014, 13:47

Die Kamera wird auf dem Stativ ganz normal ausgelöst, also per Knopfdruck auf den Aufnahmeknopf. Beim Start der Aufnahme ist die Kamera nicht in Bewegung. Die Startsekunde wird nachträglich weggeschnitten, weshalb es keines Skriptes erfordert. CHDK Version ist die aktuelle Vorschau-1.3.

Das mit den unterschiedliche Bereichen der Scharfstellung hatte ich auch schon vermutet. Starte ich aber auf ein entferntes Objekt und gehe dann auf ein näheres (nicht Makro), stellt er auch nicht scharf. Ebensowenig beim heran-/rauszoomen. Habe auch extra mal ein Ohr drangehalten und es ist nichs zu hören.

Gruß
project2
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 4
Registriert: 05.02.2014, 20:32
Wohnort: Burg
Kamera(s): Ixus 115 HS

Re: Problemfall: Video unscharf

Beitragvon roijo » 07.02.2014, 23:26

Tja, hier wäre es ganz gut, mal die Meinung eines Experten zu hören:
Wie läuft das wirklich mit dem AF bei einer Videoaufnahme ab?

Im Foto Modus mit aktiviertem AF Servo kann man es ja gut hören, wie ständig nachfokussiert wird. Im Video Modus scheint die Sache aber irgendwie anders zu funktionieren - vermutlich wird einfach eine möglichst hohe Tiefenschärfe verwendet.

Bei mir ist dieses Problem jedenfalls nichts so brennend, weil ich bei meinen Flugaufnahmen ohnehin nur weit, bis sehr weit entfernte Objekte vor der Linse habe und auch nicht zoome.

Vielleicht meldet sich ja noch ein Experte,
eine Antwort würde mich jedenfalls auch interessieren...

lg, roijo
roijo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 19
Registriert: 03.01.2014, 23:22
Kamera(s): IXUS 115 HS
Version 101c

Re: Problemfall: Video unscharf

Beitragvon roijo » 02.03.2014, 17:02

Ergebnisbericht nach etwa 13 Flügen mit insgesamt 87 Fotos und 28 Videos:

Sämtliche Fotos und Videos waren scharf! Und das mit aktiver Bildstabilisierung!
Ich meine halt "scharf" in dem Sinne, was man von einer solchen Kamera erwarten kann. Wenn ich Fotos "per Hand" schieße, werden sie auch so wie die Flugaufnhamen.

Also hier nochmals alles zusammengefasst:
Kameratyp: IXUS 115 HS
CHDK Version: 1.3

Foto Auflösung: 4000x3000
Bei den Fotoaufnahmen habe ich auch die RAW Daten mitgespeichert - auch das führte zu keinen Problemen.
Video Auflösung: 1920x1080 (also Full HD)
IS-Modus: "Nur Aufnahme"
(bei Videoaufnahme wird dabei automatisch kameraintern auf "Kontinuierlich" umgestellt)

Als Skript verwende ich mein eigenes "fv.bas" - damit kann ich per Fernbedienung wahlweise Fotos schießen oder Videos aufnehmen. Es hat bisher tadellos funktioniert!
Weiter vorne in diesem Beitrag habe ich das Skript bereits veröffentlicht - ich stelle hier aber für Interessierte nochmals die ganze Datei bereit.

lg, roijo

Kurze Erklärung zum Skript: Man benötigt dazu einen USB Auslöser den man selbst bauen kann (RC Auslöser)
Mit einem Schalter den man auf seiner Fernbedienung definiert, kann man dann einen Impuls an die Kamera schicken der dann per Skript entsprechend verarbeitet wird: Mit einem kurzem Impuls (<=1sec.) wird ein Foto geschossen und mit einem langen Impuls (ca.2sec.) eine Videoaufnahme gestartet - bzw. mit einem beliebigen weiteren Impuls wieder gestoppt. Man kann auch mit einem sehr langen Impuls (>10 sec.) die Kamera ausschalten.
Dateianhänge
fv.bas
Skript zum Fotografieren und Video aufnehmen per Fernbedienung
(558 Bytes) 67-mal heruntergeladen
roijo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 19
Registriert: 03.01.2014, 23:22
Kamera(s): IXUS 115 HS
Version 101c

Vorherige

Zurück zu 100er/1000er-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste