Update:Messungen der Stromaufnahme IXUS 860IS

1xx, 2xx, 3xx, 5xx, 7xx, 8xx, 9xx, 1xxx

Update:Messungen der Stromaufnahme IXUS 860IS

Beitragvon Jörg aus Dresden » 25.06.2008, 12:56

Messungen der Stromaufnahme (mAmpere)
--------------------------------------------------


Setup:
Stromversorgungsgerät @4V, Strom direkt abgelesen und gerundet

Ergebnisse:
Bildwiedergabe 120-190
Bildaufnahme Shutter halb gedrückt: 400-480
Aufnahmebereitschaft 320-380
Aufnahmebereitschaft Klinkenstecker 280
Aufnahmebereitschaft Monitor aus (print taste) 98
Blitz laden 950 für 3s
Sound Aufnahme 180
Sound Wiedergabe 150
Video Aufnahme 450
Video Wiedergabe 160
Aus 0.01

Einflüsse:
IS spielt keine Rolle
Skript laufen spielt keine Rolle
Bildschirm an kostet 50..130mA

Diskussion:´
1. Knipsen kostet nicht viel mehr Strom als Bild komponieren
2. Bildschirmhelligkeit verringern bringt <80mA
3. Blitz kostet kaum mehr Strom
4. Klinkenstecker lohnt sich kaum ggü Bildschirm dunkelste Einstellung

Viele Grüße
Jörg
Zuletzt geändert von Jörg aus Dresden am 13.08.2008, 08:47, insgesamt 4-mal geändert.
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Beitragvon fe50 » 28.07.2008, 13:31

Hallo Jörg,

habe ich das richtig verstanden, Du hast den Netzadapter ACK-DC30 von Canon im Einsatz ?

Wenn ja: könntest Du ein paar kleine Bilder (Kontaktseite, Steckerseite, Typenschild des externen Netzteils) hochladen ?

Ich plane, mir einen Dummy mit externem Batteriepack zu basteln, da wäre für mich noch interessant, mit welcher Spannung die Ixus 860 da zurechtkommt (Du schreibst ja 4V, einige Powershot-Modelle sind anscheinend sehr wählerisch und akzeptieren nur ein Spannungsfenster von +/- wenigen 100mV).
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Beitragvon PhyrePhoX » 28.07.2008, 13:54

4. fehlt-Einfluss von Bildschirm ausschalten (klinkenstecker)


bitte nachholen. ansonsten sehr gut ;)
Benutzeravatar
PhyrePhoX
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 490
Registriert: 04.07.2008, 22:31

Netzteil

Beitragvon Jörg aus Dresden » 07.08.2008, 13:54

Hallo,
ich habe ein Labornetzteil verwendet und zwei Drahtenden zu Haken gebogen und in die Kontakte eingehakt.
Aber ein Stück Holz mit den Kontakten an der richtigen stelle sollte kein Problem sein. Oder ein Billigakku ausschlachten (3.99 Eu) zu was anderem sind sie ja nicht gut. :-)

Mal was anderes:Hast Du eigentlich die LEDs an der 860IS schon mal mit einem Programm zum leuchten gebracht?

Viele Grüße
Jörg
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Re: Netzteil

Beitragvon fe50 » 07.08.2008, 14:04

Hi Jörg,
danke für die Info, ich bastle mal, sobald ich Zeit dazu finde...
Mal was anderes:Hast Du eigentlich die LEDs an der 860IS schon mal mit einem Programm zum leuchten gebracht?

Ja - mit eigenem Code (zum Test, unvollständig); die LED-Testscripts funktionieren nicht, die LED-Routinen sind im Code auskommentiert bzw. noch gar nicht kodiert. Mal schauen, evtl. kann ich am Wochenende den Code komplettieren, testen & PhyrePhox zum Integrieren schicken... ;)

*EDIT: So, wie versprochen...LED's funktionieren, ohne Intensitäts-Steuerung...


LED_GREEN 4 ok
LED_YELLOW 5 nicht verfügbar
not used 6 --
LED_ORANGE 7 ok
LED_BLUE 8 ok
LED_AF_BEAM 9 ok
LED_TIMER 10 wie AF_Beam

Alles anbei im .zip-file (diskboot.bin zum testen, Allbest51-trunk462; primitives Testscript (absichtlich ohne Schleifen etc.) "LED870.bas" & natürlich die das diff zum trunk463...
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Testversion SD870 mit LEDs

Beitragvon fe50 » 10.08.2008, 16:31

Testversion Ixus 860 (SD870) mit funktionierender LED - Ansteuerung, basierend auf Allbest #51-462(473), Info's & Download ist im vorheriger Beitrag zu finden...bitte mit enthaltenem Testscript testen & hier oder per PM an mich eine kurze Rückmeldung geben...

*Edit: Im aktuellen Allbest-trunk und im Juciphox-build bereits von Phyrephox eingepflegt, somit ab sofort in allen folgenden Autobuild-Versionen enthalten !
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Re: Testversion SD870 mit LEDs

Beitragvon Jörg aus Dresden » 12.08.2008, 10:23

Hallo fe50
schönen Dank erstmal dür die schnelle Hilfe.
habe mir CHDK-ixus860_sd870-100c-0.2.7-476_complete.zip
runtergeladen.
Damit funktioniert das testscript nicht.

Muß ich noch irgendwas einstellen?

Viele Grüße
Jörg
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Re: Testversion SD870 mit LEDs

Beitragvon fe50 » 12.08.2008, 11:03

Jörg aus Dresden hat geschrieben:Hallo fe50
...habe mir CHDK-ixus860_sd870-100c-0.2.7-476_complete.zip
runtergeladen.
Damit funktioniert das testscript nicht.
Muß ich noch irgendwas einstellen?

Hallo Jörg,

sorry, mein Fehler - ich dachte, PP hätte es auch im Juciphox eingebaut, momentan ist die geänderte LED-Steuerung für die SD870 aber nur im "normalen" trunk, mit dem aktuellen Allbest #51-475 Autobuild müsste es also funktionieren, ebenso mit meiner Testversion (s.o.).
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Re: Testversion SD870 mit LEDs

Beitragvon Jörg aus Dresden » 12.08.2008, 12:54

OK geht.
Vielen Dank.

Ich habe die Strommessungen um Messungen mit Skript und Klinkenstecker ergänzt.

Noch was anderes. Ich fände es sehr praktisch, wenn es eine Option zum dauerhaften Aktivieren der Serienbildfunktion gäbe.
Unverständlicherweise stellt sich das jedesmal beim Ausschalten zurück.

Das wäre doch sicher nicht schwer als Option ins CHDK einzubauen. Wie/Wo muß man diesen Wunsch vortragen?

Viele Grüße
Jörg
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Re: Testversion SD870 mit LEDs

Beitragvon fe50 » 14.08.2008, 11:22

Jörg aus Dresden hat geschrieben:...Noch was anderes. Ich fände es sehr praktisch, wenn es eine Option zum dauerhaften Aktivieren der Serienbildfunktion gäbe.
Unverständlicherweise stellt sich das jedesmal beim Ausschalten zurück. ...

Hallo Jörg,
Tja, Canon stellt aus "Sicherheitsgründen" manche Einstellungen auf Standardwerte zurück; die Speicherung von Einstellungen (Canon & CHDK) wurde schon mehrfach im e-Forum diskutiert / als "Feature Request" formuliert...

Das kannst Du eigentlich ganz einfach per Autostart-Script haben, z.B. damit:
Code: Alles auswählen
@title SD870 Bootup
if autostarted = 0 then goto "Exit"
if get_drive_mode = 0 then
  click "shoot_half"
  sleep 900
  click "down"
  sleep 40
  click "down"
  sleep 40
  click "set"
  sleep 40
endif
:Exit
  cls
  exit_alt
end

-> Script laden, Autostart auf On ==> NUR JUCIPHOX-BUILD !!!

Dann wird zukünftig dieses Script beim Einschalten (On/Off und PLAY - Tasten !) direkt in den Aufnahmemodus geschaltet (click "shoot_half"), dann per Tastenemulation (2x runter) der Reihenmodus gewählt und bestätigt (set). Anschliessend wird der ALT-Modus abgeschaltet, somit kann normal geknippst werden...

Auf diese Art kann eigentlich alles per Script definiert und dann beim Start eingestellt werden...
Wird das Script manuell gestartet, macht es nichts...
Dateianhänge
_sd870.bas
_sd870.bas: Autosart-Script für SD870
(Startet direkt im Reihenbild-Aufnahmemodus) NUR JUCIPHOX-BUILD !!!
14.08.08/fe50
(257 Bytes) 74-mal heruntergeladen
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a


Zurück zu 100er/1000er-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast