Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry Pi

Kamera-Hardware, Selbstbaufernbedienung und sonstige Hardware-Erweiterungen

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon msl » 13.03.2017, 22:31

Hallo zusammen,

prinzipiell finde ich es nicht in Ordnung, eine Software pauschal zu verurteilen, weil etwas schief gegangen ist, ohne die Ursache genauer zu erforschen. Bei mir funktioniert das Programm. Die Ursache für vereinzelte Lese- und Schreibprobleme lag eher an "wackliger" Hardware.

Dass die Mikro-SD-Karte nicht mehr funktioniert, ist sehr ärgerlich. Die Ursachen können aber sehr unterschiedlicher Art sein. Wurden zur "Wiederbelebung" mal die Hardware-Voraussetzungen geändert, z.B. Kartenleser, Kartenadapter und/oder Rechner. Ich würde mal versuchen, die Karte mit einer Kamera anzusprechen bzw. zu formatieren. Das ist übrigens auch eine gute Methode, Partitionen und Inhalte einer Karte zu leeren.

Den Programmen, die Laufwerksabbilder schreiben und lesen, ist es eigentlich egal, ob und wie viele Partitionen vorhanden sind. Sie benutzen die Rohdaten. Deshalb ist beim Schreiben einzige Voraussetzung, dass das Ziel mindestens die gleiche Größe hat.

Eine Überlegung bei der Erstellung von Abbildern wäre noch, die SD-Karte nicht bis zum letzten Byte zu partitionieren. Man könnte einen kleinen Rest unpartitioniert lassen.

Soweit ein paar Überlegungen.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4510
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 14.03.2017, 00:52

@msl

es steht Dir frei selber auszuprobieren, Deine eigene Raspi-SD-Karte via "Win32 DiskImager" auf Festplatte zu sichern und wiederherzustellen.
Aus gegebenem Anlass (nicht mehr ansprechbare SD-Karte) bin ich selber momentan aber nicht mehr zu weiteren Experimenten mit dem Programm "Win32 DiskImager" bereit.

Bei Erfolg müsstest Du aber zudem testen, wie "tolerant" dieses Programm dabei auf die minimal unterschiedlichen Partitionsgrößen unterschiedlicher SD-Karten mit offiziell gleicher Größe reagiert (bei mir jeweils 32 GB Karten). Das Rücksichern einer Image-Datei sollte ja auch auf eine bzgl. ursprünglichen Fabrikat nicht identische Speicherkarte mit offiziell gleicher Größe möglich sein.
Das ist ja noch mal so ein Thema für sich (siehe meinen nächsten Absatz an Rudi).

Falls der "Win32 DiskImager" ja tatsächlich grundsätzlich funktionieren sollte sollte er aber auch das eben genannte können.

Ansonsten funktioniert die kaputte SD-Karte nirgendwo mehr, egal welcher USB-Port, welcher Card-Reader, welches OS, welche Cam.

@Rudi

Mein vorgeschlagenes Alternativ-Programm "Roadkil's Disk Image" läuft erstaunlich stabil, ist aber beileibe noch nicht perfekt.
Grundsätzlich kann es die (jeweils 32 GB großen) SD-Karten sichern und zurückspielen. In meinen Tests wurden dabei Mikro-SD-Karten von folgenden Herstellern verwendet: Sandisk, Medion und Platinum.

Nur beim Aufspielen der alten und neuen Rasbian-Installation auf meine SD-Karte von Medion kam es jeweils zu einer Fehlermeldung (siehe Bild im Anhang).
Trotzdem lief mein Raspi 3 mit dieser SD-Karte anschließend jeweils einwandfrei hoch!

Zu Acronis Trueimage:

Meine gebrannte Acronis Boot-CD ist sicherlich meine meist gebrauchte CD an meinen diversen PCs (für Backup-Zwecke).
Allerdings basiert m.W. nur die Acronis Boot-CD auf Linux und ist für diese Zwecke wahrscheinlich ebenfalls geeignet (das muß ich aber noch ausprobieren).
Eine installierte Windows-Version von Acronis Trueimage könnte dagegen Probleme bekommen beim Erkennen der vielen Partitionen auf der Raspi Speicherkarte.
Allerdings installiere ich die Windows-Version von Acronis Trueimage ab Version 2015 nicht mehr, weil die zu tief ins System eingreift. Zum Sichern/Zurücksichern reicht ja die bootfähige CD davon aus.

Liebe Grüße
Werner_O
Dateianhänge
Fehlermeldung.gif
Fehlermeldung
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon msl » 14.03.2017, 22:34

Hallo,
Werner_O hat geschrieben:es steht Dir frei selber auszuprobieren, Deine eigene Raspi-SD-Karte via "Win32 DiskImager" auf Festplatte zu sichern und wiederherzustellen.
Ich hatte es schon mehrfach geschrieben, dass es bei mir funktioniert. Nun aber noch einmal detailliert und bebildert beschrieben.

Folgende Testbedingungen:
  • Windows 10 64 Bit, I5-Prozessor, 8 GB RAM
  • Win32 Disk Imager Version 1.0 portable
  • Transcend-USB-Kartenleser mit nativem Mikro-SD-Karten-Schacht
  • 16 GB Mikro-SD-Karte Intenso und No Name; 32 GB Mikro-SD-Karte Medion - alle Class 10

Zum Testen habe ich ein OpenElec-Image für den Raspberry Pi verwendet, weil das gerade parat war. Es enthält eine 512 MB große FAT-Partition sowie eine 4,11 GB große Ext4-Partition.
Bild

Das Image wurde von der Intenso-Karte erstellt.
Bildfoto hochladen
Bildfotos hochladen

Danach habe ich es auf alle drei genannten Karten geschrieben.
BildKostenloses Bilderhosting
Bildpicupload

Der Raspberry Pi startete das OpenElec-Mediacenter mit allen Karten ohne Vorkommnisse.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4510
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 18.03.2017, 17:51

Hallo zusammen,

@Rudi

Acronis Trueimage eignet sich leider nicht zum Sichern/Wiederherstellen von USB-Volumes (zumindest nicht meine bootfähige CD mit Acronis 2015). Beim Wiederherstellen von Images fehlt die Möglichkeit, diese auch auf SD-Karten schreiben zu können. Als Ziel können nur erkannte HD-Laufwerke ausgewählt werden. Angeschlossene SD-Karten bleiben außen vor.

@msl

Mein inzwischen auf die seit kurzem verfügbare upgedatete Programm-Version 1.0 von "Win32 DiskImager" ist leider nicht in der Lage, meine 32GB Raspi-SD-Karte überhaupt noch zu erkennen. Insofern kann ich mit dieser neuen Programm-Version von "Win32 DiskImager" meine 32GB Rapsi-SD-Karte weder sichern noch zurückspielen.

Mit dem von mir alternativ vorgeschlagenen Programm "Roadkil's DiskImage v1.6" speichere ich momentan aber gerade genau diese 32GB Raspi-Speicherkarte in ein Image (mit allen vier Partitionen). Dieses Programm funktioniert also wie gewünscht.

Insofern bleibt für mich nur festzustellen, daß das Programm "Roadkil's DiskImage v1.6" augenscheinlich wesentlich mächtiger als das Programm "Win32 DiskImager" ist, weil es eben das macht was es soll. Darum möchte es hiermit nun erneut als die bessere Alternative zu "Win32 DiskImager" empfehlen.

Mit der aktuellen Programmversion v1.0 vom "Win32 DiskImager" bekomme ich dagegen leider erst gar nicht die Möglichkeit dazu, meine Raspi-SD-Karte überhaupt sichern zu können, weil ich diese SD-Karte erst gar nicht auswählen kann!
Ebenso wie "Roadkil's DiskImage v1.6" kann dabei aber auch das Programm "Minitool Partition Wizard 10" diese Karte erkennen (siehe angehängtes Bild). Da der "Win32 DiskImager" das dagegen nicht schafft, ist dieses Programm darum m.E. auch nicht wirklich empfehlenswert.

Nachtrag 19.03.2017:

<<
Für Forenuser ist es letzlich unerheblich, welches der beiden genannten Programme verwendet wird, solange jeweils erfolgreich eine Raspi3-SD-Karte gesichert und wieder zurückgeschrieben werden kann.
Laut den Ergebnissen von msl geht das auch mit dem "Win32 DiskImager", und ich möchte das nicht anzweifeln.
Das von mir bevorzugte Programm "Roadkil's DiskImage v1.6" ist m.E. aber aus meinen genannten Gründen "mächtiger".

Es gibt aber keinen Grund für einen Glaubenskrieg zwischen diesen beiden Freeware Programmen, welche beide jeweils ihre Schwächen haben.
Insofern ist es auch recht unerheblich, daß mein erstelltes Raspi3-Image mit "Roadkil's DiskImage v1.6" erstellt wurde.

Nachträglich gesehen ist es nur suboptimal, daß mein Raspi3-Image eine 32 GB SD-Karte erfordert. Grundsätzlich hätte dazu bereits eine nur 16 oder 8 GB große Karte ausgereicht.
Meine nachträglichen Versuche, mein Raspi3-Image auf 16 oder 8 GB zu verkleinern, sind aber leider gescheitert:
Mithilfe eines gestarteten Linux in Form von "Knoppix 7.6" kann ich zwar auf der SD-Karte das logische Laufwerk "root" wie gewünscht verkleinern, nicht aber die Größe der sogenannte "erweiterte Partition", auf welcher dieses logische Laufwerk residiert.
Zum Zurückspielen meines Raspi3-Images ist darum zwingend eine mind. 32 GB große MicroSD-Karte nötig.
>>

Liebe Grüße
Werner_O
Dateianhänge
Partitionen.gif
Partitionstabelle
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 09.04.2017, 21:54

Hallo zusammen

msl schrieb:
prinzipiell finde ich es nicht in Ordnung, eine Software pauschal zu verurteilen, weil etwas schief gegangen ist, ohne die Ursache genauer zu erforschen. Bei mir funktioniert das Programm. Die Ursache für vereinzelte Lese- und Schreibprobleme lag eher an "wackliger" Hardware.

Auf diese Worte hin habe ich dem Programm "Win32 Disk Imager" eine zweite Chance gegeben und versucht, ein mit diesem Programm erstelltes Raspi3-Image auf eine baugleiche Speicherkarte (Sandisk 32GB Ultra Micro) zurückzuschreiben, wobei ich auch einen anderen Cardreader verwendet habe.

Das Ergebnis war aber leider wiederum erschreckend:
Auch diese recht teure Sandisk Speicherkarte ist nun Schrott und kann leider nur noch entsorgt werden. Auf diese Karte ist kein Zugriff mehr möglich. Eine dritte Chance gebe ich dem Programm "Win32 Disk Imager" aber nun nicht mehr:
Finger weg von diesem Programm, wenn ein Raspi gesichert und zurückgeschrieben werden soll!

Ansonsten ist aber auch das Programm "Roadkil's Disk Image" noch fehlerhaft. Ich brauchte heute vier Ansätze, um ein Image auf eine andere baugleiche Speicherkarte zurückzuschreiben. Ich mußte mehrfach mit dem Programm "Minitool Partition Wizard" die Partition/en auf dieser SD-Karte löschen. Zudem endete "Roadkil's Disk Image" mit einer Fehlermeldung, obwohl diese SD-Karte dann anschließend einwandfrei an meinem Raspi3 hochlief. Das wirkt alles andere als vertrauenserweckend ...

Die mit dem Programm "Roadkil's Disk Image" erstellte neue SD-Karte funktioniert aber einwandfrei - und genau darauf kommt es an!

Last not least:
Meine S100 kann ich via Raspi und CHDKptp leider nicht nutzen, weil die via CHDKptp keine Befehle annimmt und auch der Bildschirm dunkel bleibt. Keine Ahnung warum, aber anscheinend ist die Portierung dieser CAM auf CHDK 1.5 noch fehlerhaft.
Meine SX20 und SX240 (jew. CHDK 1.5) funktionieren dagegen einwandfrei am Raspi3 via CHDKptp.

Insofern würde ich schon gerne wissen, warum ausgerechnet meine S100 noch Probleme macht.

Ein momentan recht frustrierter
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon msl » 11.04.2017, 12:40

Hallo,

ich habe Rücksprache mit waterwingz aus dem internationalen Forum gehalten. Er besitzt eine S100 und hat bestätigt, dass es keinerlei Probleme beim Verbindungsaufbau zwischen Kamera und chdkptp gibt. Es wird also vermutlich ein lokales Problem sein.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4510
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 11.04.2017, 21:40

Hallo msl,

Danke für diese Info.

Ich habe die S100 nun auch an meinem Laptop mit Windows 7 64bit eingerichtet (Stichwort: libusb-treiber).
Anfängliche Probleme wie kein Bild an der Cam nach Anschluß via USB uvam. konnte ich durch einen Windows-Neustart beheben. Beim ersten Versuch einer Verbindung zu chdkptp für Windows war die S100 ja sogar komplett abgestürzt und ich mußte den Akku rausnehmen, um das Problem durch einen Hardcore-Neustart zu lösen.
Nach dem Windows Neustart funktioniert nun aber alles wie gewünscht. Auch bei laufendem chdkptp kann ich die S100 ein-/ausschalten und/oder das USB-Kabel an-/abstecken. Meine S100 bleibt dabei nun stets ansprechbar, wobei der TFT der S100 dabei nie ausgeht.

An meinem Raspi3 funktioniert die S100 dagegen nicht. Sobald ich sie via USB-Kabel am Raspi 3 anstecke, wird der Bildschirm der S100 dunkel.
Die Raspbian-Version von chdkptp erkennt zwar diese CAM und kann auch (zumindest angeblich) "connecten", aber eine Steuerung meiner S100 ist nicht möglich. Ich kann noch nicht mal via chdkptp auf "REC" umschalten - das Objektiv bleibt eingefahren.

Das unerwartet erschreckende ist dabei das Ausgehen des Displays der S100, sobald ich sie via USB am Raspi3 anschließe. Das chdkptp für Rasbian kann die S100 zwar erkennen und sogar connecten, aber die S100 bleibt trotzdem völlig unsteuerbar.
Diese Ergebnisse legen nahe, daß es nicht an chdkptp sondern möglicherweise auch an den Linux-Treibern für Rasbian für die Canon Powershots liegen könnte. So wirklich wahrscheinlich erscheint mir das aber nicht, weil meine SX20 und SX240 ja am Raspi3 jeweils einwandfrei laufen.

Alternativ könnte es aber auch neue Fehler in CHDK geben, die sich irgendwie eingeschlichen haben und nun diese Probleme verursachen.
Ich bin mir dabei zu 99% sicher, daß eine ältere CHDK-Version für die S100 schon mal erfolgreich an meinem Raspi3 mit chdkptp gelaufen ist!
Aktuell verwende ich CHDK 1.5 4785 - ich suche jetzt erst mal die älteste CHDK-Version für meine S100, die ich auf irgendeinem Datenträger finden kann...

Nachtrag 23:41 Uhr:
Ältere CHDK Versionen zur S100 101a finde ich leider nicht mehr - die habe ich wohl gelöscht.
Insofern kann ich auch nicht mehr nachträglich verifizieren, ob diese älteren CHDK-Versionen an meinem Raspi3 funktioniert haben.
Ich bin davon aber felsenfest überzeugt, weil ich eine Email an den Besitzer der S100 geschrieben hatte mit der Aussage, daß die S100 auch an meinem Rapsi3 via chdkptp funktioniert. Ich muß es also schon mal erfolgreich mit einer älteren als der aktuellen CHDK-Version hinbekommen haben. So eine Email schreibe ich ja erst dann, wenn ein Test auch tatsächlich (sprich nach Ausprobieren) erfolgreich war.

Jetzt ist guter Rat teuer...

Liebe Grüße
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 13.04.2017, 21:22

Hallo zusammen,

ich habe jetzt weitere Versuche mit meinem CAMs gemacht, um mehr Licht in den Dschungel bringen zu können.

Zunächst habe ich unter Windows zum bisherigen Windows-chdkptp r723 auch die neuere Version r735 installiert, wobei die S100 dabei auch mit r735 funktioniert. Auf meinem Raspi3 läuft ja bereits die neuere Rasbian-Version von chdkptp r735.

Danach habe ich alle meine CAMs (außer der uralten S3) mal an meinem Raspi3 angeschlossen und geschaut, was es dabei für Unterschiede gibt.
Das Testszenario war dabei immer gleich:
Zunächst chdkptp r735 starten, auf den Reiter "Live" gehen und dort in der Sektion "Stream" die Häkchen bei "Viewfinder" und "GUI Overlay" setzen.
Danach
a) Die CAM via USB anschließen und via PLAY-Taste im Wiedergabemodus starten
b) In chdkptp auf den Connect-Button drücken
c) Die CAM via chdkptp-Button REC in den Aufnahmemodus setzen
d) Die CAM via chdkptp-Button PLAY in den Wiedergabemodus setzen
e) In chdkptp auf den Disconnect-Button drücken
und schauen, was jeweils passiert

1) Test mit meiner SX20:
a) Der TFT der SX20 geht an und bleibt an
b) chdkptp zeigt das akuelle Wiedergabebild, der TFT der SX20 bleibt dabei an
c) Der TFT der SX20 bleibt an und zeigt ein Bild, ebenso wie chdkptp
d) Die SX20 geht in den Wiedergabemodus und der TFT bleibt an - auch chdkptp zeigt das jeweilige Wiedergabebild
e) Der TFT der SX20 bleibt an

2) Test mit meiner SX240:
a) An der CAM kommt kurz das CHDK-Startlogo, danach geht der TFT der SX240 aus
b) chdkptp zeigt das akuelle Wiedergabebild, der TFT der SX240 bleibt aber weiterhin aus
c) Der TFT der SX240 geht an und zeigt ein Bild, ebenso wie chdkptp
d) Die SX240 geht in den Wiedergabemodus und der TFT bleibt an - auch chdkptp zeigt das jeweilig Wiedergabebild
e) Der TFT der SX240 bleibt an

3) Test mit meiner S100:
a) An der CAM kommt kurz das CHDK-Startlogo, danach geht der TFT der S100 aus
b) chdkptp zeigt das akuelle Wiedergabebild, der TFT der S100 bleibt aber weiterhin aus
c) Der Druck auf die REC-Taste von chdkptp zeigt keinerlei Wirkung:
Der TFT der S100 bleibt aus und das Objektiv fährt auch nicht aus - chdkptp zeigt weiterhin nur das letzte Wiedergabebild.
Nach einem "Disconnect" zeigt chdkptp auch keine Verbindung mehr zur S100 an.
Allerdings lässt sich die S100 nun noch nicht mal mehr ausschalten - man muß den Akku rausnehmen, um die S100 wieder neu verwenden zu können :-(

Möglicherweise liegt das alles daran, daß ich mein Rasbian vor nicht allzu langer Zeit auf die neueste Version aktualisiert habe.
Das ist aber nur eine Theorie von mir ohne jegliche echte Grundlage. Zumindest "rein theoretisch" sollte ja auch eine neuere Rasbian-Version meine CAMs korrekt erkennen können.
Die Frage bleibt aber, warum nur die S100 Probleme macht, nicht aber meine SX20 oder SX240.

Fazit:
Meine S100 kann ich an meinem Raspi3 definitiv nicht verwenden!
Als "Tester" der S100 habe ich nun im Vergleich zu meiner SX20 und SX240 das unterschiedliche Verhalten dieser CAMs möglichst genau dargestellt. Mehr kann ich vorläufig nicht machen.
Hoffentlich können die jeweiligen CHDK-Entwickler aus meinen Testergebnissen Ideen dazu schöpfen, was noch korrigiert werden muß.

Nachtrag 00:05 Uhr:

<<
Ich habe jetzt doch noch auf HD die älteren CHDK-Versionen 1.5 v4722 und v4755 gefunden und jeweils ausprobiert. Aber auch bei denen kommen die genannten Fehler.

Da ich mir zu 100% sicher bin, daß zumindest eine dieser Versionen schon mal erfolgreich an meinem Raspi3 gelaufen ist, bleibt logisch gesehen nur mein gemachtes Rasbian-Update auf die aktuelle Version als Ursache übrig für die Probleme mit meiner S100.

Um das zu verifizieren müßte ich aber eine ältere Rasbian-Version zurückspielen und ich weiß noch nicht, ob ich davon überhaupt ein Image habe. Eine vollständige Neuinstallation mit einem älteren Rasbian kommt für mich aber nicht infrage - ich habe dafür momentan leider nicht die Zeit :-(
>>

Liebe Grüße
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 14.04.2017, 15:30

Hallo zusammen,

endlich habe ich den Fehler gefunden:
meine S100 funktioniert nicht mit der neuesten Rasbian Version von chdkptp r735!
Mit der älteren Rasbian Version von chdkptp r723 funktioniert sie dagegen (siehe angehängtes Bild) :-)

Als Übergangslösung habe ich jetzt beide Versionen auf meinem Raspi parallel installiert, bis eine zukünftige fehlerbereinigte Version von chdkptp für Rasbian mit allen meinen CAMs funktioniert.

Jetzt sollte ergründed werden, warum die Rasbian Version von chdkptp r735 zwar mit meiner SX20 und SX240 funktioniert, nicht aber mit meiner S100. Die Windowsversion r735 funktioniert ja auch mit der S100 wie im vorherigen Posting beschrieben.

Liebe Grüße
Werner_O
Dateianhänge
S100.jpg
Screenshot S100 mit chdkptp r723
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon msl » 16.04.2017, 10:04

Hallo,

da die meisten Probleme bei der chdkptp-Raspi-Version durch Gphoto-Prozesse verursacht werden, ist meine erste Frage, wurden die Hinweise aus diesem Beitrag berücksichtigt? Wenn ja, müsste analysiert werden, ob andere Prozesse die "Problemkameras" in Beschlag nehmen.

Die Änderungen in chdkptp zwischen Revision 723 und 735 sollten eigentlich keine Auswirkungen auf das Kameraverhalten haben.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4510
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 17.04.2017, 21:45

Hallo msl,

diesen genannten Beitrag von Dir hatte ich leider völlig übersehen :-(

Nachdem ich am Raspi bei der Datei "chdkptp_gui.sh" am Anfang diese drei zusätzlichen Zeilen eingefügt habe funktioniert nun auch Version r735 mit meiner S100 :-)

Danke für Deine Hilfe und liebe Grüße
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 18.04.2017, 21:43

Nachtrag:

msl schrieb:
Die Änderungen in chdkptp zwischen Revision 723 und 735 sollten eigentlich keine Auswirkungen auf das Kameraverhalten haben.

Bei mir haben sie aber unterschiedliche Auswirkungen auf meine S100:
Die drei zusätzlichen Zeilen (zum Deaktivieren eines Dienstes) bei der Datei "chdkptp_gui.sh" brauche ich ja nur bei r735, nicht aber bei r723.

Rein logisch gesehen muß r735 also irgendetwas anders als r723 machen, was dann zu diesen Unterschieden führt.
Woran es genau liegt, weiß ich aber natürlich leider nicht.

Soviel zur Info,
liebe Grüße
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Re: Wlan-Kamera-Fernsteuerung inkl. Live-Bild mit Raspberry

Beitragvon Werner_O » 22.04.2017, 17:21

Hallo zusammen,

in einem weiteren Test habe ich auch meine uralte S3 zusätzlich getestet.
Auch die ist am Raspi3 via chdkptp r723 und r735 steuerbar, ohne dazu irgendwelche Rasbian-Dienste deaktivieren zu müssen.

Es blieb darum die Frage, warum von meinen vier CAMs einzig und allein nur meine S100 mit chdkptp r735 Probleme hat und nur dann funktioniert, wenn ein laufender Rasbian-Dienst zuvor beendet wurde.
Bei der Suche nach einer Begründung dafür ist mir dabei eingefallen, daß von meinen vier CAMs nur die S100 auch GPS hat.
Rein logisch gesehen blieb darum das bei der S100 mit implementierte GPS als wahrscheinlichste Fehlerursache übrig.

Für weitere Versuche habe ich darum zwei verschiedene Versionen von chdkptp_gui.sh für r735 erstellt:
Die eine original und die andere mit den zusätzlichen drei Zeilen zum Deaktivieren eines am Raspi laufenden Dienstes.
Zusätzlich habe die S100 dabei mal mit und auch ohne aktiviertes GPS ausprobiert.

Meine Testergebnisse bringen nun aber endlich Licht in den Dschungel, denn es liegt anscheinend tatsächlich an der GPS-Einstellung meiner S100:
1) Ist die GPS-Funktion bei der S100 aktiviert, funktioniert chdkptp r735 auch ohne nötige Anpassungen (sprich: zunächst einen Dienst deaktivieren)
2) Ist die GPS-Funktion bei der S100 dagegen deaktiviert, braucht chdkptp r735 dagegen die nötige Anpassungen, damit es laufen kann

Soviel zu meinen Testergebnissen. Hoffentlich hilft das den Entwicklern von chdkptp, um dieses tolle Programm weiter verbessern zu können.

Liebe Grüße
Werner_O
Benutzeravatar
Werner_O
CHDK-Legende
CHDK-Legende
 
Beiträge: 1011
Registriert: 22.10.2010, 14:12
Wohnort: Köln
Kamera(s): SX20 1.02d
SX240 1.01a
S100 1.01a
S3 1.00a

Vorherige

Zurück zu Technik-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast