Canon SX20 1.00f CHDK-DE problems

Welcome to all English speaking CHDK users

Canon SX20 1.00f CHDK-DE problems

Beitragvon phaedra » 03.04.2011, 20:42

Hallo

@ f_m_b

Today I tested the new CHDK version sx20-100f-1.1.0-608.
Camera shutdown during navigation in the Chdk menu (example i have only change chdk language from german to english and camera crash).
I found also the usual problem:I can enter in the CHDK menu and change the parameters but When i go out from CHDK menu i can't go and use Canon menus.
All buttons are inoperative and i can't see any of the menus Canon.
I hear only the sound of the key pressed.
I discovered something interesting:
As soon as I left the CHDK menu for recall (example) the ISO Canon menu i must first press the ISO button and then the button Shortcut twice.
This procedure is valid for entry into other menu Canon and also change the data.
I tried to change the key 'ALT Mode' from Shortcut to Video or to Flash but the problem is always present.
I know that the 913 version of Neszt is not very stable but at the moment is that I can use without any major problems.
A question please:
Since the release of Neszt not have the problem of the battery (color space remaining) and the navigation in Canon menu,You or other experts could try (if You have time) to improve that version.
Thank you again for your interest.

Best regards
Pauli
Benutzeravatar
phaedra
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 14
Registriert: 11.03.2011, 11:00
Wohnort: Udine-Italy
Kamera(s): A710-S3-S5-SX20

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon f_m_b » 04.04.2011, 00:18

Hello Pauli

so i have to say "sorry" about my bad english. ;-)

Now i think i have understood your problems...
All parts of CHDK in newer version works fine with 1.02b and 1.02d, but with 1.00f you have, with the same softwareparts, crashes and problems.
In CHDK there are two kinds of software. One is the same for all camera-types and the other is especialy for the specific camera model and firmware.
I think we have to look into this specific part to find out the problems.

I'am sorry, but i have no experience in arm-assembler-code, finding out stubs, function entries and all this stuff we need to.
But i will try to have a look into this...

I can build you the newest version of int. CHDK, so you can try out if the problems are only in the CHDK-DE.
Could you please also "cry out a help" in the international forum, maybe we find there someone else who can help us...

EDIT: Ok lets try to find out the problem... First we are looking for a minimum working version.
1) rev 1125 with most compile options (gcc 4.51). Clean all from your sd-card and put the full version on it. Please test and report.
2) rev 1125 with no compile options (gcc 4.51). Change only the diskboot.bin on your card. Please test and report.
3) rev 1125 with no compile options (gcc 3.46). Clean all from your sd-card and put the full version on it. Please test and report.
Dateianhänge
sx20-100f-0.9.9-1125-full.zip
3) version for sx20 1.00f based on rev 1125 with no compile options (gcc 3.46)
(463.98 KiB) 137-mal heruntergeladen
sx20-100f-0.9.9-1125.zip
2) version for sx20 1.00f based on rev 1125 with no compile options (gcc 4.51)
(110.75 KiB) 125-mal heruntergeladen
sx20-100f-0.9.9-1125-full.zip
1) version for sx20 1.00f based on rev 1125 with most compile options (gcc 4.51)
(542.77 KiB) 146-mal heruntergeladen
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 22:59
Kamera(s): -

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon phaedra » 04.04.2011, 18:25

@ f_m_b

Hello (his English is better than my)
In first thank You for the help and sorry for the time You have spent for me.
I started the thread of my problems in this forum because three weeks ago the international forum was down.
Today I tested the new three CHDK version:
far all there is the same problem of the other chdk-de release (navigation in Canon menu just out of the CHDK menu ).
Don't warry actually i use the Neszt 913 version and i can work for my purpose althoug there are little bugs.
I think asking for help to the Chdk international forum for a stable 1.00f version.
I thank all the people who helped me in this forum.

Best regards
Pauli
Benutzeravatar
phaedra
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 14
Registriert: 11.03.2011, 11:00
Wohnort: Udine-Italy
Kamera(s): A710-S3-S5-SX20

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon f_m_b » 13.04.2011, 00:07

Hello Pauli

if the problem of 1.00f is low memory, then could help this:
Link to CHDK with active exmem.
But i think you have seen it already...

If you don't understand the german ask me in english. ;-)
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 22:59
Kamera(s): -

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon phaedra » 14.04.2011, 17:37

@f_m_b

Hello Frank,
Please can You translate and explain to me what should i do to test Your new 1.00f version (sx20-100f-1.1.0-626-full)?
I have a 16gb memory card I always make two partitions as for the other versions (one for bin "bootable" file and the other for CHDK file)?
If I understand correctly I need to verify that there is a written "ok" on display with the version "Testbetrieb"?
ThanK you for You reply

Best regards
Pauli
Benutzeravatar
phaedra
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 14
Registriert: 11.03.2011, 11:00
Wohnort: Udine-Italy
Kamera(s): A710-S3-S5-SX20

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon f_m_b » 15.04.2011, 00:05

@phaedra:
Hello Pauli
i'am going to translate the test instructions tommorow evening into (my not so good) english... :)
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 22:59
Kamera(s): -

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon phaedra » 15.04.2011, 11:32

@ f_m_b

Hello Frank,

I read the discussion in this forum and in the CHDK international forum
(http://chdk.setepontos.com/index.php?PH ... ic=5980.75)
and I understand (i hope) that we can use a small amount of memory inside the Canon cameras to use the CHDK software.
One problem is to find a memory region completely free and unused by the internal Canon software.
Tested the version [ sx20-100f-1.1.0-626-full.zip Basiert auf CHDK-626 (1.00f). Erweiterter Speicher aktiv. Testbetrieb!!!]
In my 16 GB memory card i made two partitions one of 2MB for the bin file and the other of 15GB for CHDK.
First time start on the camera i have see the written 'ok' in the left bottom corner of the display.
Same big problem of the other versions:
I can enter in the CHDK menu and change the parameters but When i go out from CHDK menu i can't go and use Canon menus.
All buttons are inoperative and i can't see any of the menus Canon.
I hear only the sound of the key pressed.
As soon as I left the CHDK menu for recall (example) the ISO Canon menu i must first press the ISO button and then the button Shortcut twice.
This procedure is valid for entry into other Canon menu and also change the data and is annoying but I've seen that works.
I tried to do some small test with some difficulty to enter in the Canon menus:
I took pictures (Raw +Jpeg superfine) in Auto-P-M-C mode:'ok' is present.
I took a little video in M mode:
'ok' not present i read this written on the display:

s:3dfffe0 e:3ffffe0
f:3dfffe0 l:3ff1efc c:495496

So i turned off and on the camera and now i read this written on the display:

s:3dfffe0 e:3ffffe0
f:3e5a200 l:3fab9fc c:345600

I don't know if can be interesting.
First time i turned on the camera and 'ok' was present i read the memory info:

Free memory:252040 bytes
CHDK size:272496
Loaded at:0x13DD20

If I can help in some other way let me know.

Best regards
Pauli
Benutzeravatar
phaedra
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 14
Registriert: 11.03.2011, 11:00
Wohnort: Udine-Italy
Kamera(s): A710-S3-S5-SX20

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon f_m_b » 15.04.2011, 22:32

Hello Pauli

I checked the 1.00f Files and noticed that i forgot to change one source file... :oops:

I deleted the old Files and replaced it with the corrected one.
Link to the corrected files

I'm sorry. Please test it again.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 22:59
Kamera(s): -

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon phaedra » 16.04.2011, 15:03

@ f_m_b

Hallo Frank

Tried the 629 1.00f version but not working.
Too many problems:
To turn on the camera sometimes I have to press two or three time the 'Play' key.
I do not see the written 'ok' as in the latest '626 Testbetrieb' version.
For enter in CHDK menu I don't see the written 'ALT' pressing the key Shortcut.
Sometimes camera turns off browsing in the CHDK menu.
When i go out from CHDK menu there is the same problem of the other versions:
I can not recall and see the menu canon.
In my 'poor' opinion 'Shorcut', 'Menu','Func.Set' Canon camera keys are for some reasons in conflict with the use of CHDK menu.
In this version the camera freezes more times and if i want to navigate in the Canon menu with the 'annoyng' solution i've found (press two times the Shortcut key after the Canon key) i have more problems.
A curiosity: it is normal that the bin file has only 139Kb?

I ask help for a stable SX20 1.00f version to the CHDK international forum.
I hope some 'guru' help me.
If You want i can still test other new 1.00f version, let me know.

Best regards
Pauli
Benutzeravatar
phaedra
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 14
Registriert: 11.03.2011, 11:00
Wohnort: Udine-Italy
Kamera(s): A710-S3-S5-SX20

Re: Canon SX20 1.00f CHDK-DE problems

Beitragvon f_m_b » 16.04.2011, 18:54

Ok. Then we change to the international Forum...
By the way... They found out the proplem with
phaedra hat geschrieben:To turn on the camera sometimes I have to press two or three time the 'Play' key.
f_m_b
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 148
Registriert: 30.05.2010, 22:59
Kamera(s): -


Zurück zu International

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron