[geklärt] Kartenprobleme

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

Kartenprobleme

Beitragvon Ruscher » 12.08.2011, 10:59

Hallo zusammen,
ich hab ein ganz merkwürdiges Problem.

Habe gestern ca 100 Bilder mit den Sevenup Skript gemacht. Soweit ok. Nach den Aufnahmen hab ich die Kamera ausgeschaltet.

Heute Morgen kommt beim Einschalten: Das Normale Canon Startlogo. Kein Logo von CHDK. Dann die Meldung
Keine Bilder auf der Karte. Eigentlich sollte sich das CHDK Logo ja auch melden.
Die Canon Software auf dem Rechner sagt keine neuen Bilder vorhanden.

Die Kamera sagt Karte geperrt, was ja auch ok ist, da der Schieber für den automatischen Start von CHDK so eingestellt ist.

Wenn ich jetzt die Karte in einen Kartenleser stecke kann ich zwar das Inhaltsverzeichnis einlesen, aber es sind eigentlich nur Hyrogliefen darin zu sehen. Wenn ich nach Bildern suche, findet der Rechner natürlich keine.
:?

Hat jemand eine Ahnung was das sein kann??? Bzw weiss jemand, ob ich wenigstens die Bilder auf der Karte retten kann ???

Vielen Dank für Eure Hilfe
Gruß Ruscher Bild
Benutzeravatar
Ruscher
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 9
Registriert: 17.07.2011, 17:01
Kamera(s): Canon PowerShot SX30is V1.00n
CHDK-DE V1.1.0-709

Re: Kartenprobleme

Beitragvon msl » 12.08.2011, 11:19

Hallo,

das sieht so aus, als habe sich die SD-Karte verabschiedet oder es wurde einfach durch korrupte Schreibzugriffe die Datenstruktur zerstört. Ursachen gibt es da viele. Meistens fängt das Übel schon bei dem nicht korrekten Entfernen aus dem Kartenlesegerät an. Möglicherweise hilft eine grundlegende Formatierung.

Zur Datenrettung gibt es in der Linkliste hier im Forum einen eigenen Abschnitt mit einer ganzen Reihe von Links.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4463
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Kartenprobleme

Beitragvon rudi » 12.08.2011, 11:38

Hallo Ruscher,

du kanst folgendes versuchen:
  • SD-Karte im Kartenleser mit dem Hexeditor HxD über "Extras > Datenträger öffnen" dort unter "Physischer Datenträger" den richtigen Wechseldatenträger auswählen, den Schreibschutz anhaken und öffnen.
  • Nach JPG-Bildstartsequenz suchen über "Suchen > Suchen" Datentyp: "Hex-Werte" auswählen, Suchen nach: FFD8
    Steht die Markierung an einem Sektorbeginn, dann fängt hier ein Bild an. Die Zeichenfolge "Exif" im Text ist auch noch ein Hinweis darauf.

    Das sieht in etwa so aus:
    Code: Alles auswählen
    FF D8 FF E1 25 FE 45 78 69 66 00 00 49 49 2A 00  ÿØÿá%þExif..II*.  Sektor 14720

  • Findest du viele solcher Bildstarts, dann speichere dir ein Abblid deiner Karte mit "Datei > Speichern unter..." z.B. "SD.img" auf die Festplatte. Dann können wird versuchen die Bilder mit einem Programm von diesen Abbild zu extrahieren.
Gruß rudi
Benutzeravatar
rudi
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 495
Registriert: 11.09.2009, 11:27
Kamera(s): A590IS_101B, SX260_100B

Re: Kartenprobleme

Beitragvon Ruscher » 13.08.2011, 18:54

Danke für die hilfreichen Tipps

hab einige Bilder retten können. Und die Karte neu FORMATIERT.

Eigentlich melde ich die Karte am PC immer ab.

Hoffe es kommt nicht wieder vor
Gruß Ruscher Bild
Benutzeravatar
Ruscher
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 9
Registriert: 17.07.2011, 17:01
Kamera(s): Canon PowerShot SX30is V1.00n
CHDK-DE V1.1.0-709


Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste