[geklärt] Probleme mit LOG Dateien

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

Probleme mit LOG Dateien

Beitragvon c_joerg » 18.08.2014, 08:50

Hallo,

in meiner Scripten lege ich immer zwei LOG Dateien an.

Die eine mit print_screen() um aller Prints und Fehlermeldungen zu loggen und mit

Code: Alles auswählen
function log_name()
    namepart = os.date("%d%m%H%M")
    log_num  = i
    log_path = "A/CHDK/LOGS/"
    log_file_name = "MyIn"
    log_file_ending = ".log"
    log_name = log_path..log_file_name..namepart..log_file_ending
    logfile=io.open(log_name,"wb")
    io.output(logfile)
end

function log(...)
    io.write(...)
    io.write("\n")
end


um Werte wie Av, Tv, Temp, Vbatt, in ein Matrix zu schreiben. Die Datei kann ich dann z.B. in Excel oder MATLAB für eine graphische Darstellung direkt einlesen.

Bisher funktioniert das sehr gut.
Ist es eigentlich zulässig, beide Methoden gleichzeitig zu verwenden?

Ich habe nur manchmal ein Problem (Bei beiden Dateien immer gleichzeitig).
Das Datum und die Uhrzeit der Datei sind manchmal falsch. Beide haben dann z.B 01.01.2000 00:00.
Das passiert aber recht selten. Grundsätzlich schreibe ich am Anfang immer noch mal das Datum in die LOG Datei. Dieses Datum ist immer richtig.

Grüße Jörg
c_joerg
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 297
Registriert: 14.08.2014, 06:50
Wohnort: Bremen
Kamera(s): S110 103a
IXUS500HS
IXUS30 100k
2 * S45
2 * G1X 101a, 100e
EOS1200D
SX230 101a
SX50hs 100c
IXUS160 100a

Re: Probleme mit LOG Dateien

Beitragvon msl » 18.08.2014, 10:01

Hallo,

du kannst beide Log-Methoden gleichzeitig verwenden.

Das "01.01.2000 00:00"-Problem ist ein altbekannter Bug im DryOS. Wenn nach dem Einschalten der Kamera die erste Datei mittels CHDK auf die SD-Karte geschrieben wird, also CHDK-RAW/DNG-Dateien, Log-Dateien, Konfig-Dateien u.s.w., erhält sie den genannten Zeitstempel. Ab der zweiten Datei ist dann alles i.O. Bei normalen Fotos tritt dieser Bug nicht auf!

Mache nach dem Einschalten der Kamera einfach ein "Blindfoto". Danach erhalten alle mit CHDK geschriebenen Dateien den richtigen Zeitstempel.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4464
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Probleme mit LOG Dateien

Beitragvon c_joerg » 18.08.2014, 10:08

Hallo,

vielen Dank. Dann werde ich das mal so machen...

Grüße Jörg
c_joerg
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 297
Registriert: 14.08.2014, 06:50
Wohnort: Bremen
Kamera(s): S110 103a
IXUS500HS
IXUS30 100k
2 * S45
2 * G1X 101a, 100e
EOS1200D
SX230 101a
SX50hs 100c
IXUS160 100a


Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron