Problem mit ptpCamGui

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

Problem mit ptpCamGui

Beitragvon gominu2015 » 04.11.2015, 08:32

Hallo,

Obwohl ich einen "workaround" gefunden habe, wissen die Spezialisten
vielleicht eine bessere Loesung.

Auf einem Laptop(WIN7 64BIT) habe ich vor etwa 2 Jahren libusb mit einer SX220HS und einer
8GB Karte erfolgreich installiert und auch mit ptpCamGui gearbeitet.

Inzwischen bin ich auf eine 32GB Karte umgestiegen und siehe da, ptpCamGui
findet keine Kamera mehr.

Der eigentliche Fehler taucht allerdings schon beim Anschluss der 220HS an den Laptop auf.
Nach dem Verbinden mit dem Laptop (richtiger USB-Port) und dem Einschalten der Kamera
erscheint kurz auf dem Display der 220HS : "Fehler in der Verbindung"

Liegt es etwa an der 32GB Karte; unter CHDK funktioniert die Karte EINWANDFREI!
(--oder sogar an der Firmware der 220HS--oder an der libsub)

Somit hab ich eine 8GB Karte neu formatiert, CHDK installiert und getestet.
Siehe da, die Meldung "Fehler in der Verbindung" erscheint nicht mehr und
ptpCamGui erkennt die Kamera und funktioniert.

Liegt es doch an den 32GB ?
Also, auf eine 32GB Karte CHDK neu installiert. Und siehe da, auch diese Karte
funktioniert ohne Fehlermeldung.

Was nun ? Sind etwa zu viele Bilder im Ordner DCIM ? Es sind 5414 Dateien in 31 Sub-Ordnern.
Insgesamt 7.37 GB in "DCIM" .
Diese Sub-Dirs legt CHDK jeden Monat (oder frueher) neu an und lauten etwa "108__01" bis "138__11".

Zu testzecken hab ich den Ordner "DCIM" nach "DCIM_bis_Okt2015" umbenannt und einen
leeren "DCIM" angelegt. (auf der urspruenglichen Karte, die bisher nicht funktioniert)

Und siehe da, jetzt funktioniert meine "alte" 32GB Karte einwandfrei mit ptpCamGui.
Auf die Bilder in "DCIM_bis_Okt2015" kann ich natuerlich via 220HS nicht mehr zugreifen.

Liegt der Fehler tatsaechlich an zu vielen Bildern in DCIM oder gibt es eine andere Erklaerung ?

Gruesse
Reinhard



Hardware: SX220HS; CHDK 1.4.0 4278; 101b; 32GB Transcend SDHC
PC Laptop Intel 4GB; Win7 64bit
libusb: libusb-win32-bin v1.2.6.0 (01/17/2012)
ptpcamGui: ptpCamGui 137
gominu2015
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 03.11.2015, 10:36
Kamera(s): SX220HS

Re: Problem mit ptpCamGui

Beitragvon msl » 04.11.2015, 11:48

Hallo und willkommen,

das Problem liegt in der Tat an der großen Anzahl an Bildern. Um so mehr Bilder auf der Karte sind, desto länger dauert auch der Kamerastart im Wiedergabemodus. Die Kamera indiziert die Fotos für die Vorschau. Und das benötigt Arbeitsspeicher.

Gerade die SX220 ist nicht gerade üppig mit Arbeitsspeicher ausgestattet. Es hat Jahre gedauert, das CHDK für die SX220 so zu optimieren, dass auch alle CHDK-Standardfunktionen verfügbar sind.

Du kannst versuchen, statt ptpCamGui chdkptp zu verwenden. Dieser CHDK-PTP-Klient arbeitet effektiver und schneller. Mehr dazu hier: viewtopic.php?f=7&t=2699

Übrigens wird die Ordnerstruktur im Ordner DCIM durch Canon-Einstellungen bestimmt, und nicht durch CHDK.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4463
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Problem mit ptpCamGui

Beitragvon gominu2015 » 04.11.2015, 19:15

Danke fuer den Tip,

da die Fehlermeldung "Fehler in der Verbindung" schon beim Anschluss der Kamera an den PC auftritt, bringt "chdkptp" auch nichts. Dort kommt die Meldung: " ERROR: no matching device"

Ich muss mich wohl mit dem "workaround" begnuegen. Damit kann ich leben.

Gruss
Reinhard
gominu2015
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 03.11.2015, 10:36
Kamera(s): SX220HS


Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: Yahoo [Bot] und 1 Gast