[geklärt] SD-Kartenfehler

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

SD-Kartenfehler

Beitragvon Tammo » 26.10.2008, 18:52

Ich weiß nicht genau, ob es was mit CHDK zu tun hat, aber vielleicht kann mir totzdem jemand helfen. Ich war grade heute auf der DTM am Nürburgring und habe einige tolle Fotos machen können. Nun bin ich nach Hause gekommen und wollte diese Bilder wie gewöhnlich mit dem Notebook internen SD-Cardreaderrunterladen. Bis etwa 50 % ging das auch. Dann hat das Programm (Cam2PC) einen Fehler angezeigt (AVI-Datei kann nicht runtergeladen werden). Bin dann in den Explorer gewechselt und habe in in der Miniaturansicht gesehen, dass die meisten Bilder ab der Helfte grau sind. Die Karte war leider zu diesem Zeitpunkt nicht schreibgeschützt. Hab die Karte dann raus aus dem Cardreader (sicher entfernt!) und habe den schreibschutz reingemacht und wieder in den Cardreader geschoben. Nun wurde die Karte nicht mehr richtig erkannt (ist nicht formatiert - soll formatiert werden?).

Die schon heruntergeladenen Bilder sind ok.

Ich hab ein bisschen gegoogelt und hab mit dem Programm PC Inspector File Recovery versucht weiterzukommen. Leider sag das Programm nur "Bad parameters for calculating logical drive information from Boot Sector" Es erkannt nur 7,xx MB und mit dem Programm lässt sich sonst dann nichts mehr machen, auf dem Laufwerk.

die Kamera sagt jetzt auch Speicherkartenfehler, und lässt sich nur ohne CHDK staten, trotz Schreibschutz.

Nun noch ein paar Infos:
Kamera: SX 100 (2 Monate jung)
Speicherkarte: hama 2 GB (auch 2-3 Monate jung)
CHDK-sx100is-100c-0.5.5-527

Bin mal auf Tipps gespannt. Mich hat vorallem verunsichert, dass ich "dabei zuschauen konnte", wie die Karte kaputt geht.
Tammo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.08.2008, 13:27
Wohnort: Filderstadt

Beitragvon msl » 26.10.2008, 23:55

Hallo,

es ist davon auszugehen, dass der Fehler im Zusammenspiel zwischen SD-Karte und Cardreader entstanden ist. Also solltest du diese beiden Dinge genauer untersuchen.

Wenn das mit File Recovery nicht geklappt hat, wird wohl leider kaum noch eine Chance bestehen, die fehlenden Bilders und AVIs zu retten. Du solltest aber trotzdem noch mal der Ursache auf den Grund gehen. Stelle sicher, dass der Cardreader i.O. ist und die SD-Karte sauber arbeitet. Evt. war die Karte nicht korrekt eingesteckt. Mach ein paar Testläufe bevor Du wieder wichtige Fotos verarbeiten möchtest.

Das CHDK die Ursache ist, kannst Du ausschließen.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4507
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Beitragvon Tammo » 27.10.2008, 08:22

Hallo und vielen Dank schonmal!

Auch nach öfterem Einlegen der Karte ändert sich nichts. Auch ohne Schreibschutz hat sich nichts getan. Eine andere SD Karte funktioniert, daher kann es nur noch an der Karte liegen.

Ich dachte eigentlich auch nicht, dass es direkt an CHDK liegt, sondern eher, dass man die Karte dafür bootbar machen muss.

LG
Tammo
SX 100
sx100is-100c-0.9.7-783-full
Tammo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.08.2008, 13:27
Wohnort: Filderstadt

Beitragvon msl » 27.10.2008, 10:06

Damit die Karte bootfähig wird, ändert die zuständige Software eigentlich nur ein Bit. Das kann nicht die Ursache sein.

Ich denke, Du solltest Kartenleser und die verwendete Software zur Übertragung im Auge behalten.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4507
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Beitragvon Tammo » 28.10.2008, 14:38

Mit dem Programm "TestDisk & PhotoRec", also genauer mit PhotoRec konnte ich meine Bilder nun sichern. Das Programm hat mir auch die korrekte Größe der SD-Karte angezeigt.

Nun noch eine letzte Frage:
Garantiefall oder formatiern, CHDK drauf machen und weiterbenutzen?
SX 100
sx100is-100c-0.9.7-783-full
Tammo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.08.2008, 13:27
Wohnort: Filderstadt

Beitragvon trichtex » 29.10.2008, 17:46

Moin!

Tammo hat geschrieben:Garantiefall oder formatiern, CHDK drauf machen und weiterbenutzen?


Wenn sie sich formatieren, beschreiben und auslesen läßt, spricht nichts dagegen, sie danach auch weiterzuverwenden. Läßt sie sich hingegen nicht formatieren, nutze die Garantie.

Munter bleiben... TRICHTEX
Powershot A610 100e mit CHDK DE aktuell
trichtex
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 43
Registriert: 20.05.2008, 09:32

Beitragvon fe50 » 29.10.2008, 18:44

Tammo,

falls Du die Karte weiterverwenden solltest würde ich Dir gringend empfehlen, sie vorher intensiv zu prüfen; hier bietet sich H2Testw von der c't-Redaktion an (kostenlos, deutsch, einfach & zuverlässig, ohne Installation): http://www.heise.de/ct/ftp/
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 15:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Beitragvon Tammo » 29.10.2008, 23:59

Alles klar,
danke für die Hilfe!
SX 100
sx100is-100c-0.9.7-783-full
Tammo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.08.2008, 13:27
Wohnort: Filderstadt


Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 2 Gäste

cron