[gelöst] Ixus 960is stürzt bei Video nach 21s ab

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

Ixus 960is stürzt bei Video nach 21s ab

Beitragvon hotte12345 » 31.12.2008, 16:25

Hallo zusammen,
bei meiner Ixus 960 geht Video mit chdk leider nicht. Mit Quality bei 84 stürzt sie nach 21 Sekunden, mit Quality bei 50 nach 42 Sekunden ab. Hab schon mit 3 Chdk Versionen und 2 Karten getestet- jedesmal gleiches Ergebnis: Kamera ist noch an , Bildschirm wird schwarz(Hintergrundbeleuchtung ist noch an), keine Reaktion auf Tasten. Einzige Hilfe ist Akku raus und wieder rein.

Zoomen bei Video geht übrigens auch nicht.

Ohne chdk funktioniert alles normal, andere chdk Funktionen sind auch normal.

Nun zu meiner Frage. Liegts am chdk oder an meiner Kamera? Hat jemand von euch die gleiche und kann den Fehler bestätigen oder negieren?

Gruß

Ralf
hotte12345
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 15.08.2008, 19:10

Beitragvon piti » 31.12.2008, 16:50

ahoi
bin neu hier und teste auch gerade rum....hab das gerade mal ausprobiert ohne irgendwas in den menues zu aendern und das selbe problem :cry:
zoomen geht,aber nur rein und rauszoomen ueber den beim aufnahmestart vorliegenden zoomwert hinaus.
die aufnahme wird scheinbar auch nicht gespeichert
piti
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 30.12.2008, 03:17

Beitragvon hotte12345 » 31.12.2008, 16:59

Hallo piti,

zoomen geht bei mir gar nicht, dafür aber speicher wenn man unter der 21 Sekunden Grenze bleibt. Schade eigentlich.
Du hast auch eine 960is?

Gruß
Ralf
hotte12345
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 15.08.2008, 19:10

Beitragvon piti » 31.12.2008, 17:13

ja,hab ne 960is
bin der totale dau was das ganze hier angeht,selbst die serienfuntionen der cam sind mir
nur teilweise bekannt. :D
grad nochmal rumprobiert...nun geht zoomen in beide richtungen ohne das ich was geaendert haette.
speichern geht wirklich.beim bespielen der karte wurde seitens cardtricks allerdings gemozt das sie zu
gross ist und maximal ne 2gb karte verwendet werden soll.ich hab ne 4gb sdhc class 6 karte drinne...
liegt da vielleicht der fehler ?
piti
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 30.12.2008, 03:17

Beitragvon hotte12345 » 31.12.2008, 18:23

Glaub ich nicht, daß es an den 4 gb liegt, kann es aber auch nicht sicher ausschließen. Ich habs mit ner 4gb SD Karte und ner 8gb SDHC Karte getestet, wobei die 8gb eine Sandisk ExtremeIII ist, also schnell genug. Bei beiden ist nach 21 Sekunden schluss.
hotte12345
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 15.08.2008, 19:10

Beitragvon piti » 31.12.2008, 19:02

hmmm...wenn ich im videomodus(kamera scharf,objektiv ausgefahren) auf "Menü" gehe und dort "digitalzoom" ausschalte geht kein zoom mehr...bei einstellung "standart" kann ich nur in dem bereich zoomen in dem ich mich vor dem aufnahmestart befunden habe...also 0...4,0 x oder 4,0 x ...15x
manchmal aber komischerweise nur der bereich oberhalb des beim start eingestellten zooms...hängt wohl von der objektentfernung bei aufnahmestart ab ?
komisch...
Gruss : Tom
ixus960is
piti
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 30.12.2008, 03:17

Beitragvon Holli » 31.12.2008, 20:54

Hi,

ich teste das gerne alles (habe diverse Karten, auch 4GB SDHC class6), sobald ich meine Camera zum Booten gebracht habe.

SDHC-Karten sind standardmässig FAT32-formatiert, CHDK erwartet jedoch FAT, welches maximal 2GB unterstützt, bei spezieller Formatierung bis zu 4GB. Bei SDHC-Karten >4GB soll der Trick mit Partitionieren helfen, 1. Partition ca. 16MB (sollte dick reichen, CHDK benötigt auf der ixus960 keine 3MB), 2. Partition Rest der Karte, auf der landen dann auch die Bilder.

Nachzulesen im Handbuch auf Seite 70 ;)

Gruss, Holli
IXUS 960IS 1.00dBenchmarks
Benutzeravatar
Holli
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 31.12.2008, 19:37

Beitragvon piti » 31.12.2008, 23:35

ich hab noch ne 1gb karte gefunden...leider genau das selbe :
stürzt im videomodus nach 21sekunden ab,zoom geht grad wie er will
karte im lesegeraet mittels cardtricks auf fat 16 formatiert, anschliessend bootbar gemacht
und zum schluss die DISKBOOT.bin sowie den CHDK ordner draufkopiert..danach noch schreibschutz und fertig...an den karten liegts wohl nicht
naja.. erstmal nen guten rutsch !Bild
Gruss : Tom
ixus960is
piti
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 30.12.2008, 03:17

Beitragvon hotte12345 » 01.01.2009, 16:42

Ich habs mal in den CHDK Bugtracker eingetragen. Mit Severity major, wenn ichs so recht bedenke vielleicht doch ne Stufe zu hoch gegriffen. Aber bei meiner 8gB Karte kann ich Video sonst nicht benutzen, da im Modus ohne chdk nur die kleine erste Partition erkannt wird.

Frohes neues

Ralf
hotte12345
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 15.08.2008, 19:10

Re: Ixus 960is stürzt bei Video nach 21s ab

Beitragvon Holli » 02.01.2009, 00:58

hotte12345 hat geschrieben:bei meiner Ixus 960 geht Video mit chdk leider nicht. Mit Quality bei 84 stürzt sie nach 21 Sekunden, mit Quality bei 50 nach 42 Sekunden ab. Hab schon mit 3 Chdk Versionen und 2 Karten getestet- jedesmal gleiches Ergebnis: Kamera ist noch an , Bildschirm wird schwarz(Hintergrundbeleuchtung ist noch an), keine Reaktion auf Tasten. Einzige Hilfe ist Akku raus und wieder rein.

Zoomen bei Video geht übrigens auch nicht.

Ohne chdk funktioniert alles normal, andere chdk Funktionen sind auch normal.


Hi Ralf,

nachdem mein Problem mit dem Bootfähigmachen meiner Karten gelöst ist, kann ich Deine obigen Angaben ebenfalls exakt bestätigen.

Was ich noch getestet habe:

Statt Video in 640er-Auflösung 1024er versucht, also quasi die native Auflösung des CCD-Chips.
Da funktioniert das Ganze bis 2'05", danach die selben Symptome.

Tja, da würde ich jetzt auch mal die Ursache bei CHDK suchen, denn Videoaufnahmen ohne CHDK sind absolut problemlos, weshalb ich dafür also bis auf Weiteres einmal die Karte werde rausnehmen müssen um den Schreibschutz zu deaktivieren.

CU, Holli
IXUS 960IS 1.00dBenchmarks
Benutzeravatar
Holli
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 31.12.2008, 19:37

Beitragvon CHDKLover » 06.01.2009, 19:55

Hallo hotte12345,
ewavr hat eine eventuelle Lösung des Problems gefunden. Probier einfach mal die aktuellste Version aus.

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 18:25
Wohnort: Dresden
Kamera(s): a610 100e

Beitragvon Holli » 06.01.2009, 20:36

Moin,

Build 667 hat das Video-Problem auf meiner Ixus 960 offensichtlich behoben, auf allen Karten in allen Auflösungen durchgängige Aufnahme bis zum Kapazitätsende der Karte möglich, im Standardmodus auch mit Zoom.
Konnte keinen Absturz provozieren.

Gruss, Holli
IXUS 960IS 1.00dBenchmarks
Benutzeravatar
Holli
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 31.12.2008, 19:37

Beitragvon piti » 06.01.2009, 21:24

jepp ! auch bei mir scheints unabhängig von der verwendeten karte zu funktionieren ...THX ! :D
Gruss : Tom
ixus960is
piti
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 30.12.2008, 03:17

Beitragvon hotte12345 » 07.01.2009, 12:02

Super,

bei mir funktiniert es jetzt auch perfekt. Toll!!!!

Gruß

Ralf
hotte12345
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 15.08.2008, 19:10

Beitragvon Holli » 07.01.2009, 12:26

Moin,

Build 668 lässt nun auch im XVGA-Modus (1024) das Zoomen zu, ausserdem erscheint eine neue tolle Restplatz- und Zeitberechnung sowie die aktuelle Bitrate zusätzlich zur Balkenanzeige (Restplatz) im Display.

Einzige Auffälligkeit: Beim allerersten Anschalten der Camera über den ON/OFF-Knopf reagierte diese nicht, erst mit dem PLAY-Knopf ging die Camera an.

Danach ging's dann auch wieder mit dem ON/OFF-Knopf.
Kann ich mit leben ;)

Gruss, Holli

P.S.: Liest der Entwickler hier eigentlich auch mit, oder wie bekommt der Rückmeldungen?
P.P.S.: Das Verhalten beim allerersten Anschalten war mit einer anderen Karte nicht mehr reproduzierbar...
IXUS 960IS 1.00dBenchmarks
Benutzeravatar
Holli
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 35
Registriert: 31.12.2008, 19:37

Nächste

Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste