[geklärt] Bad Pixel bei Canon Powershot g7

Benutzung und Hintergrundinformationen von CHDK-RAW/DNG-Dateien

Bad Pixel bei Canon Powershot g7

Beitragvon cons » 21.02.2012, 20:42

Hallo erstmal,

ich habe mir eine Canon Powershot G7 gebraucht gekauft und habe überbelichtete DNGs geschossen. Mit RawTherapee erhalte ich allerdings sehr viele dies schwarzen Bad Pixel. Auf einen Ausschnitt von 100x170 Pixel sind es z.B. 12. Dann müssten es auf die gesamte Fläche ca. 7000 sein.

Meine naive Frage ist non ob das so ok ist, oder ob die Kamera ne Macke hat?

Ich erwarte eigentlich sehr viel weniger Fehler Pixel und noch dazu eher in einer RGB Farbe. Ich verwende eine leere BadPixel Datei. Das Muster waren auf einen weitern Bild identisch (zumindest bei den paar Pixel die ich überprüfte). Ich habe Bild auch mal mit Lightroom ausprobieren lassen und das war das nicht so. Liegt aber wohl eher an der Vorerarbeitung von Lightroom.

Viele Grüße und vielen Dank schon mal
Cons
cons
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 21.02.2012, 20:29
Kamera(s): G7

Re: Bad Pixel bei Canon Powershot g7

Beitragvon TobiMarg » 21.02.2012, 23:17

Hallo und wilkommen im Forum

Ich kann auf deine Frage nicht genau antworten, aber es gibt hier einen Thread zur Anzahl der Badpixel.
Ausserdem kannst du im CHDK-Menü eine Badpixeldatei erzeugen lassen, wobei auch die Gesamtmenge der
Badpixel angezeigt wird.

Gruss
TobiMarg
TobiMarg
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 102
Registriert: 24.09.2011, 15:17
Kamera(s): SX230HS 1.01c

Re: Bad Pixel bei Canon Powershot g7

Beitragvon fe50 » 22.02.2012, 07:01

cons hat geschrieben:...Dann müssten es auf die gesamte Fläche ca. 7000 sein. ...
Meine naive Frage ist non ob das so ok ist, oder ob die Kamera ne Macke hat?
Das liegt im üblichen Umfang; wenn die G7 (wie einige andere Powershots dieser Generation auch) mehrere interne Fehlpixeltabellen verwendet, können es auch abhängig von ISO / Belichtungsdauer weniger sein.

Ich erwarte eigentlich sehr viel weniger Fehler Pixel und noch dazu eher in einer RGB Farbe. Ich verwende eine leere BadPixel Datei.
Lies Dich mal im Handbuch zum Thema ein...
Wenn Du eine leere badpixel.bin verwendest werden die Fehlpixel nicht bereinigt, d.h. bei der DNG-Erzeugung blendet CHDK die bereits von der Canon-Firmware als defekt markierten Pixel nicht aus, zeigt sie also sichtbar an.
Die Canon-Firmware markiert anhand interner Tabellen die ihr bekannten Fehlpixel mit dem entsprechenden Wert (0 / schwarz); derart markierte Pixel werden dann bei der Weiterverarbeitung ausgeblendet (z.B. JPG Erstellung) oder sind als schwarze Pixel sichtbar, wenn dies unterbleibt.
Was Du also im DNG siehst sind die "Markierungen" der Canon-Firmware...

Die Datei badpixel.bin wird von CHDK erzeugt, indem die "Markierungen" in einer RAW Aufnahme ausgelesen werden, enthält also ihre Position und damit ist dann CHDK die Canon-interne Fehlpixelliste bekannt.

* http://chdk.wikia.com/wiki/Badpixel_removal
"The grass was greener, The light was brighter"►  ◄fe50 home►  ◄TRAIL-Magazin►  ◄RTFM !
Benutzeravatar
fe50
CHDK-Legende
CHDK-Legende
 
Beiträge: 1105
Registriert: 25.04.2008, 14:28
Wohnort: B'Württemberg
Kamera(s): Ixus50 101b, Ixus860 100c, SX10 101a

Re: Bad Pixel bei Canon Powershot g7

Beitragvon cons » 23.02.2012, 20:03

Hallo TobiMarg und fe50,
Vielen Dank für die Antworten.
Die Canon-Firmware markiert anhand interner Tabellen die ihr bekannten Fehlpixel mit dem entsprechenden Wert (0 / schwarz); derart markierte Pixel werden dann bei der Weiterverarbeitung ausgeblendet

Dies war mir nicht klar und ich habe es so nicht erwartet.
Für die Statistik (wenn es jemanden interessiert): Bei mir werden ca. 5500 Bad Pixel gefunden.
Viele Grüße und vielen Dank noch einmal
Cons
cons
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 21.02.2012, 20:29
Kamera(s): G7


Zurück zu RAW und DNG

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast