LEDs blinken lassen und Pieps

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

LEDs blinken lassen und Pieps

Beitragvon Jörg aus Dresden » 19.06.2008, 22:47

Hallo,
kennt jemand Befehle, um die LEds anzusteuern (insbe. die Fokus LED) und einen Beep auszulösen?
Danke
Jörg
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Beitragvon CHDKLover » 20.06.2008, 11:58

Hallo Jörg aus Dresden,
in Scripten kannst du mit:
Code: Alles auswählen
set_led x 1

eine LED einschalten
und mit
Code: Alles auswählen
set_led x 0

eine LED ausschalten

Dabei steht das x für:
x=4: LED_GREEN
x=5: LED_YELLOW
x=6: unbenutzt
x=7: LED_ORANGE
x=8: LED_BLUE
x=9: LED_AF_BEAM
x=10: LED_TIMER


Im CHDK Quellcode kannst du z.b mit
Code: Alles auswählen
started();

die blaue Print-LED zum leuchten bringen und mit
Code: Alles auswählen
finished();

wieder ausschalten

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 19:25
Wohnort: Dresden
Kamera(s): a610 100e

Beitragvon Jörg aus Dresden » 23.06.2008, 14:22

Hallo,
danke für die Hinweise.
Leider scheint das mit dem allbest built noch nicht zu funktionieren und einen anderen gibt es für meine Kamera schinebar nicht.
Gibt es noch einen anderen Weg?

Danke Jörg



in Scripten kannst du mit:
Code: Alles auswählen
set_led x 1
[quote][/quote]
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Beitragvon CHDKLover » 23.06.2008, 15:40

Hallo Jörg aus Dresden,
ich habe es auf meiner A610 erfolgreich mit folgendem Code getestet: (für Scripts)
Code: Alles auswählen
for x=4 to 10
set_led x 1
sleep 1000
set_led x 0
next x

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 19:25
Wohnort: Dresden
Kamera(s): a610 100e

Beitragvon msl » 24.06.2008, 15:21

Hier noch ein vollständiges Skript:

Code: Alles auswählen
@title LED-Test

sleep 1000
print "LED-Test"

for a=4 to 10

print a

set_led a 1
sleep 2000
set_led a 0

next a

end


Nr. 6 ist bei mir mit der Betriebsanzeige (grüne LED) belegt.

Signaltöne können bisher nicht ausgelöst werden.

Gruß msl
Dateianhänge
test_led.bas
LED-Test-Skript
(134 Bytes) 45-mal heruntergeladen
Zuletzt geändert von msl am 13.07.2008, 14:17, insgesamt 1-mal geändert.
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4512
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Beitragvon Jörg aus Dresden » 25.06.2008, 13:38

danke für das Skrip. Es läuft durch, aber es leuchtet nichts.
Habt Ihr eine Idee, was das sein könnte.
Viele Grüße
Jörg
IXUS 860IS
Jörg aus Dresden
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 26
Registriert: 30.05.2008, 09:34

Beitragvon silas » 13.07.2008, 14:08

Hier noch ein script!
Code: Alles auswählen
@title led
@param a Welche led?
@default a 9
@param b led an sekunden
@default b 5
if a<1 then let a=9
if b<1 then let b=5

set_led a 1
sleep b*1000
set_led a 0
end
a550,IXUS 80IS (1.01a)
aktuelle version
Flickr
Benutzeravatar
silas
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 150
Registriert: 23.04.2008, 14:11
Wohnort: Schweden


Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron