Hilfe beim compilieren unter Eclipse

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Hilfe beim compilieren unter Eclipse

Beitragvon mr.burns » 14.03.2014, 22:43

Hallo,

habe mal wieder einwenig Zeit gefunden um CHDK selbst zu kompilieren.
Ich verwende dazu die OpenSource Entwicklungsumgebung Eclipse (Version Kepler). Habe zuvor GCC 3.4.6 installiert.
Mein System: Windows 7 professional 64Bit.

Habe ein neues C++ Projekt erstellt, make durch gmake ersetzt und folgende Build-Variablen verwendet:

PLATFORM=s110 PLATFORMSUB=103a fir

Dann habe ich auf 'Built project' geklickt und bekam folgende Fehlermeldung auf der Konsole:

21:34:08 **** Incremental Build of configuration Default for project CHDK_S110_test ****
gmake PLATFORM=s110 PLATFORMSUB=103a fir
gmake: Interrupt/Exception caught (code = 0xc00000fd, addr = 0x41cfab)
21:34:09 Build Finished (took 171ms)


Was mache ich falsch? Vielen Dank für jede Art von Hilfe...
mr.burns
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 23.02.2014, 21:23
Kamera(s): IXUS 860 IS, Powershot S110 103.a

Re: Hilfe beim compilieren unter Eclipse

Beitragvon msl » 14.03.2014, 23:42

Hallo,

mit Eclipse kann ich dir nicht weiterhelfen. Mir ist auch nicht bekannt, dass es schon einmal Berichte über die Benutzung von Eclipse im Zusammenhang mit CHDK gab.

Warum legst du ein C++-Projekt an? CHDK ist vorrangig in C geschrieben.

Aus welcher Quelle stammt dein GCC-Compiler. Der muss für CHDK besonders aufbereitet sein. Fertige Pakete gibt es auch hier im Download-Bereich. Ich empfehle die Version 4.5.1 für Windows. Die funktioniert 100%ig.

Du kannst auch die CHDK-Shell zum Compilieren verwenden. Dafür muss sich das Projekt als Arbeitskopie im Unterordner 'trunk' des CHDK-Shell-Installationsverzeichnis befinden. Außerdem muss der Projekt-Ordner im Namen mit 'trunk' beginnen, z.B. 'trunk_work'.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4510
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Hilfe beim compilieren unter Eclipse

Beitragvon mr.burns » 15.03.2014, 12:05

Hallo msl,

danke erstmal. Es kann nichts mit Eclipse zu tun haben, da Eclipse ja die GCC Tools verwendet, also gcc und gmake usw.. Eclipse dient hier nur als Editor der dann gcc, gmake genauso aufruft, als würde ich es in der DOS-Box machen. Habe GCC 4.5.1 aus dem von Dir genannten Download-Bereich installiert.
Habe mein Problem lösen können, habe nun aber ein anderes.
Zunächst mal für all die, die dasselbe Problem haben. Ich hatte GCC im Verzeichnis C:\Programme (x86)\gcc installiert.
Habe somit C:\Programme (x86)\gcc\bin in der PATH Variablen angegeben. GCC mag wohl keine Klammern in der PATH Variablen.
Habe dann GCC nach C:\gcc kopiert die PATH Variable angepasst und jetzt läuft der Compiler, bekomme aber am Ende eine Fehlermeldung:

[C:\gcc451\bin\gmake.exe[1]: *** No rule to make target `../generic/wrappers.c', needed by `wrappers.o'. Stop.
gmake: *** [all-recursive] Error 1


Den gesamten Compile-Log habe ich als Datei angehängt.

Danke nochmals...

-- 15.03.2014, 11:15 --

Hallo,

ich hab's hinbekommen.
Ich hatte im vorherigen Versuch nur das Verzeichnis S110 unter Platform in mein Projekt übertragen.
Habe nun den kompletten trunk in mein Projekt übertragen und der Compile-Vorgang läuft jetzt sauber durch. Habe jetzt eine selbst erstellte diskboot.bin.
Dateianhänge
S110log.txt
Compile log
(7.11 KiB) 48-mal heruntergeladen
mr.burns
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 23.02.2014, 21:23
Kamera(s): IXUS 860 IS, Powershot S110 103.a


Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste