[uBasic] MD_FAST - Schnelle Bewegungserkennung

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon userc23 » 01.05.2011, 00:54

Hallo!

Ich hab versucht das MD-Fast auf meiner SX200is probeweise (vor der Gewittersaison) laufen zu lassen.

Leider struerzt das Skript nach der Schwellwertberechnung ab. Ich seh am Display die flackernde (!) Anweisung fuer weitere Befehle (Schwellwert = 2; hoch => wiederholen; rechts =>+1;links=> -1; runter => weiter). Die Kamera reagiert aber auf keine Befehle. Einziger Ausweg: Ausloeser druecken, um das Skript abzubrechen. Hab schon mittels Trial & Error weiter zu kommen, bin aber gescheitert. :(

Hab schon im Forum gesucht, aber nichts gefunden bzw. die falschen Schlagwoerter verwendet...

Kann mir jemand weiterhelfen?


Nachtrag 01.05.2011:
Ich hab jetzt noch andere Skripte (MD_Tune & HyperBlitz) ausprobiert, die ebenfalls nicht das machen, was sie tun sollten..
Dazu hab ich einen Thread im allgemeinen Probleme-Bereich eroeffnet.


Danke im Voraus!

LG,
userc23
PowerShot SX200is 1.00d
CHDK-DE 1.1.0-637
userc23
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 5
Registriert: 01.05.2011, 00:37
Kamera(s): PowerShot SX200is 100d
CHDK-DE 1.1.0-637 24.04.11

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon S5andi » 01.05.2011, 10:55

Hallo userc23,

das gleiche Problem habe ich bei dem Script HDR-Hyper (Posting vom 28.4.) entdeckt.
Es scheint ein Problem mit den neueren CHDK-Versionen zu sein.
Ich kann deinen Fehler auf der S5IS auch nachvollziehen. Wenn du die Version 601 verwendest, funktioniert das Script.

Grüsse S5andi
S5 IS 1.01a + SX230HS 1.01e CHDK-DE: akt. Version
S5andi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 38
Registriert: 16.08.2008, 08:48

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon msl » 01.05.2011, 13:35

Hallo,

stimmt, das Skript läuft mit der aktuellen Version nicht korrekt. Ich kann im Augenblick keine Beziehung zwischen den letzten Änderungen und dem Skriptverhalten herstellen.

Da muss sich mal jemand ausführlich damit beschäftigen. Vielleicht findet sich ja einer der vielen Mitleser hier. ;)

Gruß msl

Nachtrag: Wenn man den letzten Parameter (Autoschwellwert) auf Null stellt, kann man das Skript wenigsten zum Auslösen nach Bewegungserkennung benutzen. Der Schwellwert ist als Vorgabewert auf 10 eingestellt. Diesen Wert kann man im Bereich zwischen 5 und 10 variieren, um die Reaktion zu optimieren. Diese automatische Schwellwert-Einmessung ist nicht unbedingt notwendig.
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4512
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 01.05.2011, 18:44

mon moin,

ja was ist denn nu?

Wenn ich das richtig sehe wird das "wait click" in den neuen Builds schlichtweg ignoriert!
Wieso verschwindet denn die anderen Anzeigen wie die DOF-Anzeige für einem Moment? cls sollte doch hier keine Wirkung zeigen.

Am Skript sollte es meiner Meinung nach nicht liegen.

Übrigens das gleiche Phänomen wie es S5Andi schon andernorts beschrieben hat.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon userc23 » 01.05.2011, 21:46

@ S5andi:
Danke fuer die superschnelle Rueckmeldung! MD_Fast arbeitet mit CHDK-DE rev601 einwandfrei! =D>


@msl, gehtnix und chiptune:
Auch den Gurus selbstverstaendlich vielen Dank fuer die grossartige Arbeit hier!!
PowerShot SX200is 1.00d
CHDK-DE 1.1.0-637
userc23
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 5
Registriert: 01.05.2011, 00:37
Kamera(s): PowerShot SX200is 100d
CHDK-DE 1.1.0-637 24.04.11

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 01.05.2011, 22:32

moin,

wollte ich mir doch mal ein Ei kochen. Da versagt schon Eieruhr.bas mit den neuen Versionen!

Das liegt an CHDK, nicht am Skript. Da sind die Coder gefragt.

Mal so dahin gesagt, da werden noch einige Skripte nicht einwandfrei funktionieren.

gruss gehtnix Bild
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon msl » 01.05.2011, 22:49

Hallo,

mal so dahin gefragt, warum fällt das erst nach Wochen der Änderung auf? :shock:

Ich habe mich gerade aufklären lassen. Der "Stopp-Code" wurde schon vor längerer Zeit abgeschafft - warum auch immer. Das ganze ist mir beim Aktualisieren auch nicht aufgefallen, weil diese Änderung explizit nicht beschrieben wurde. Im Code selbst war es für mich nicht erkennbar - bin halt kein Programmierer.

Ich hoffe, ich konnte soweit überzeugen, dass der "Stopp-Code" allgemein wieder eingeführt wird. Sonst müssen wir auch hier einen eigenen (DE)Weg gehen.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4512
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 01.05.2011, 23:09

Hi,

mal so dahin geantwortet.

Man probiert ja nicht nach jedem Update alle Skripte durch!

Für mich stellt sich eher die Frage wie man so eine Funktion einfach stilllegen kann?

Das ist doch eine tief greifende Änderung in der Skript-Sprache, einfach so abstellen :roll: ohne Info dazu :roll:

Des g´hört sich nidda, des is net recht so :!:

gruss gehtnix Bild
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon CHDKLover » 02.05.2011, 10:51

Hallo,
das Problem sollte ab Revision 653 behoben sein.

CHDKLover
A610 100e CHDK-DE: aktuelle Version
Benutzeravatar
CHDKLover
Super-Mod
Super-Mod
 
Beiträge: 878
Bilder: 8
Registriert: 12.09.2007, 19:25
Wohnort: Dresden
Kamera(s): a610 100e

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 02.05.2011, 11:58

moin,

wunderbar, jetzt geht alles wieder wie gewohnt.

Danke

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon S5andi » 06.05.2011, 20:01

Hallo gehtnix,

hast du das ausprobiert, ob es jetzt geht?

Ich habe heute die Scripte MD-Fast und HDR-Hyper getestet. Hiert habe ich mit den neuen Version 653 und 655 immer noch Probleme, während beide Scripte mit der Version 601 funktionieren:

MD-FAST:
Automatische Schwellwertermittlung erfolgt, die Menüpunkte danach lassen sich auswählen und Script läuft. Wenn eine Bewegung erkannt wird, bleibt Kamera mit Rückschaubild (keine Kameraanzeigen, keine Maske etc.) stehen. Abbruch des Scriptes mit Auslöser möglich.

HDR-Hyper:
Menüpunkte lassen sich jetzt ändern. Es erfolgt nur keine Auslösung mit "halber Druck". Es scheint der Befehl "shoot_half" nicht zu funktionieren.
Abbruch des Scriptes mit Auslöser ebenfalls möglich.

@msl: habe die Fehlerbeschreibung nur in diesen Thread gepackt, wollte nicht doppelt posten. Ich hoffe das ist iO.

Grüße s5andi
S5 IS 1.01a + SX230HS 1.01e CHDK-DE: akt. Version
S5andi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 38
Registriert: 16.08.2008, 08:48

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 06.05.2011, 23:05

moin moin,

da war ich euphorisch zu schnell!

Die Set Taste ging und da war für mich der Kaas gespitzt. Aber ein shoot_half habe ich nicht gedrückt.

Mit REV660 geht wieder gar nichts und mit anderen Revisionen (653) konnte ich zwar den Customtimer ausschalten, oder eben SET, aber nicht wieder einschalten.
Da reagiert das wait_click wohl wieder nicht.

Hab mir jetzt auch eine 601 kompiliert und alles ist gut.

gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon msl » 07.05.2011, 08:46

gehtnix hat geschrieben:Hab mir jetzt auch eine 601 kompiliert und alles ist gut.
Das ist auch eine Lösung. Die hilft dir, bringt uns in der Fehleranalyse aber nicht so richtig weiter.

MD-Fast arbeitet bei mir mit der aktuellen Version(660), HDR-Hyper dagegen nur bedingt. Eine Analyse, wann genau unter welchen Bedingungen wait_click nicht funktioniert, wäre interessant. Da könnten viele mitwirken, die die Skripte benutzen. Es wäre auch interessant zu wissen, ob sich unterschiedliche Kamera-Modelle auch unterschiedlich verhalten.

Schönes Wochenende
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4512
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon S5andi » 07.05.2011, 11:36

Hallo zusammen,

ich habe noch mal ein paar Sachen ausprobiert, vielleicht hilft das den Fehler einzugrenzen:
verhalten gleich bei version 655 un 660

MD-FAST:
Der o.g. Fehler Wenn eine Bewegung erkannt wird, bleibt Kamera mit Rückschaubild (keine Kameraanzeigen, keine Maske etc.) stehen tritt nur auf, wenn der Parameter "review-Zeit" auf 0 gesetzt ist, bei 1 läuft es korrekt.

HDR-Hyper:
Den Custom-Timer und Hyperfokus kann ich aus- und anschalten, allerdings verschwindet das Menü nach ca. 2 sek ohne Bedienung. Es scheint die Endlosschleife verlassen zu werden. Monitor sieht aus wie vor dem Start des Scriptes.
Allerdings läuft das Script irgendwie, denn nach 2-maligem Druck auf Auslöser kommt die Meldung *** Unterbrochen***.
Nach dem erstmaligen Auslöserdruck keine Aktion der Kamera erkennbar

sind eigentlich die einzelnen ChDK-versionen zwischen 601 und 622 irgendwo als kompilierte Version vorhanden? Ich würde mich bereiterklären diese zu testen um den Fehler einzugrenzen.

Grüße S5Andi
S5 IS 1.01a + SX230HS 1.01e CHDK-DE: akt. Version
S5andi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 38
Registriert: 16.08.2008, 08:48

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 07.05.2011, 14:04

Mahlzeit,

ist mir schon klar dass mit rev601 der Fehler nicht gefunden wird!

Ich habe mir jetzt eine 660 gedreht, nur mit textreader, uBasic und lua. Nicht wegen der schlanken KB sondern um alle anderen möglichen Fehlerquellen wegzuschalten.

Kamera ein
HDR-Hyper start
half_shoot tot
shoot tot
shoot nach dem 2ten x funktioniert, Skript bricht ab

Skript neustart ohne Kamera aus
SET geht
Custom T aus/ein geht
half_shoot tot

und nun geht auch SET nicht mehr!

Da scheint shoot_half und shoot auch fehlerbehaftet zu sein.

Noch folgende Überlegung
    Die Shell standardmäßig mit den oben drei genannten Optionen einzustellen - die Power-User müssen halt dann Optionen zuschalten. Um die etwaigen neuen Fehler eben gleich auf diesen Kreis einzuschränken
    Bei dem Dateinamen CHDK-DE-a610-100e-S-rev660.zip, dies 1.1.0 wegzulassen und S für "Standard" - eben diese 3 Standard-Optionen, und ein O für weitere zugeschaltete Funktionen zu verwenden.
    Auch wäre es doch gegeben den Standard vom Download "a610-100e-" so (oder ähnlich) abzuändern "a610-100e-rev660-D-S-rev660.zip

da muss man aber schon geschmeidig bleiben

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

VorherigeNächste

Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron