[uBasic] MD_FAST - Schnelle Bewegungserkennung

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon reyalp » 14.05.2011, 07:32

S5andi hat geschrieben:MD-FAST:
Der o.g. Fehler Wenn eine Bewegung erkannt wird, bleibt Kamera mit Rückschaubild (keine Kameraanzeigen, keine Maske etc.) stehen tritt nur auf, wenn der Parameter "review-Zeit" auf 0 gesetzt ist, bei 1 läuft es korrekt.

This makes perfect sense, http://tools.assembla.com/chdkde/changeset/653 makes makes any delay of zero to indefinite. That means sleep(0) sleeps forever.

In international changeset 1185 and chdkde changeset 661 I've made it so only wait_click uses 0 for indefinite wait.

I don't think there are any other functions that should wait forever on zero.

It's possible that other scripts which calculate a sleep time or take sleep time from menu settings had the same problem. I haven't tried HDR-Hyper yet.

edit:
I think HDR-hyper can have the same problem, there's lots of sleep <variable>
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 19
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon msl » 14.05.2011, 13:48

Thanks reyalp - great job. =D>

Now all scripts works fine with the recent CHDK-DE version.



Nun sollte wieder alles richtig funktionieren. Meine Tests waren jedenfalls erfolgreich.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4512
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon S5andi » 14.05.2011, 13:54

Hallo,

kann ich bestätigen. Die von mir beschriebenen Fehler in MD_Fast und HDR_Hyper sind nicht mehr vorhanden.
Danke an alle.

Grüße
S5Andi
S5 IS 1.01a + SX230HS 1.01e CHDK-DE: akt. Version
S5andi
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 38
Registriert: 16.08.2008, 08:48

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 14.05.2011, 14:08

moin,

selbst die Eieruhr funktioniert wieder!
Betraf alle Skripte in denen "wait_click" ohne Zeitangabe auftrat.

Tanks to reyalp


gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon tripod » 18.07.2011, 16:21

Hallo zusammen,

ich habe mir die SX 230 gekauft und verfolge die Entwicklung des CHDK für diese Kamera mit interesse. Die zweite Beta aus dem Entwicklertread läuft so weit auch ganz gut bei mit. Leider habe ich es bisher noch nicht hin bekommen mehr als ein Foto mit MF_FAST ohne Eingriff zu machen. Wenn ich MD_Fast starte misst die Kamera irgend etwas ein, danach bestätige ich die ermittelten Werte mit der "runter" Taste. Wenn sich jetzt etwas im Bild bewegt wird auch ein Foto gemacht (auf Wunsch sogar als DNG RAW) und der Aufnahmezähler hoch gezählt. Danach wird aber, trotz Bewegungen kein weiteres Foto aufgenommen. Erst wenn ich zwei mal die ALT Taste (DISP. + FUNC.) gedrückt habe wird bei eine Bewegung wieder ein weiteres Foto gemacht und der Aufnahmezähler hoch gezählt, jetzt also auf zwei. Ist dieses so richtig? Ich habe es so verstanden, das die Kamera solange Fotos macht wie sich etwas im Bild bewegt und die Aktivierungszeit nicht abgelaufen ist bzw. der Akku nicht leer ist.

gruß tripod
tripod
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 18.07.2011, 16:00
Kamera(s): Canon Powershoot SX 230 HS Firmware GMC 1.00C

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 20.07.2011, 01:41

moin,

erscheinen denn nach dem ersten Foto diese Rahmen auf dem LCD?

Probier doch mal MD-Six mit den Standard-Einstellungen aus.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon tripod » 20.07.2011, 10:22

Hallo,

nach dem ersten Foto erscheint der "normale" Rahmen von der Orginal Firmware auf dem Bildschirm, Die drei Rahmen von MD sind dann nicht mehr zu sehen, erst wenn ich den ALT Modus deaktiviere und wieder aktiviere (2x <DISP.>+<FUNC.>) erscheinen wieder die MD Rahmen und es wird bei erneuter Erkennung von Bewegungen ein Foto gemacht.

Wenn ich MD-Six runterlade und ohne etwas an den Parametern zu ändern starte erscheint zwar
***** GESTARTET *****
Beenden: Auslöser drücken
LCD aus nach 3 Bildern
MD-SIX"

aber dann passiert gar nichts mehr. Ich habe sogar versucht die Kamera von einem dunklen Objekt auf ein Helles Fenster zu schwenken (schnell und langsam) aber es passiert rein gar nichts.

Gruß tripod
tripod
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 18.07.2011, 16:00
Kamera(s): Canon Powershoot SX 230 HS Firmware GMC 1.00C

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon gehtnix » 20.07.2011, 17:44

moin,

das hört sich schwer nach Beta-Stadium an.

SX220-User aufgemerkt! Gibt es da diese Fehlermeldung auch?

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon tripod » 01.09.2011, 14:05

Hallo,

ich habe es Gestern nochmal mit der Revision 786 versucht und nun klappt es. Jetzt kann ich ohne Eingriff mehrere Fotos mit dem MD_Fast script machen.

Gruß

tripot
tripod
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 7
Registriert: 18.07.2011, 16:00
Kamera(s): Canon Powershoot SX 230 HS Firmware GMC 1.00C

anfängerfrage zu md_fast einstellung

Beitragvon Fusselfan » 23.02.2012, 15:25

Hallo, ich bin recht neu hier und hab auch schon eine frage.

ich habe mir md_fast (automatischer fokus) auf die speicherkarte gezogen. die cam zeigt mir auch alles ganz toll an. aber irgendwie hab ich nen knoten hinter der stirn was die einstellungen an gehen.
ich habe vor mir eine glasschale mit wasser aufgebaut, einen kontrastreichen hintergrund gewählt und einen "tropfenmacher" besorgt.
nu sitze ich hinter der cam und tropfe wie doof, nur passiert nichts.
welche einstellungen sind denn falsch?
startstunde -1
startminute -1
endstunde -1
endminute 5
anzahl spalten 1
anzahl zeilen 4
vergleichsintervall ms 10
schnellwert 22
maske 1
linke spalte 1
obere zeile 1
rechte spalte 1
untere zeile 1
pixel step) 6
reviewzeit sek. 0
autoschweller 1


ich hoffe ihr könnt mir diese anfängerfrage verzeihen und mir auf die sprünge helfen. welche einstellung muß ich ändern damit ich den tropfen fotografieren kann?

viele grüße Fusselfan
Fusselfan
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 1
Registriert: 22.02.2012, 16:37
Kamera(s): Canon PS SX1IS

Re: anfängerfrage zu md_fast einstellung

Beitragvon gehtnix » 24.02.2012, 01:46

Hi Fusselfan,

sei hier doch zunächst mal gegrüßt.

Fusselfan hat geschrieben:nu sitze ich hinter der cam und tropfe wie doof, nur passiert nichts.
Da hoffe ich, du hast mittlerweile deine undichte Stelle gefunden.

Fusselfan hat geschrieben:...welche einstellung muß ich ändern damit ich den tropfen fotografieren kann?
Zunächst musst du mal deine eigene Einstellung ändern!
Als Neuling willst du gleich mit einer sehr komplexen Aufgabe loslegen.
Versuche es doch mal erst mit einfachen Bewegungsauslösungen so dass du ein gewisses Gefühl für die wichtigen Parameter bekommst.

Des weiteren ist es fast unmöglich Empfehlungen aus der Ferne zu geben weil man deinen Aufbau nicht kennt.

Schau dir mal das PDF zu MD-SIX an, da habe ich einiges erklärt.
Ich würde die prüfende Zelle kleiner machen, also Zeile und Spalte erhöhen und die Maske kleiner machen.
Dann auf Serienbilder einstellen. Dann wird gleich eine Foto-Reihe gemacht.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon Pier » 24.02.2012, 16:40

Ich weiß nicht, ob es helfen wird, aber in vielen anderen MD Scripten autoschweller 1 bedeutet
autocalibrierung und kein Aufnahme.Es muss ein anderer Parameter in der Script, der Fotos erlaubt sein.
z.B. autoschweller 0 , oder wenn z.B w=0 Aufnahme w=1 autoschweller
bitte entschuldigen Sie mein schlechtes Deutsch.
Benutzeravatar
Pier
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 25
Registriert: 21.02.2012, 15:03
Kamera(s): SX130IS 101c

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon Christian72D » 24.06.2012, 07:26

Ich habe gerade festgestellt daß mir MD_FAST immer meine Beleichtungszeit umstellt.
Bei uns bauen gerade Rotkehlchen ihr Nest und das wollte ich fotografieren (lassen).

Die Fotos von gestern sind alle verschwommen weil ich nicht drauf geachtet habe daß mir das Script (ich weiß nur nicht an welcher Stelle) meine im Tv Modus eingestellte Belichtungszeit von 1/1000 automatisch beim Start auf 1/25 setzt.

Wie/wo kann ich das ändern?
Canon PowerShot SX50HS 1.00B
Canon PowerShot SX270HS 1.01B
Benutzeravatar
Christian72D
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 81
Registriert: 01.10.2010, 12:55
Kamera(s): PowerShot SX110IS

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon Dini » 18.07.2012, 14:47

Hallo Leute,

seit kurzem habe ich die Canon IXIUS 230 HS und bin total begeister was man mit CHDK alles so machen kann.
Nun bin ich bei den "Blitzen" die ich gerne mal aufnehmen möchte.
Zuerst habe ich das Skript o. MF in die Kamera geladen.

MIT Auto.Schwellenwerteinstelung und ohne weiter Einstellungen zu verändern.
Tätigkeit der Kamera:
Die Kamera scheint diesen Schwellenwert zu ermitteln und zeigt mir danach mögliche Einstellungen der Kamera durch Hoch/Runter/Links/Rechts-Taste.
Runter=Weiter und diese Taste drücke ich dann und ab da passiert nichts mehr bzw. es werden keine Bilder aufgenommen wenn ich mit der Hand mal durch das Bild fahre.

OHNE Auto.Schwellenwerteinstelung und ohne weiter Einstellungen zu verändern.
Tätigkeit der Kamera:
Sie fängt sofort an Bilder zu schießen.

Ich bin sicher das ich was falsch mache da ich noch ein echter Newbie bin.

Wer kann mir weiter helfen bitte?

Danke
Dini
canon ixus230hs
Benutzeravatar
Dini
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 24
Registriert: 14.07.2012, 16:30
Kamera(s): Canon IXUS 230 HS 100e

Re: MD_FAST - Schnelle Bewegungserkennung

Beitragvon SteveMcKlick » 14.04.2014, 12:55

Hallo Freunde,
ich habe eine Canon IXUS 980 IS,
die hat wohl einen Digic 4 Prozessor.
Kann ich da diesen Skript generell vergessen,
oder kann es doch gehen?
Ich hab es mal probiert und es scheint zu gehen,
aber es sagt mir dass ich abschalten soll:
1) Blitz (gemacht -> ok)
2) Autofokus (gemacht -> ok)
3) Saftey Mf --> keine Ahnung wie ich das machen soll, bei der Ixus; weiss nicht mal was das ist.

Kann mir bei diesem Anfängerproblem jemand helfen?
Das wäre toll.

LG
Stefan
SteveMcKlick
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 05.10.2010, 08:41
Kamera(s): Canon Ixus 980 IS (2x)
Casio EX-F1 (leider noch ohne CasioHackDevelopmentKit)

VorherigeNächste

Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste