[uBasic] MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Re: MD_SLOW und IXUS75, einige Probleme gelöst

Beitragvon gehtnix » 13.01.2010, 23:36

Hi phcanon,

sei gegrüßt hier.

Neulinge gehen gerne hier vorbei.

Da chiptune seine Skripte vor der Fehlerbereinigung (hier & hier)
geschrieben hat, ist es denkbar, dass Du mit MD-Fast, MD-Tune die gleichen Probleme bekommst.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Beitragvon phcanon » 14.01.2010, 00:01

Hallo gehtnix,

danke für die sehr schnelle Antwort. (Habe diese Antwort fälschlicherweise auch noch an rudi gerichtet.)

Signatur habe ich schon angepasst. Ich hatte die Regeln anfangs mal gelesen.

Ich hatte im der Code Ecke unter Skript-Sammlung (getestet und allg. lauffähig) nachgeschaut.
Vielleicht sollten da die verbesserten/korrigierten Programme abgelegt werden.
Als Anfänger orientiert man sich sehr stark an diesen Beispielen.
Und man sucht dann leider die Fehler wie schon viele vor einem.

Wäre eine tolle Sache, am Datum sieht man dass die Skripte etwas älter sind aber man hofft dass Sie trotzdem problemlos laufen (geht ja auch meist so).

Ich hatte schon nach Stackoverflow ... usw gesucht aber wenn man nicht das richtige Schlüsselwort findet kommt man nicht weit. Danke für die Links.

Du weißt bestimmt schon im Schlaf wo was zu finden ist.

Gruss Peter
CHDK Einsteiger
IXUS 75 V 1.01B
IXUS 75 V 1.02A
phcanon
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 6
Registriert: 01.01.2010, 14:01
Wohnort: München

Beitragvon gehtnix » 14.01.2010, 00:19

phcanon hat geschrieben:Habe diese Antwort fälschlicherweise auch noch an rudi gerichtet
Und ich habe mich schon gewundert ;)

phcanon hat geschrieben:Wäre eine tolle Sache, am Datum sieht man dass die Skripts etwas älter sind aber man hofft dass Sie trotzdem problemlos laufen
Das Datum stand bis vor einiger Zeit sogar dabei. Da allgemein im Archiv nur Skripts erwähnt und verlinkt werden die laufen, spielt das Datum keine Rolle. Jetzt wäre chiptune am Zug um Deine Änderung in seinem Skript hochzuladen. Und schon stimmt es mit dem Link vom Archiv wieder.

phcanon hat geschrieben:Du weißt bestimmt schon im Schlaf wo was zu finden ist
Nee, so ist es nicht. Musste auch erst die Suche bemühen um an die Links zu gelangen.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon Ruscher » 31.07.2011, 14:54

Hallo alle zusammen, ich lese hier schon eine ganze Zeit mit und vesuche so, auf die Dinge die mir unklar sind, Antworten zu finden.
Trotz Suchfunktion gelingt mir das leider nicht immer. Also habe ich jetzt mal eine Frage zu den MD Scripten.

MD-SLOW soll ja den Autofokus mit benutzen können. Daher versuche ich dieses SCRIPT zu begreifen.

In der Anleitung steht, das es für die DICICIII Modelle gedacht ist und auf anderen Prozessoren nicht läuft.

Ist das immer noch so? Wie verhält es sich mit DIGIC IIII Kameras? Laut Canon und Wikipeter hat meine SX30 IS je so einen DIGIC IIII
Chip drinnen.

Hab ich mit dem Script eine Chance? Oder zerlegt sich die Kamara beim abarbeiten des Scriptes ? :)

Vielen Dank für euere Mühen und die zahlreichen Antworten

Ruscher
Gruß Ruscher Bild
Benutzeravatar
Ruscher
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 9
Registriert: 17.07.2011, 17:01
Kamera(s): Canon PowerShot SX30is V1.00n
CHDK-DE V1.1.0-709

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon gehtnix » 31.07.2011, 20:02

Herzlich Willkommen hier bei CHDK,

der Hinweis zu DIGIC II/III stammt aus grauen Vortagen. Da sollte ohne "Zerlegen" bei deiner Kamera funktionieren.

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon dapro » 22.10.2011, 09:14

Hallo,

ich habe ein kleines Problem, das Script startet bei mir ohne probleme, nur leider tut es nachdem es den Autoschwellwert hat nichts mehr, es bleibt nicht hängen sondern reagiert nicht auf bewegungen. Ich habe alle einstellungen auf Standart belassen, als Test habe ich den Autoschwellwert mal ausgeschaltet, aber auch dann tut sich bei den aufnahmen leider nichts. Ich hoffe ihr könnt mir bei der Fehlersuche helfen

Gruß
Tim
dapro
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 12
Registriert: 21.10.2011, 21:06
Wohnort: Bottrop, NRW
Kamera(s): Canon PowerShot A495
Canon PowerShot A490
Casio EX FC100

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon jürgen » 24.10.2011, 08:41

leider funkt das MD-Slow bei mir auch nicht. vl kann ja einer der profis helfen. (Powershot sx 120is)

mfg
jürgen
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 48
Registriert: 18.08.2011, 11:04
Kamera(s): powershot sx120is

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon msl » 24.10.2011, 10:22

Hallo,

das Skript wurde 2008 für die damalig aktuellen Kameras entworfen. Der Autor hat in diesem Skript kameraspezifische Variablen (Propertycases) zur Analyse des AF (Autofokus) verwendet. Diese Variablen haben sich bei neueren Kameras geändert oder sind so gar nicht mehr verfügbar. Deshalb kann es zu Problemen kommen.

Es müsste sich mal jemand finden, der diesen kameraabhängigen Teil anpasst. Dann wird dieses Skript auch mit aktuellen Kameras funktionieren.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4514
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon msl » 26.10.2011, 14:01

Hallo,

für wen auch immer, aber im Eröffnungsbeitrag habe eine neue Skript-Version MD_SLOW2 hinzugefügt. Diese sollte prinzipiell mit allen Kameras funktionieren. Allerdings muss man sich auch mal generell mit Bewegungserkennung beschäftigen, damit man die Einstellungen versteht.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4514
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon jürgen » 26.10.2011, 14:49

Hab das Script zwar noch nicht getestet, aber jetzt schon mal ein großes dankeschön. Du bist echt spitze.

Ps.: Erster Test erfolgreich
jürgen
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 48
Registriert: 18.08.2011, 11:04
Kamera(s): powershot sx120is

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon Dini » 20.07.2012, 10:04

Habe das mit MD Slow und MD Slow II ausprobiert;

und wie schon mit MD-Fast passiert bei meiner Kamera so gar nichts was mit Bewegung vor der Linse zu tun hat.

Hab schon eine echte Polka vor dem Objektiv hingelegt, aber ausgelöst hat da nichts. :-({|= Nur die Hexe hat mich dabei geschossen....*lach*

Naja so ganz stimmt das mit dem auslösen nicht. [-X Im Modus OHNE "Autoschwellwert" fängt sie an Bilder zu machen und hört gar nicht mehr auf. \:D/

Als Intervall-Skript also durchaus zu empfehlen. =D>

Woran das nun alles liegt? Keiiiiine Ahnung! Ich habe mir hier die letzten Tage (und Nächte) die Augen wund gelesen und probiert ohne Ende und bin auf keinen grünen Zweig gekommen. :-k

"Ich weiß nicht, ich weiß einfach nicht" (Zitat: James T.Kirk-USS-Enterprise)

EDIT zu -von msl » 20.07.2012, 12:41
Mache ich sofort. Danke. :D
Zuletzt geändert von Dini am 20.07.2012, 12:11, insgesamt 1-mal geändert.
canon ixus230hs
Benutzeravatar
Dini
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 24
Registriert: 14.07.2012, 15:30
Kamera(s): Canon IXUS 230 HS 100e

Re: MD_SLOW - Bewegungserkennung mit sicherem AutoFokus

Beitragvon msl » 20.07.2012, 11:41

Hallo,

es macht wenig Sinn, hier in jedem Thema zu einem Skript mit Bewegungserkennung mitzuteilen, dass es nicht funktioniert. Offensichtlich scheint es ja ein kameraspezifisches Problem zu sein. Demzufolge wäre ein neues Thema im entsprechenden Kamera-Unterforum sinnvoll, z.B. "Ixus230 - Probleme mit der Bewegungserkennung".

Dann könnte man der Sache mit einfachen Testskripten auf den Grund kommen.

Wichtig ist u.a. auch die Angabe der verwendeten CHDK-Version und der Kamera-Firmware-Version. Wir sollten erst mal herausfinden, ob die Bewegungserkennung bei der Ixus230 überhaupt funktioniert, und wenn ja, ob es Probleme mit dem Shoot-Befehl gibt.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4514
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Vorherige

Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste