[uBasic] Sevenup - Update - X

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Re: Sevenup - Update - X

Beitragvon erfi00 » 05.03.2013, 21:17

Meiner Meinung kann man das nur einstellen bei Wechsel in den Wiedergabemodus.
Die Kamera geht aber nicht während der Intervallaufnahme in den Wiedegabemodus..., darf sie auch nicht, sonst stimmen beim Folgefoto die Brennweite usw. nicht...
erfi00
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 121
Registriert: 18.03.2012, 13:48
Kamera(s): Canon Power Shot SX230HS (100c)

Sevenup - Intervall mit Canon a2300

Beitragvon California_t2 » 11.03.2013, 13:27

Hallo

Habe mir letzte Woche eine Canon A2300 gekauft und möchte damit in regelmäßigen Abständen Bilder eines Gebietes (im Gebirge) machen.
Nun habe ich mir das Skript Sevenup - Intervall heruntergeladen. Super Sache!

Leider habe ich ein Problem mit dem Nachtfaktor! Die Kamera sollte in der Nacht (ca. 20:00 bis 06:00) keine Fotos macht. Ich habe also den Nachtfaktor = 0 gesetzt (Wie in der Beschreibung).

Lieder reagiert die Kamera nicht auf diese Skriptzeilen. Egal was ich bei der Nachtschaltung ändere (Beginn, Ende, Faktor) die Kamera läuft gleich weiter als ob es diese Funktion (Zeilen im Skript) nicht gäbe.

Hoffe ihr habt eine Lösung für mein Problem da die Kamera im Gelände aufgestellt wird kann ich nicht so oft die Speicherkarte leeren.

Schöne Grüße


Meine Einstellungen im Skript:

@title Sevenup
@param a Anzahl Bilder (Faktor 100)
@default a 100
@param b Anzahl Bilder (Faktor 10)
@default b 0
@param d Intervall (min)
@default d 30
@param e Intervall (sec)
@default e 0
@param f Bild-Kompression (0,1,2)
@default f 0
@param g Bild-Pixel (0,1,2,4,6,8)
@default g 1
@param i LCD aus nach x Bildern
@default i 2
@param o Sucherkamera 0=ja 1=nein
@default o 1
@param c Suchbereich von HYP in %
@default c 10
@param p Sleep f. Backlight (x10ms)
@default p 50
@param h Zoom 0=aus 1=ein
@default h 0
@param j AkkuStop bei mV
@default j 4560
@param m AkkuStop 0=aus 1=ein
@default m 0
@param q Bearbeitungszeit 1/100
@default q 6
@param x Start um x Uhr
@default x 12
@param y Start um x Minuten
@default y 30
@param w Start-Timer 0=aus 1=ein
@default w 0
@param v Nachtfaktor (Intervall x)
@default v 0
@param z Beginn Nachtfaktor (Std.)
@default z 20
@param n Ende Nachtfaktor (Std.)
@default n 6
@param r USB-Taster 0=aus 1=ein
@default r 0
@param l AF-Lock 0=aus 1=ein 2=Hyper
@default l 0
Zuletzt geändert von msl am 11.03.2013, 13:51, insgesamt 1-mal geändert.
Grund: edit by mod: Beitrag in bestehenden Thread verschoben.
California_t2
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 3
Registriert: 11.03.2013, 13:10
Kamera(s): Canon a2300

Re: Sevenup - Update - X

Beitragvon gehtnix » 12.03.2013, 00:53

Fantom hat geschrieben:weiss jemand wie ich es einstelle, dass das objektiv nach jedem foto einfährt?
Mal unabhängig ob das geht oder nicht geht, weiß ich jetzt auch nicht, aber da käme eine große Belastung auf die feinen Kunstoff-Zahnräder zu! Was sich nicht bewegt kann nicht Verschleißen. Alte Beamten Weisheit.

gruss gehtnix Bild

-- 12.03.2013, 00:59 --

California_t2 hat geschrieben:...Egal was ich bei der Nachtschaltung ändere (Beginn, Ende, Faktor) die Kamera läuft gleich weiter als ob es diese Funktion (Zeilen im Skript) nicht gäbe.
Habe ich soeben geprüft, nicht nur dass es diese Zeilen im Skript gibt, sie werden auch berücksichtigt, sprich die Kamera macht nix!

Mach mal folgendes:
- Das Skript zurück setzen auf Ursprungszustand
dann
- Nachfaktor auf 0

Die Uhrzeit deiner Kamera auf 21:55 stellen und nun diese 10 Fotos machen.
Ich habe das Skript vorhin um 22:13 abgebrochen und nur 5 Bilder auf der Karte gehabt.

gruss gehtnix Bild
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: Sevenup - Update - X

Beitragvon California_t2 » 15.03.2013, 19:58

Hallo gehtnix

Danke für die Antwort.
Habe deine Anweisungen ausprobiert und es hat funktioniert.

Danach habe ich es mit der Uhrzeit 13:00 bis 14:00 ausprobiert. Die Uhrzeit auf 12:50 gestellt und abgewartet. Dabei hat es wieder nicht geklappt.

Kann es sein dass der Wert der Startzeit (zb.: 22) für 22:00 Uhr größer sein muss als der Wert der Endzeit (zb.: 06) für 06:00 Uhr ??

Sg
California_t2
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 3
Registriert: 11.03.2013, 13:10
Kamera(s): Canon a2300

Re: Sevenup - Update - X

Beitragvon Tarribo » 20.03.2013, 00:28

Hallo, ich habe auch ein Problem mit Sevenup. Prinzipiell bin ich von dem Skript extrem begeistert. Allerdings möchte ich nun eine Langzeitbeobachtung über mehrere Tage machen (Baustelle). Ich wollte zwischen 6 und 18 Uhr aufnehmen und habe die Parameter (so dachte ich) entsprechend eingestellt (siehe unten) Die Kamera hat am ersten Tag auch brav bis 18:00 Uhr gearbeitet und am nächsten Morgen um 6:00 Uhr wieder angefangen. Aber dann hat sie um 8:28 Uhr einfach abgebrochen. Auf der Karte war noch jede Menge Platz. Das Objektiv ist auch nicht eingefahren. Vielleicht lags an der Kälte. Ich hatte zwar einen Wind-und Wetterschutz gebaut, aber wer weiß. Oder die Noname Karte ist unzuverlässig. Ich werde das Ganze auch noch mal mit Markenkarten wiederholen.
Ich wäre euch trotzdem dankbar, wenn ihr euch mal kurz meine Einstllungen anschauen könntet. Vielleicht liegt der Fehler ja zwischen den Ohren.

Viele Grüße

Tarribo

Meine Einstellungen im Skript:

@title Sevenup
@param a Anzahl Bilder (Faktor 100)
150
@param b Anzahl Bilder (Faktor 10)
1
@param d Intervall (min)
0
@param e Intervall (sec)
45
@param f Bild-Kompression (0,1,2)
0
@param g Bild-Pixel (0,1,2,4,6,8)
1
@param i LCD aus nach x Bildern
0
@param o Sucherkamera 0=ja 1=nein
1
@param c Suchbereich von HYP in %
10
@param p Sleep f. Backlight (x10ms)
50
@param h Zoom 0=aus 1=ein
0
@param j AkkuStop bei mV
4560
@param m AkkuStop 0=aus 1=ein
0
@param q Bearbeitungszeit 1/100
6
@param x Start um x Uhr
12
@param y Start um x Minuten
30
@param w Start-Timer 0=aus 1=ein
0
@param v Nachtfaktor (Intervall x)
0
@param z Beginn Nachtfaktor (Std.)
18
@param n Ende Nachtfaktor (Std.)
6
@param r USB-Taster 0=aus 1=ein
0
@param l AF-Lock 0=aus 1=ein 2=Hyper
0
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon gehtnix » 27.03.2013, 15:22

moin,

mir fällt auf, die Bildanzahl ist bei California_t2 und Tarribo "sehr hoch" eingestellt. Diesen Wert doch mal auf 10 oder 20 setzen. Sind dann doch immer noch 1000 oder 2000 Aufnahmen. Wenn das funktioniert kann man ja auf 50 erhöhen.

Mal ab hier lesen wie es bei normalzeit lief:
viewtopic.php?p=24716#p24716

gruss gehtnix Bild
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: Sevenup - Update - X

Beitragvon Tarribo » 27.03.2013, 21:59

Hallo Gehtnix,

danke für die Antwort. Ich habe jetzt mal eine SX20 IS genommen und da beteht das Problem ebenfalls. Die Kamera erwachte brav und pünktlich um 5:00 Uhr, machte aber nach zwei Bildern gar nichts mehr.Meine IXUS 220 HS war bei Abbruch immer "paralysiert" d.h. Objektiv noch ausgefahren, Kamera tot. Nur mit dem an/aus Knopf erwachte sie wieder. (Objektiv rein, dann wieder raus, Display an) Ich hatte schon gelesen, dass Gehtnix Probleme mit dem Start innerhalb der Unterrechungszeit hatte. Ich habe immer vorher gestartet.

Das merkwürdige ist, dass zumindest die IXUS mit 7upLight tadellos durchläuft. Aber Sevenup (mit der Abschaltung) ist irgendwie problematisch:-(

Ich versuche jetzt mal einen Durchlauf mit weniger Aufnahmen. Aber irgendwie glaube ich, dass das Problem woanders liegt. (Zumal ich auch schon über 10.000 Aufnahmen mit 7upLight hatte) Kann es sein, dass einige Wartezeiten im Skript für die IXUS zu kurz sind und es zu Konflikten zwischen Kamera und CHDK kommt? Oder gibt es noch einen anderen Ansatz?

Kann ich die Nachtabschaltung ohne Timerfunktion aus Sevenup in 7upLight kopieren? Und wenn ja, wo müsste die hin. Dann fielen der Start-Timer und der USB Taster als Fehlerquelle aus...

Etwas ratlos

Tarribo
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon gehtnix » 27.03.2013, 23:48

moin,

wenn 7upLight läuft, dann probiere gleiches mit Sevenup aber ohne Nachtschaltung.
Seltsam dass es nach dem Wecken für 2,5 Stunden läuft, später aber nach 2 Aufnahmen stehen bleibt.

Eine weitere Möglichkeit wäre:

- die sleep-Zeiten zu erhöhen.
- die Bildeinstellungen so belassen wie im Original-Skript

Am Sichersten ist es das Skript in Grundeinstellung zu setzen und von da die "neuen" Änderungen vorzunehmen.
Auf der Karte unter \CHDK\Data die Dateien Sevenup.* löschen.

Und die ganze Canon-Automatik-Gedöns abschalten > Skript.PDF lesen.

Auch ein bisschen ratlos.....


Gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: Sevenup - Update - X

Beitragvon Tarribo » 28.03.2013, 12:40

Hi Gehtnix,

vielen Dank für die schnelle Antwort. Ich werde die Karten mal formatieren und komplett neu bespielen. Und dann folge ich deinen Ratschlägen. Mal sehen, was draus wird. ich werde so oder so berichten. Immerhin muss man bedenken, dass wir derzeit noch nachts Minusgrade haben. Vielleicht war auch das das Problem. Oder die Noname-Karte hat gezickt. Ich ersetze sie jetzt durch eine Marken-Karte und starte dann Testläufe. ist ja Ostern und ich hab ein bisschen Zeit.

Was den Abbruch angeht, muss ich noch hinterher schicken, dass es bei unterschiedlichen Kameras passiert ist. Die IXUS hat nach 2,5 Std. aufgehört. Ich habe mir áber in der Bucht noch eine SX 20 IS gekauft (weil ich das Problem mit Zeitraffer UND der Belichtungszeit von max 1 Sek. -für Nachtaufnahmen zu kurz- nicht in den Griff bekam) Und die gute SX 20 hat nach dem Wecken dann nur noch zwei Bilder gemacht...

Dir aber erst mal ein dickes Kompliment und Dankeschön. Ist ja eher selten, dass jeand eine tolle Idee in die Tat umsetzt, das Ergebnis dann jedermann kostenlos zur Verfügung stellt UND sich danach auch noch mit den individuellen Problemchen der User beschäftigt.

DANKE!!!

Tarribo
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon Tarribo » 10.04.2013, 22:09

So, einige Tage und diverse Testläufe weiter, stehe ich immer noch vor einem Rätsel. Sevenup läuft einfach nicht stabil.
Ich habe die Karte formatiert, CHDK und Sevenup neu draufgespielt und die Kamera mit Nachtabschaltung 23 bis 0 programmiert, Intervall 5 Min 0 Sek. Sie hat das letzte Bild um 23:03 gemacht. Und das erste dann wieder um 0:03. Dann lief sie brav bis ich um 8:53 abgebrochen habe. Da dachte ich schon, alles sein fein. Dann habe ich sie von 21 bis 5 programmiert, Intervall 10 Sek. Sie ist brav um 21 Uhr schlafen gegangen und hat dann um 5 Uhr pünktlich wieder angefangen. Aber um 7:04 is sie nach insgesamt 1245 Bildern einfach still gestorben. Objektiv noch draußen, IXUS nicht mehr ansprechbar. Der Druck auf den On-Knopf bewirkte das Ein- und gleich wieder Ausfahren des Objektivs.
Die Kamera hing am externen Strom. Also kein schlapper Akku...
Dann habe ich die Kamera einfach mal drei Stunden vor Abschaltung laufen lassen, um den Sonnenuntergang aufzunehmen. Sie hat nach 85 Bildern einfach abgebrochen.
Heute habe ich das Skript auf die Standardwerte gesetzt und es mal so laufen lassen. Sie hat nach 27 Bildern abgebrochen.

Ich bin etwas ratlos. Die Ixus 220HS ist doch eine eher neue Kamera. Kann die zur Verarbeitung des Skriptes deutlich länger brauchen als andere? Reichen die Bearbeitungszeiten nicht? Ich hatte die Zeit im Skript von 6/100 bei zwei Durchläufen auf 10/100 hoch gesetzt. Das hatte aber keine durchschlagende Wirkung...

Ich würde gern die Teile des Skriptes, die ich nicht unbedingt brauche, weglassen. Das wären der Hyp Fokus, der USB Taster und, wenns sein muss, auch der Timer. Aber ich habe etwas Sorge, dass ich dabei zuviel/zuwenig weglösche und das Skript gar nciht mehr läuft. Kann mir jemand helfen? Hat jemand noch ne andere Idee?

Viele Grüße

Tarribo
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon msl » 11.04.2013, 21:46

Hallo,

wenn du auf den Timer verzichten kannst, dann nimm doch die Light-Version. Ich denke aber, dass damit das Problem nicht gelöst wird.

Das von dir beschriebene Phänomen tritt immer wieder bei diversen Kameras, insbesondere den Ixen, auf. Konkrete Erklärungen gibt es nicht.

Folgende Fragen könnten der Klärung dienen:

Welche Kameraeinstellungen benutzt du?
Sind Automatiken wie iContrast aktiv?
Sind Safety-Funktionen aktiv?
Wieviel Bilder befinden sich auf SD-Karte vor! Skriptstart?
Ist die SD-Karte fragmentiert?

Die Fragen haben folgenden Hintergrund. Verwende so wenig wie möglich automatische Funktionen. Die SD-Karte sollte möglichst leer sein.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4501
Bilder: 271
Registriert: 22.02.2008, 12:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Sevenup - Update - X

Beitragvon Tarribo » 13.04.2013, 19:50

Hallo msl,

7upLight läuft auf meiner IXUS problemlos. (Ich hatte bislang nur einen Ausfall bei extremen Minusgrade)

Ich würde aber gern Sevenup benutzen, weil ich die Nachtabschaltung genial finde. Dadurch lässt sich halt jede Menge Nachbearbeitung einsparen und die Laufzeit bis zum Speicherlimit der Karte deutlich verölängern. Klar, wem erzähl ich das. Deshalb dachte ich, eine Art 7upLight mit Nachtabschaltung ohne den Rest wäre so schlank, dass es vielleicht laufen würde.

Ich habe gerade noch mal geschaut. Alle Automatikfunktionen sind aus. Das Einzige was noch an war: Der Stromsparmodus mit Abschaltung nach x Minuten. Den hab ich jetzt auch deaktiviert. Die Kamera hängt ja eh am Netzteil.

Was genau meinst du mit Safety-Funktionen?

Ob die Karte fragmentiert ist, weiß ich nicht. Es ist sehr gut möglich. Ich hatte sie zwar vorher formatiert, aber vielleicht reicht das nicht? Beim ersten Durchlauf waren keine Fotos drauf. Danach dann halt schon.

Irgendwie etwas frustrierend. Da hat man ein geniales Skript und dann die "falsche" Kamera...

Ich werde noch mal schauen, ob eine neue, frische Karte Änderung bringt.

Oder kann ich noch etwas anderes versuchen?

Viele Grüße

Tarribo
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon theotrucker » 14.04.2013, 09:04

Hast du beim Formattieren das Häkelchen vor Schnellformatieren weggelassen?
Bei mir (SX20) macht das viel Unterschied!

Grüße Theo
theotrucker
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 27
Registriert: 02.03.2013, 18:01
Wohnort: Landgraaf, NL
Kamera(s): S1 IS, SX20 IS chdk sx20-102b-1.2.0-27xx immer neueste!

Re: Sevenup - Update - X

Beitragvon Tarribo » 15.04.2013, 11:22

Ich denke, ich habe die Karte vollständig und nicht nur schnellformatiert. Aber jetzt bin ich mir auf einmal nicht mehr so sicher :-)
Ich werds noch mal gründlich machen.
Übrigens hab ich in einer SX20 ein ähnliches Problem mit der Vollversion von Sevenup. Die Kamera bricht sogar noch viel früher ab. Läuft Sevenup auf deiner SX20 sauber?

Gruß Tarribo
2x IXUS 220 HS
CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0
Tarribo
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 37
Registriert: 24.03.2010, 00:38
Kamera(s): PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 101
PowerShot ELPH 300 HS / IXUS 220 HS / IXY 410F 100

CHDK-DE 100c-1.1.0
CHDK-DE 101e-1.1.0

Re: Sevenup - Update - X

Beitragvon gehtnix » 16.04.2013, 01:23

moin,

als mal hier ein 7upLight abgeändert zu 7upNIGHT.bas

Folgendes ist hinzugekommen
@param s Nacht Start
@default s 20
@param t Nacht Ende
@default t 7

und ab Zeile 134

rem Nachtschaltung immer aktiv!
rem Zum Testen kann (get_time 2) auf 1 geändert werden. Dann gelten Minuten!
do
sleep 10000
until (get_time 2)<=a and (get_time 2)>=b

Von mit heißer Nadel gestrickt. Mit den Minuten habe ich ausprobiert, da wurde ausgesetzt und dann ging es weiter.

gruss gehtnix Bild
Dateianhänge
7upNight.bas
(3.29 KiB) 132-mal heruntergeladen
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 13:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

VorherigeNächste

Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: Baidu [Spider] und 3 Gäste

cron