[uBasic] Sevenup - Update - X

CHDK-Skripte, CHDK-Entwicklung, PC-Zusatzprogramme, Informationen für Tüftler

Re: Sevenup - Update - IX

Beitragvon Christian72D » 07.08.2011, 14:48

Ich habe das Problem daß SevenUp nicht auf meiner SX30 läuft, nach dem ersten Bild hängt es sich immer auf.
Mit 7UpLight klappen die Aufnahmen, das Verhalten der Kamera ist aber trotzdem komisch.

Nach der zweiten Aufnahmne wird der Bildschirm ordnungsgemäss abgeschaltet, schaltet sich aber nach der dritten Aufnahme wieder ein.
Das ist ja nicht so schlimm, ich kann ja den Monitor einklappen, dann schaltet sich der Bildschirm ja sowieso ab.
*Nachtrag: Ich habe gerade folgenden Satz gelesen: "Neu- "Am Ende des Skriptes wird er wieder für die restlichen x Bilder angeschaltet.""
Damit hat sich dieser Punkt zumindest erledigt da ich es zum Testen auf den 10 eingestellten Bildern gelassen hatte.
Nachtrag Ende*

Und nach dem Beenden des Scripts ist die Kamera wieder im normalen Aufnahmemodus, und nicht im Alt-Modus.

Kann mir das jemand erklären?

Ich habe alle Parameter im Script so gelassen wie sie waren, die neuste CHDK-DE Version ist installiert, und die aktuellste Version von 7UpLight ist natürlich auch drauf.
Canon PowerShot SX50HS 1.00B
Canon PowerShot SX270HS 1.01B
Benutzeravatar
Christian72D
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 85
Registriert: 01.10.2010, 11:55
Kamera(s): PowerShot SX110IS

Re: Sevenup - Update - IX

Beitragvon msl » 07.08.2011, 15:53

Christian72D hat geschrieben:Und nach dem Beenden des Scripts ist die Kamera wieder im normalen Aufnahmemodus, und nicht im Alt-Modus.

Kann mir das jemand erklären?


Während das Skript läuft, befindet sich die Kamera im ALT-Modus. Ausführliche Informationen dazu gibt es im Handbuch. Das Skript ist durch einen entsprechenden Befehl in der Lage, diesen ALT-Modus bei Beendigung des Skriptes ohne dein Zutun zu verlassen.

Im Übrigen kann es durchaus möglich sein, das das Skript mit den Grundeinstellungen nicht wie gewünscht funktioniert. Da sich CHDK unter bestimmen Einstellungen Skripteinstellungen merkt, ist es manchmal hilfreich, unter CHDK/DATA auf der SD-Karte alles außer logo_de.data zu löschen. Man erkennt schon am Dateinamen die Zugehörigkeit der Daten zum Skript.

msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Sevenup - Update - IX

Beitragvon gehtnix » 07.08.2011, 16:23

Christian72D hat geschrieben:Kann mir das jemand erklären?
Aber logo ;)

Christian72D hat geschrieben:...das Verhalten der Kamera ist aber trotzdem komisch...
Komisch ist es nur wenn man nicht weiß was alles geschieht. Richtig ist dennoch das diese Infomation im PDF bisher gefehlt haben.

Habe folgendes zum PDF hinzugefügt:
Syntax: [ Download ] [ Verstecken ]
Benutze Text Syntax Highlighting
Das Skript verlässt am Ende der Session automatisch den ALT-Modus. Nach weiteren x Minuten, je nach eingestelltem Canon-Stromsparmodus, schaltet die Kamera komplett selber ab.
Neulinge sollte zunächst das Skript ohne Veränderung, Ausnahme ist lediglich die Option „Sucherkamera 0=ja 1=nein“ starten. Da werden 10 Bilder mit 10sek Intervall gemacht. Bild-Pixel/Kompression wird zudem verändert und wieder auf den Ausgang zurückgestellt. Nach dem 2ten Bild schaltet der Monitor ab und nach dem 8ten Bild wird der Monitor wieder zugeschaltet, bleibt also am Ende wieder an.
Erstellt in 0.000 Sekunden, mit GeSHi 1.0.8.9
So ist das nicht mehr so geheimnisvoll :lol:

Christian72D hat geschrieben:...nach dem ersten Bild hängt es sich immer auf...
Da steht eine Seite weiter oben ein verändertes Skript, probiere mal dieses.

gruss gehtnix Bild
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: Sevenup - Update - IX

Beitragvon Christian72D » 07.08.2011, 17:01

msl hat geschrieben:Im Übrigen kann es durchaus möglich sein, das das Skript mit den Grundeinstellungen nicht wie gewünscht funktioniert. Da sich CHDK unter bestimmen Einstellungen Skripteinstellungen merkt, ist es manchmal hilfreich, unter CHDK/DATA auf der SD-Karte alles außer logo_de.data zu löschen. Man erkennt schon am Dateinamen die Zugehörigkeit der Daten zum Skript.

Alles gelöscht, geht aber nach dem ersten Bild trotzdem sofort komplett aus.

-- 07.08.2011, 18:09 --

gehtnix hat geschrieben:Habe folgendes zum PDF hinzugefügt:
So ist das nicht mehr so geheimnisvoll :lol:

Ich kenne dein tolles Script schon was länger, diese Änderungen hatte ich nicht gesehen, sorry fürs NICHT Lesen. :(

gehtnix hat geschrieben:Da steht eine Seite weiter oben ein verändertes Skript, probiere mal dieses.

Werde ich gleich direkt mal Testen.
Canon PowerShot SX50HS 1.00B
Canon PowerShot SX270HS 1.01B
Benutzeravatar
Christian72D
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 85
Registriert: 01.10.2010, 11:55
Kamera(s): PowerShot SX110IS

Re: Sevenup - Update - IX

Beitragvon Tais » 08.08.2011, 01:14

Hallo Gehtnix und Team!

Mit dem neuen Skript funktioniert der Timer nun einwandfrei :D
Vielen Dank!!!

Viele Grüße
Tais
Tais
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 11
Registriert: 25.07.2011, 19:07
Kamera(s): Canon S95

Re: Sevenup - Update - IX

Beitragvon ingo3d » 10.08.2011, 09:02

Hallo Gehtnix,
dein Script funktioniert bei mir auch, löst aber nur alle 3sek.aus, obwohl ich 1sec. eingestellt habe.
Liegt wohl noch an den Einstellungen.
Da ich, wenn der SDM für meine Kameras fertig ist, vorhabe, 3D-Zeitrafferaufnahmen zu machen, viewtopic.php?f=17&t=2424 würde mich ein Script interessieren das beide Kameras synchron in kurzer Zeit (1sec.) auslöst. Ich hoffe du hilfst mir (Laien) dabei.

Gruß Ingo
ingo3d
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 15
Registriert: 05.08.2011, 20:53
Kamera(s): Ixus80, SX130, Fijifilm W3, Sony P200

Re: Sevenup - Update - IX

Beitragvon msl » 10.08.2011, 10:20

Hallo,

technisch bedingt (Verschlusszeit, Verarbeitungszeit) sind so kurze Zeitabstände nur bedingt möglich. Ein Blick in die technischen Daten deiner Kamera zeigt dir die Grenzwerte.

Mit etwas "Trickserei" haben wir hier schon Werte um eine Sekunde und darunter erreicht. Dabei muss man dann alle Einmessprozeduren deaktivieren und evt. auf den Serienbildmodus zurückgreifen. Es gibt dazu einige Beiträge im Forum. Musst mal suchen. Das ganze dann noch auf zwei Kameras zu synchronisieren, ist eher nicht machbar.

Realistische einstellbare Zeitabstände enden bei 2 - 3 Sekunden, je nach Kamera und Bedingungen.

Das alles gilt für CHDK. Wie es bei SDM aussieht, kann ich nicht sagen. Aber auch da gibt es Hardware-Grenzen.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Sevenup - Update - IX

Beitragvon ingo3d » 10.08.2011, 11:35

Wenn ich an der SX130 auf Serienauslösung schalte, dann macht sie etwa ein Bild in der Sekunde.
Das würde mir schon reichen. Ich muß mich mehr mehr mit den Scripten befassen, leider kenne ich mich nicht mit Programmierung aus.
Aber was hat Lenin gesagt: lernen, lernen nochmals lernen!

Gruß Ingo
ingo3d
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 15
Registriert: 05.08.2011, 20:53
Kamera(s): Ixus80, SX130, Fijifilm W3, Sony P200

Re: Sevenup - Update - IX

Beitragvon gehtnix » 11.08.2011, 21:12

moin,

das Skript und PDF habe ich aktualisiert.

Im Skript wird jetzt bei aktiviertem Start-Timer automatisch das "LCD aus" auf 0 Bilder gesetzt. Das sieht eh keiner, reine feinoptimierung.

Im PDF noch einen Hinweis, wird ja immer wieder überlesen :roll: , zu der wichtigen Suchereinstellung und zu dem kleinst möglichen Intervall von 0 sec. 0 sec bedeutet nun aber nicht 0 sec!
Mit 0 sec wird Bild auf Bild gemacht. Keine Wartezeit, kein Serienmodus!. Die Zeit von Bild zu Bild kann sogar geringfügig variieren! Das ist abhängig von Bildinhalt und Einstellungen der Kamera!

gruß gehtnix
Bild
Benutzeravatar
gehtnix
CHDK-Legende
CHDK-Legende
 
Beiträge: 2406
Bilder: 8
Registriert: 17.04.2008, 12:42
Wohnort: München
Kamera(s): A610 100e+f + IXUS50 101b

Re: Sevenup - Update - X

Beitragvon jürgen » 18.08.2011, 11:12

hey leute,

habe ein problem beim skript. Wollte gerade versuchen einen apfel aufzunehmen der von wespen gefressn wird.

Nur das skript schaltet das display nach den ersten zwei bildern nicht ab?
kamera läuft gerade

Einstellung sx120:
610 bilder
15 Sec
Bild-Pixel 4 (640x480)
lcd abschaltung 2 nach 2 bildern
K. mit Sucher 1 (bin mir nicht sicher)
Sleep f. Backlight (10-20)
AF-Lock (1)
jürgen
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 48
Registriert: 18.08.2011, 11:04
Kamera(s): powershot sx120is

Re: Sevenup - Update - X

Beitragvon msl » 18.08.2011, 11:26

Hallo und willkommen,

im Prinzip sind alle Einstellungen richtig. Wahrscheinlich ist aber das "Sleep f. Backlight" zu wenig. Versuche mal Werte Richtung 50.

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Re: Sevenup - Update - X

Beitragvon jürgen » 18.08.2011, 12:34

danke das wars. hoffentlich erhöht sich die akkuzeit.
jürgen
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 48
Registriert: 18.08.2011, 11:04
Kamera(s): powershot sx120is

Re: Sevenup - Update - X

Beitragvon Lena » 30.08.2011, 13:57

Hallo
aller Anfang ist bekanntlich schwer.

SX 220 HS FW 1.01b neueste CHDK vom 29.08.

Kameramodus Av
Mein Ziel vorerst:
a. - Intervallaufnahmen - zeitgesteuert
b. - Intervallaufnahmen sofort nach Anzahl
nach stundenlangem probieren mit b brach die Aufnahme nach einer stets variierende Anzahl ab - schwankend zwischen 33 und 645 ohne für mich erkennbare Systematik. Ich hatte fast schon die Vermutung eines thermischen Problems, weil die Temp bei Optical stets 37 Grad anzeigte.
Die Lösung kam aber mit Verz. nach shoot - den Wert auf 1 damit waren dann bei Intervall von 5 sec 1500 Aufnahmen möglich, - dann war der Akku leer.
also ok.
übrigens Temp nach 1500 pic - optical 39; CCD 40; battery 41 Grad C

dann gings an a, wobei es mir darauf ankommt, das LCD aus bleibt - zumindest bis zum Auslösezeitpunkt
Verz. nach shoot 1
sleep f. backlight auf mind 68
Bearbeitungszeit auf 6

damit bleibt der Bildschirm dunkel bis zur eingestellten Auslösezeit.

aber während der Aufnahmen - auch nach den eingestellten LCD aus 2 - geht der Bildschirm immer kurz an.
damit kann ich leben auch wenns anders schöner wäre.

übrigens habe ich sleep f. backlight mal auf 80 gesetzt, da mußte ich die Bearbeitungszeit auf 4 herunter setzen um den gleichen Effekt (LCD aus bis Auslösezeitpunkt) zu erzielen.

Ein Mengentest mit diesen Einstellungen also ca 1500 Bilder steht noch aus.
soweit erstmal auch als die viel geforderte Rückmeldung.
Gruß Lena
PS: Ein riesen Dankeschön an Entwickler dieser Möglichkeiten. Ich bin davon restlos begeistert
Benutzeravatar
Lena
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 3
Registriert: 21.08.2011, 06:52
Kamera(s): Powershot SX 220 HS FW 1.01b

Re: Sevenup - Update - X

Beitragvon buz » 12.10.2011, 13:09

Hallo,

ich hab in der Doku keine Information gefunden, ob man das Script (bzw. 7UpLight) mit der A495 verwenden kann.
Die A495 hat keinen manuellen Fokus. Bringt die Funktion AF-Lock dann überhaupt etwas? Sollte man den Fokus per ALT festlegen?

Beste Grüße, Uli
Benutzeravatar
buz
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 15
Registriert: 16.02.2011, 00:36
Kamera(s): A490

Re: Sevenup - Update - X

Beitragvon msl » 12.10.2011, 13:26

Hallo,

Sevenup/7uplight funktionieren prinzipiell auf allen CHDK-unterstützten Kameras.

AF-Lock hat nichts mit dem manuellen Fokus zu tun. Damit wird einfach nur der einmal festgestellte Fokuspunkt gespeichert (sprich eine Veränderung gesperrt). Das ist auch in der Bedienanleitung zu Deiner A490/495 nachzulesen (S. 74).

Gruß msl
■ "Hey you, don't tell me there's no hope at all. Together we stand, divided we fall."CHDK inside FAQCHDK-Neuigkeiten auf Twitter
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4540
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

VorherigeNächste

Zurück zu Code-Ecke

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron