G7 - Fehlermeldung bei Bewegungserkennung

G1, G2, G3, G4, G5, G6, G7, G9, G10, G11, G12, G15, G16, G1X, G3X, G5X, G7X, G9X

G7 - Fehlermeldung bei Bewegungserkennung

Beitragvon freiundgleich » 07.04.2009, 21:32

Wenn ich bei meiner Powershot G7 100i das Skript „Bewegungserkennung“ (Autor Johan Van Barel, 02-04-2008, in den beiden get_prop-Befehlen 206 durch 205 ersetzt) starte, erscheint die Fehlermeldung „BASIC:45 Unk stat“ (statt „stat“ möglicherweise auch „stmt“ oder „stnt“ - schwer lesbar).
Hat jemand eine Idee dazu?

Dietmar
freiundgleich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 08.03.2009, 23:20

Beitragvon msl » 07.04.2009, 21:56

Überprüfe noch einmal Deine Veränderungen zu den Propcase-Variablen. Hat sich da ein Tippfehler eingeschlichen? Die Fehlermeldung besagt, dass sich im Umfeld der Skriptzeile 45 ein unbekannter Befehl befindet. So etwas ist meist auf Syntaxfehler zurückzuführen.

Solltest Du den Fehler nicht finden, probier einfach ein anderes Skript zum Thema Bewegungserkennung aus.

Gruß msl
Benutzeravatar
msl
Super-Mod
Super-Mod
 
Beiträge: 4561
Bilder: 271
Registriert: 22.02.2008, 11:47
Wohnort: Leipzig
Kamera(s): A720 1.00c
SX220 1.01a

Beitragvon freiundgleich » 07.04.2009, 22:54

Liebe/r msl,

das war ja prompte Arbeit. Ich hatte tatsächlich einen Tippfehler gemacht, nämlich das Leerzeichen nach der 205 vergessen. Leider läuft das Skript trotzdem nicht (mit p, ohne p, mit 205 oder mit 206).
Deiner Antwort entnehme ich, dass beim Zeilenzählen die Leerzeilen weggelassen werden (sonst wäre ich nämlich bei der Zeile t=0 gelandet).
Dann werde ich mal andere Skripte ausprobieren ...

Auf jeden Fall herzlichen Dank!

Dietmar
freiundgleich
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 2
Registriert: 08.03.2009, 23:20


Zurück zu G-Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron