G11 startet nicht mehr

Fragen zur Bedienung und Funktionsweise des CHDKs
Forumsregeln
Überprüfe folgende Dinge:
Bist stets der Dokumentation gefolgt?
Hast du im Forum schon nach ähnlichen Problemen gesucht?
Hast du bei deiner Frage das Problem umfassend beschrieben?
Welche Kamera und CHDK-Version betrifft das Problem?

Probleme mit einem Skript sollten möglichst und wenn vorhanden in dem zugehörigen Thema zum Skript besprochen werden.

G11 startet nicht mehr

Beitragvon Peter11 » 23.02.2021, 14:02

Hallo,
nachdem meine G11 einige Jahre wg. Objektivschaden im Regal lag, habe ich nun ein Ersatzobjektiv eingebaut.
Die Reparatur war erfolgreich und die Kamera funktionierte wieder :-))
Damals hatte ich schon ChDK verwendet und wollte es auch wieder installieren. Aber da muß etwas schief gangen sein.
Wenn ich die Kamera über die Playback- oder die Power-Taste einschalte, geht sie nur kurz für ca. 2 Sekunden an und dann wieder aus.
Mit der Power-Taste fährt das Objektiv aus, dann Kamera aus. Beim 2. mal fahrt Objektiv wieder ein, dann schaltet sie wieder ab.
Aber die Kamera bleibt an, wenn ich vor den og. Tasten die FUNC-Taste betätige und festhalte und verhält sich dann scheinbar normal, bis ich eine Taste betätige.
Ich kann das CHDK-Menü starten und bedienen, wenn ich die Playback-Taste nach FUNC+Playback ein 2. mal betätige.
Es kommt die Fehlermeldung "Canon ROM corrupted fehlerhafte Chuncks ff810000".
PRIMARY.BIN ist vorhanden.
Beim ersten Versuch hatte ich die SD-Karte mit EOSCam präpariert. War das ein Fehler?
Firmware: GM1.00k

Peter
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon Caefix » 24.02.2021, 21:14

Willkommen im Forum, es geht heut worum? :o

Hmmm, die Kamera funktioniert [nur] ohne CHDK? :shock:

Bei EOS-Tool kann man zu wenig falsch machen, das eher nicht, Mac-Mecker auch nicht. :oops:

:idea: 0xff810000 ist die Startadresse des FW-Dumps. 8)
Im "Idealfall" hast Du die falsche Firmware Version erwischt. Da gibt es 100 f,h,j,k,l.
Exif-Tool-GUI oder CHIMP.exe helfen beim Setup.
Canon FW Update gibt es zur G11 nicht, eine PS.FI2, die man braucht, um CHDK per Firmware-Update im Wiedergabe Menü nachzuladen auch nicht... :cry:

Ist die Fehlermeldung weiss auf schwarz am unteren Rand (Canon) oder im "CHDK-LOOK" bunt :?:
Gleich nach dem ersten Booten nach dem Setup :!: erscheint üblicherweise ganz kurz ein Fensterchen während des Prüfsummenvergleichs. :!:

Dann könnte es ein derzeit extrem seltener "BIT-ROT-BUG" sein, darauf freut man sich im internationalen Forum ganz besonders. =D>
:arrow: https://chdk.fandom.com/wiki/Canon_Firmware_Corruption
Vermutlich braucht es dann für weitere Recherchen ein spezielles "Buildl" extra nur für Deine Kamera, um schrittweise voranzukommen.
Das wird spannend && 99%ig lustig... :^o
:leer: Wellcome to the forum :p :?:
:arrow: :arrow: :arrow: https://chdk.setepontos.com/index.php?t ... #msg143717

P.S.:
If they got a firmware dump after the error, please ask them to upload it somewhere.

https://chdk.setepontos.com/index.php?t ... #msg145221

P.P.S.: Wo Löten ist von Nöten, geh ich Flöten. ;)
Aufgeben würde ich die Kamera nach dem Aufwand jedenfalls erst recht nicht.
Die 8192kb.bin alleine mit 7-zip Kompression "Ultra" könntst Du auch 'im Forum' abladen, dann sehen wir weiter ...
EsGibtKeinenErdaufgangAufDemMond! SoSimpel...
Caefix
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 53
Registriert: 15.06.2018, 20:14
Kamera(s): Einige!

Re: G11 startet nicht mehr

Beitragvon Peter11 » 26.02.2021, 23:32

Hallo Caefix,
danke für Deine Antwort.

Hmmm, die Kamera funktioniert [nur] ohne CHDK?

Eben nicht. Ohne Chdk zeigt sie genau dasselbe Fehlerbild. So bald ich eine Taste drücke, geht sie wieder aus.
Durch das entfernen der Speicherbatterie geht sie beim Einschalten ([FUNC+PowerOn] zur Datumseinstellung. Dort kann ich mit dem Drehrad das Datum verstellen. Aber sobald ich eine Taste drücke, geht sie wieder aus.


Ist die Fehlermeldung weiss auf schwarz am unteren Rand (Canon) oder im "CHDK-LOOK" bunt

sieht aus wie von CHDK

Aufgeben würde ich die Kamera nach dem Aufwand jedenfalls erst recht nicht.

Na dann bin ich guter Hoffnung :-)

Die 8192kb.bin alleine mit 7-zip Kompression "Ultra" könntst Du auch 'im Forum' abladen, dann sehen wir weiter ...

s. Anhang.
.7z kann man nicht hochladen. Daher habe ich sie wieder in .BIN umbenannt. Ich hoffe das funzt?
Dateianhänge
PRIMARY.BIN
z-zip komprimierte Datei
(1.92 MiB) 55-mal heruntergeladen
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon reyalp » 27.02.2021, 00:57

Peter11 hat geschrieben:.7z kann man nicht hochladen. Daher habe ich sie wieder in .BIN umbenannt. Ich hoffe das funzt?


Ich spreche leider kein deutsch Bitte versuchen Sie es bei Bedarf mit Google Translate

Hi Peter,

Caefix mentioned your problem in the international forum: https://chdk.setepontos.com/index.php?t ... #msg145220

From the dump, it seems your camera's original firmware is damaged. This is probably a normal failure from age, not related to CHDK or EOScard.

It may be possible to make a special build of CHDK that will fix the damaged parts, but because there are so many changes, I think it's likely to fail again in the future.

Let me know if you want to try. It may take some time, and it's possible trying to fix it could make things worse. It's also possible the problem isn't really in the ROM and the corruption in the dump came from somewhere else. For example, if electronics on the mainboard are damaged.

Edit:
Another developer on the international forum thinks this isn't from age, because the bits have changed from 1 to 0. I believe this is probably correct https://chdk.setepontos.com/index.php?t ... #msg145228
Zuletzt geändert von reyalp am 27.02.2021, 19:46, insgesamt 1-mal geändert.
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon Caefix » 27.02.2021, 18:19

Das könnte zur Identifizierung der 1. Hürde auch interessant sein:
https://chdk.fandom.com/wiki/Canon_Basic/Card_Setup
https://chdk.fandom.com/wiki/Canon_Basic/Scripts/Romlog
Womöglich was mit AudioHandler, gibt´s noch schöne Töne :?:
EsGibtKeinenErdaufgangAufDemMond! SoSimpel...
Caefix
CHDK-Begeisterter
CHDK-Begeisterter
 
Beiträge: 53
Registriert: 15.06.2018, 20:14
Kamera(s): Einige!

Re: G11 startet nicht mehr

Beitragvon Peter11 » 01.03.2021, 12:02

Hi reyalp,

reyalp hat geschrieben:Let me know if you want to try. It may take some time, and it's possible trying to fix it could make things worse.

What do I have to lose now? :shock:
The last attempt before burial... Yes, with your help, I would try a rescue.

reyalp hat geschrieben: It's also possible the problem isn't really in the ROM and the corruption in the dump came from somewhere else. For example, if electronics on the mainboard are damaged.

I think that is unlikely. After installing the new lens the camera was ok. May be I did something wrong with the installation of CHDK.

Caefix hat geschrieben:Womöglich was mit AudioHandler, gibt´s noch schöne Töne

Nein es gibt keine Töne. / There are no sounds can be heard from the camera.
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon reyalp » 02.03.2021, 04:04

Peter11 hat geschrieben:Hi reyalp,
What do I have to lose now? :shock:
The last attempt before burial... Yes, with your help, I would try a rescue.

What I meant was the camera can currently still run CHDK code, so in principle, repair may be possible. If I make a mistake in the repair code, it could do more damage, so that's no longer possible. Of course, the camera is of little use if you don't try, so in that sense there's nothing to lose.

I'll try to come up with a CHDK build using the "cache hacks" method srsa_4c suggested on the international forum. This should be quite safe. It may be a few days before I have anything to post.

In the meantime, it would be helpful if you can get another dump of the ROM, to verify that the same defects are present each time. I expect this is true, but it would be good to be sure. You can just delete the PRIMARY.BIN from the card, and if CHDK doesn't show you the checksum error again, you can delete the .CFG files from the CHDK directory.

I think that is unlikely. After installing the new lens the camera was ok. May be I did something wrong with the installation of CHDK.

I think a mistake in CHDK installation is unlikely to cause this, but I don't have a good theory how it did happen. Possibly there's some clue in the specific addresses and values that changed.

Caefix hat geschrieben:Nein es gibt keine Töne. / There are no sounds can be heard from the camera.

One of the errors in the ROM is in code related to playing sound, so it's possible the crash happens when it attempts to play a sound in response to key presses. Turning off menu sounds might avoid that crash, but you likely can't get to that part of the menu without crashing. It could be possible from CHDK, but other areas of the ROM are damaged too.
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon Peter11 » 02.03.2021, 17:33

reyalp hat geschrieben:I'll try to come up with a CHDK build using the "cache hacks" method srsa_4c suggested on the international forum.

Do I still have to learn something for that? It's very special. I hope you will lead my hands if it comes to the showdown.

In the meantime, it would be helpful if you can get another dump of the ROM, to verify that the same defects are present each time. I expect this is true, but it would be good to be

I made the dump again. But compared to the other dump it's very different.
That's why i made another dump. This has fewer changes compared to its predecessor.
I remembered that i forgot to activate the SD write protector before starting.
In that case the following dump is much more different.
I do not understand the context.
Dateianhänge
PRIMARY.bin
(1.92 MiB) 47-mal heruntergeladen
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon reyalp » 02.03.2021, 19:57

Peter11 hat geschrieben:Do I still have to learn something for that? It's very special. I hope you will lead my hands if it comes to the showdown.

Nothing you need to do until I have a build for you to try, unless you want to try to code it yourself.

I made the dump again. But compared to the other dump it's very different.
That's why i made another dump. This has fewer changes compared to its predecessor.
I remembered that i forgot to activate the SD write protector before starting.
In that case the following dump is much more different.
I do not understand the context.

The differences are in the area where the camera stores settings, not in the firmware code, so it's normal for that area to change.

The code part of the ROM is identical to the one you posted before, with the same damage as we saw before. This is good.
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon reyalp » 08.03.2021, 03:21

Hi Peter

Here's a CHDK build that will hopefully avoid the problems. It uses "cache lockdown" to fix the damaged parts of the firmware, by locking corrected values in the CPU instruction and data caches.

This means is it is not a permanent fix, it will only be active when this specific CHDK build is loaded. However, it should be low risk, and I can test equivalent code on my cameras.

There is some chance the lock could be lost. If that happens, the build will display a message "PATCH FAIL" followed by a number in the upper left of the display. This could also happen if I made a mistake in the code. If you see it, please let me know.

I do not have a G11, so I have not tested this specific build, but I tested similar code on D10, which is a digic 4 with similar firmware.

I'm not sure how you originally installed CHDK, but if you have a card already bootable, you can just replace the files (both the DISKBOOT.BIN and everything in the CHDK folder). If your card was partitioned (for larger than 4GB) then the DISKBOOT.BIN must go on the small partition.

I have also attached the source code patch. It's just information for anyone interested, you do not need it unless you want to build CHDK from the source code.

Please let me know if it works, or if you have any questions.
Dateianhänge
peter-g11-100k-cache-patch-build-1.patch
(26.98 KiB) 46-mal heruntergeladen
g11-100k-1.6.0-5780-reyalp-peter-fix-1.zip
(766.68 KiB) 44-mal heruntergeladen
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon Peter11 » 09.03.2021, 09:08

Hello realp,
many thanks for your help! I am impressed about your system knowledge and I can imagine that it is very time-consuming

There is some chance the lock could be lost. If that happens, the build will display a message "PATCH FAIL" followed by a number in the upper left of the display.

Unfortunately it happened. I got "PATCH FAIL 300000dd"

Peter
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon reyalp » 09.03.2021, 09:37

Peter11 hat geschrieben:Unfortunately it happened. I got "PATCH FAIL 300000dd"

Do you see it as soon as the camera starts, or is there some delay?

I'll have to think about this, it may be a few days before I have time to work on it.
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon Peter11 » 09.03.2021, 12:24

There is no delay, can say it occurs immediately.

But alwaysI have to follow the start-up procedure:
Step 1: Press and hold <FUNC> and then <PLAY>. Camera starts into Setup for Time/Date
Step 2: Press <Play> again to start CHDK. Then i get the PATCH FAIL (without delay).
Peter11
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 8
Registriert: 23.02.2021, 13:10
Kamera(s): G11

Re: G11 startet nicht mehr

Beitragvon reyalp » 09.03.2021, 19:11

Peter11 hat geschrieben:There is no delay, can say it occurs immediately.

But alwaysI have to follow the start-up procedure:
Step 1: Press and hold <FUNC> and then <PLAY>. Camera starts into Setup for Time/Date
Step 2: Press <Play> again to start CHDK. Then i get the PATCH FAIL (without delay).

Thanks. I think I see why it happens now, it was a mistake on my part. I should have new build to test in a day or two.
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Re: G11 startet nicht mehr

Beitragvon reyalp » 13.03.2021, 09:14

Hi Peter,

Here's a new build to try.

I think I've understood the problem and made a better test on my camera, but mistakes are always possible. It should show the PATCH FAIL message like before if anything goes wrong.
Dateianhänge
peter-g11-100k-cache-patch-build-2.patch
(33.01 KiB) 42-mal heruntergeladen
g11-100k-1.6.0-5781-reyalp-peter-fix-2.zip
(767.12 KiB) 46-mal heruntergeladen
reyalp
CHDK-Einsteiger
CHDK-Einsteiger
 
Beiträge: 29
Registriert: 25.12.2010, 02:18
Kamera(s): a540 d10 sx160 elph130 g7x sx710 elph180 sx730

Nächste

Zurück zu Probleme

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast